Welcome! Log In Create A New Profile


software problem: target temperature not reached

Posted by mchahn 
software problem: target temperature not reached
June 12, 2019 06:01PM
I have a problem where the software sets the temp of the hot-end to about 10 degrees C below the target the g-code specifies. This is consistent when set to low or high temps. This is an image of a temp plot from octoprint.

I know the hardware is good because the head heats up to the wrong temp with a normal heating curve. The printer had no problems with the same firmware for weeks. This just started happening today.

I have tried ...
1) Using the front panel to test temp instead of g-code
2) Changing temperatures
3) Trying different PIDS including the auto-tuned ones
4) Rebooting printer between each test
5) reading the marlin configuration.h looking for clues

Anyone have any idea what might cause this?
Re: software problem: target temperature not reached
June 12, 2019 06:25PM
I fixed my problem by reloading the firmware. I should have tried this earlier but I didn't see how firmware could change.

Sorry for any trouble.
Re: software problem: target temperature not reached
June 14, 2019 12:31AM
Well it wasn't really fixed. It is happening again. I tried everything and then I just gave up and changed the marlin config temp window to +- 10 degrees so it works now staying 10 degrees below what the g-code requests. I set the temp in my slicer to 10 degrees more so it is at the right temp.

One of the more confusing problems I've had with any software. Maybe I'll do some marlin debugging and track down exactly where the problem is. Any suggestions on the best way to debug? Maybe print one-line output on the bottom of the screen?
Sorry, only registered users may post in this forum.

Click here to login