Welcome! Log In Create A New Profile

Advanced

Unable to compile Marlin 2.0.X if I enable EEPROM

Posted by Astr0kreep 
Unable to compile Marlin 2.0.X if I enable EEPROM
September 12, 2019 10:49AM
Hello everyone,

I'm pretty new to 3D printing and compiling the firmware. A few weeks ago I added a SKR1.1 board to my printer and for the most part, had a perfectly functional 3D printer until I added 3DTouch. I've noticed that I don't have EEPROM enabled so I cannot calibrate my auto bed leveling sensor correctly. None of the values stick because EEPROM is disabled.

Here's where it gets tricky if I enable/define EEPROM settings I cannot compile Marlin. It will fail every time. If I comment it out it works and I can compile. This is super frustrating (last 2 days have been a nightmare regarding setting up the auto leveling.).

I have uploaded an image of the error but I can upload more information and configs if needed.

Any Ideas?
Attachments:
open | download - Capture (1).PNG (18.7 KB)
Re: Unable to compile Marlin 2.0.X if I enable EEPROM
September 12, 2019 03:38PM
If you would upload your Marlin 2.0 to a file Share an post a link, I will take a look for you. As I have all my 3D Printers on Marlin 2.0.x


Electronics Technician / Computer Programmer
Re: Unable to compile Marlin 2.0.X if I enable EEPROM
September 12, 2019 03:52PM
Thanks Roberts_Clif!

I really appreciate the assistance. I've added a google drive link below. Zip file should be shared. Let me know if it doesn't allow you to download it.

Here's the link: [drive.google.com]
Re: Unable to compile Marlin 2.0.X if I enable EEPROM
September 13, 2019 10:12AM
Seems to be a bug

if you disable the following in Configuration_adv.h
#define BACKLASH_COMPENSATION

you can get around it.
Re: Unable to compile Marlin 2.0.X if I enable EEPROM
September 13, 2019 10:55AM
Hey Dust,

Thanks for the reply. I'm going to try that in a few minutes. Would you say its safe to report it as a bug on the github page?
Re: Unable to compile Marlin 2.0.X if I enable EEPROM
September 13, 2019 01:40PM
It worked! It compiled and flashed and EEPROM is active. Doing my first print in about 3 days now.
Sorry, only registered users may post in this forum.

Click here to login