Problem z axis
October 18, 2019 04:49PM
So I have a Monoprice mini v1. The mother board failed so I replaced it with a reprap RAMPS 1.4 board and Arduino Mega 2560 processor. I have compiled and loaded Marlin 1.1.9. The unit appears to home normally, but when I go to print a file the extruder hits the build plate. I was able to correct this by leveling the bed using a very thick piece of card board, but I don’t like the solution. Is there a way of fixing this using the Marlin software? Thanks.
Re: Problem z axis
October 26, 2019 05:41AM
I'm moving this to the Marlin subforums, because that's where it belongs smiling smiley (and you'll get more useful replies!).


http://www.marinusdebeer.nl/
Re: Problem z axis
October 26, 2019 08:41AM
How thick is the cardboard.

Yes you can set the Z-Offset using Marlin, depending on how thick the cardboard is.

On the LCD you can change the Z-Offset
Tune ("TAB Web Page Label")
[marlinfw.org]

From Marlin Firmware you can set Z-Offset
#define Z_PROBE_OFFSET_FROM_EXTRUDER -0.5 // Z offset: -below +above [the nozzle]

From your Slicer in Terminal mode you can Use
M851 Z offset //: XYZ Probe Offset - Marlin Firmware
__________________________________________
After setting the new Value for Z Offset always remember to Save the changes
Using the LCD "store settings"

From the Terminal mode
M500 // : Save Changes

Edited 4 time(s). Last edit at 10/26/2019 08:45AM by Roberts_Clif.


Electronics Technician / Computer Programmer
Re: Problem z axis
November 02, 2019 02:40PM
The cardboard is probably between 1 and 2 mm thick.

So from Marlin firmware I should set #define Z_PROBE_OFFSET_FROM_EXTRUDER somewhere between -1 and -2? Then recompile and load that? Right?
Re: Problem z axis
November 02, 2019 09:42PM
There are many ways to set the Z-Offset I have mine set at -0.5 though it has always been set there.
Could set it to 0 and adjust my mechanical Proximity Sensor slide mount adjustment of the Z- Axis to adjust for the difference.

I also use babysteps to quickly nudge the nozzle into place while printing a single lap Skirt, If I have not adjusted to the correct Z-Offset.

#define BABYSTEPPING

Edited 3 time(s). Last edit at 11/02/2019 09:43PM by Roberts_Clif.


Electronics Technician / Computer Programmer
Re: Problem z axis
November 10, 2019 03:31PM
So I opened up Marlin in Arduino set the z axis offset. Recompiled and loaded it. Now the last two items in the main menu are missing and I cannot print from an sd card. Any ideas?
Re: Problem z axis
November 10, 2019 04:18PM
Upload your Marlin to a share like Google Drive and post a link.


Electronics Technician / Computer Programmer
Re: Problem z axis
November 13, 2019 12:57PM
I did not know what else to do so I uploaded the entire set of files.

Here is the link [drive.google.com]
Re: Problem z axis
December 07, 2019 09:25PM
So after a long struggle to get Marlin BugFix1.1 compiled and running I am back to the previous issue. I have tried to change Z_PROBE_OFFSET_FROM_EXTRUDER to a number of values. It does not seem to change the position of the extruder relative to the build plate. It is still digging into the build plate no matter what settings I use for Z_PROBE_OFFSET_FROM_EXTRUDER.

It does not appear that I have any menu options on the LCD to change the Z offset.

I have been thinking the problem may be in the initial gcode. Here is that for the test print I am working with.

G21;(metric values)
G90;(absolute positioning)
M82;(set extruder to absolute mode)
M107;(start with the fan off)
G28;(Home the printer)
G92 E0;(Reset the extruder to 0)
G0 Z5 E5 F500;(Move up and prime the nozzle)
G0 X-1 Z0;(Move outside the printable area)
G1 Y60 E8 F500;(Draw a priming/wiping line to the rear)
G1 X-1;(Move a little closer to the print area)
G1 Y10 E16 F500;(draw more priming/wiping)
G1 E15 F250;(Small retract)
G92 E0;(Zero the extruder)

Another maybe unrelated problem is that the EEPROM setting in Marlin is V56 and the EEPROM I have on the printer is V55. Do you know how to fix that?

One thing that might be helpful is that the card board I mentioned at the top of this whole deal is 1.49 mm thick.
Re: Problem z axis
December 09, 2019 01:51PM
Quote
Rhartl
Another maybe unrelated problem is that the EEPROM setting in Marlin is V56 and the EEPROM I have on the printer is V55. Do you know how to fix that?

From terminal, execute:

M502
M500
M501

The "M502" will reset the EEPROM values to the defaults defined in your configuration files. The "M500" will store the new values to EEPROM. The "M501" will read the values back.

You should get into the habit of doing this every time you install new firmware.
Re: Problem z axis
December 14, 2019 09:41PM
Okay so now I have managed to manipulate the Z offset, but strange things are happening. When I use the M206 command to set the Z offset to -1.49 the echo in Pronterface shows that it is set to that. So I save it to EPROM with the M500 command. What I am seeing on the LCD Info Screen is that the Z is set to -2.98.

Also much of the X and Y axies are screwed up. Help...
Re: Problem z axis
December 15, 2019 02:55AM
M206 is persistent, from the description in the marlin site:
"The home offset is persistent — added to the current position until changed."

I think it means that the effect is cumulative.

I am not sure but isn't it better to use M851 Z-1.49
Or is that only for when homing with a probe?


http://www.marinusdebeer.nl/
Re: Problem z axis
December 15, 2019 10:45AM
So this is what I get when I try to use M851:

echo:Unknown command: "M851 Z-1.49"
Re: Problem z axis
April 22, 2020 12:39PM
I’m baaack. Sorry but I continue to have difficulty with this. It appears to me that there is no selection under tune to change the offsets. Changing the value of Z_PROBE_OFFSET_FROM_EXTRUDER I find negative values does not change things. Positive values Improve the issue but once I get to 3 I get tearing of the tape and no extrusion. Checking immediately after demonstrates normal extrusion. I have tried using M206 in both the Cura preprint routines and from eprom without success. Help...

Edited 1 time(s). Last edit at 04/22/2020 07:31PM by Rhartl.
Attachments:
open | download - 75DE2253-FB7C-423D-8E0E-1BD168C2136A.jpeg (23 KB)
Re: Problem z axis
April 22, 2020 08:58PM
Watch this video


Electronics Technician / Computer Programmer
Re: Problem z axis
April 22, 2020 10:41PM
So my auto homing leaves the extruder at x=0, y=0 , z=0. Manually centering the extruder in the center of the build plate and following instructions I finish with an offset of 0.3. My control menu looks like the attached picture. There does not seem to be a selection for Z Offset. I am using Marlin Version Bugfix 1.1.x.
Re: Problem z axis
April 23, 2020 10:03AM
Marlin 1.1.9BF
Click rotary button Select Control Click
Select Motion Click
Select Probe Z Offset Click
Change Offset Click

Return to Main LCD Menu
Click Select Control Click
Select Store Settings Click


Electronics Technician / Computer Programmer
Re: Problem z axis
April 23, 2020 10:39AM
I am having trouble attaching a photo of my menu, but these are the options under motion:
Velocity
Acceleration
Jerk
Steps/mm

No other options. No Probe Z Offset.
Re: Problem z axis
April 23, 2020 04:17PM
This is strange because I installed Marlin 1.1.9BF into a spare controller to find the LCD Menu to post for you.


Electronics Technician / Computer Programmer
Re: Problem z axis
April 23, 2020 04:32PM
I’ve downloaded version1.1.9 and version 2.0.5. I haven’t yet gone through the configuration files to set them up for my hardware, but I will if you think that will help. I should mention that I had problems with timing in relation to LCD with 1.1.x bf. People on this forum had me do some modifications of the code to make the LCD work. Might have affected the menus??
Re: Problem z axis
April 24, 2020 10:12AM
This is the modification I made for the display problem I had:

Its just problem of your display beeing to slow (lik mine), i added the ST7920_Delay setting, since that time its fine
#define REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER
#define ST7920_DELAY_1 DELAY_NS(63)
#define ST7920_DELAY_2 DELAY_NS(63)
#define ST7920_DELAY_3 DELAY_NS(63) // this is the defaults for a 16mhz processor (ie a mega2560)
Re: Problem z axis
May 06, 2020 01:26PM
So talked to Monoprice and they say that the mini has no Z probe. In which case how does manipulating the value of Z_PROBE_OFFSET_FROM_EXTRUDER change the height of the extruder above the bed? I am not trying to be sarcastic, I just would like to know how the firmware deal with the situation when there is no Z probe.
Re: Problem z axis
May 06, 2020 04:08PM
You need to remove ANY and ALL offsets in Marlin, slicer, g-code and eprom and make the proper mechanical adjustments to your machine.
Re: Problem z axis
May 06, 2020 06:54PM
Describe what you mean by “proper mechanical adjustments”.
Re: Problem z axis
May 08, 2020 12:51PM
I may have slightly misunderstood when reading this the first time but, I believe it sounds like you may still need to adjust your home position after you figure out the offset issue.
It seems you've been reading advice assuming you had a probe and your chasing your tail with offsets, I'd recommend starting with a clean pallet.

1: Comment out any instances of probe or auto bed level in Marlin. Fresh copy of Marlin is ideal.
2: Set all Marlin offsets to 0
3: Double check you aren't applying any offsets in the slicer, including start g-code

After that, home the z axis and level the bed. Be sure the z axis is at 0 when performing bed level. There is possibility z is driving up a few mm after homing and your leveling from the incorrect z height, double check to insure it's really ay 0.
Re: Problem z axis
May 16, 2020 12:10PM
I am not so sure I can eliminate offsets from Marlin. Is there a g code command that will tell me what the offsets are?
Re: Problem z axis
May 16, 2020 03:16PM
Well working some more with the initial gcode I find this: after leveling the bed using an index card as a spacer when I execute a G1 command moving the print head around on the build plate the head clears fine and the tape on the build plate is undamaged. When an extruder command is added to the G1 statement the nozzle hits the build plate. I am thinking this a hardware problem, but I am not sure how to proceed.
Re: Problem z axis
May 17, 2020 01:36PM
Quote
Rhartl
The cardboard is probably between 1 and 2 mm thick.

So from Marlin firmware I should set #define Z_PROBE_OFFSET_FROM_EXTRUDER somewhere between -1 and -2? Then recompile and load that? Right?

THERE is the problem!!
there are 2 offsets. THIS one is the distance laterally that the probe exists from the nozzle.
the offset you are looking for is addressing is the offset of the nozzle from the bed.
As mentioned, there are many ways to change the offset. Doing it in f/w is tedious. I set 0 in firmware and use my display to set it. I can then save it to EEPROM when I get it right.
The way I set it is to home Z. My home command raises to 20 when done. I then lower it till the paper sticks a little and observe the Z height on Repetier. Then I set the offset to that on the display and rehome Z. At that point the paper test should be good. If not, try again. When done M500 will save it.
The offset adjustment in ver 2 is under MAIN:CONFIGURATION menu item PROBE Z OFFSE: (the T gets cut off.) Adjusting that positive sets Z=0 away from the bed.
I stopped setting it in f/w but I think this is the item to do it in. I don't exactly remember, and the definition isn't exactly clear!!!!!
//#define HOTEND_OFFSET_Z { 0.0, 0.00 } // (mm) relative Z-offset for each nozzle. 0.10 would yield that distance AWAY from the bed. NOW there was an issue, and again my memory is weak, but one setting was opposite another and this one may need to be -0.10 to be away from the bed so if you use it, check it first.
Re: Problem z axis
May 17, 2020 04:14PM
So here is the deal. As far as I can tell there is nothing in the menus on the LCD that support adjusting the offsets. There is an item under prepare that says Set offsets. If I try that before homing it tells me I need to punch home. After that it says “Offsets saved”, with no opportunity to change the offsets. After starting a print if I press this selection I get “Err: Too far!”. I’m kind of stuck.
Re: Problem z axis
May 17, 2020 07:21PM
I am using 2.0.x bugfix. what are you using?
Sorry, only registered users may post in this forum.

Click here to login