Re: Problem z axis
May 17, 2020 07:22PM
upload your config files and/or anything else you may have changed
Re: Problem z axis
May 18, 2020 11:47AM
1.1.9. When I get back to the computer I have Arduino and the configuration files on I will send you the configuration files in another post. I should say that after messing around with it for several hours over the last two days. I went into the configuration file and eliminated EEPROM. It now works pretty well. Must be something there that is fouling things up.
Re: Problem z axis
May 19, 2020 05:33PM
This is everything I can remember editing.
Attachments:
open | download - Configuration.h (72.4 KB)
open | download - Configuration_adv.h (71.4 KB)
open | download - pins.h (29 KB)
Re: Problem z axis
May 19, 2020 05:52PM
To set the Z offset:
  • Turn off software end stops with "M211 S0"
  • Set the Z offset to 0 with "M851 Z0"
  • Home with "G28"
  • Using the LCD, jog the Z axis down slowly until the nozzle just grabs a piece of paper between it and the bed
  • Take note of the value shown for Z on the LCD. It should be negative (for example on my machine it's -1.15)
  • Set the Z offset using "M851 Z", for example "M851 Z-1.15"
  • Also set Z_PROBE_OFFSET_FROM_EXTRUDER in Configuration.h to the measured value:
    #define Z_PROBE_OFFSET_FROM_EXTRUDER -1.15

Edited 3 time(s). Last edit at 05/19/2020 05:55PM by MMcLure.
Re: Problem z axis
May 19, 2020 09:08PM
My system does not recognize M851.
Re: Problem z axis
May 19, 2020 09:37PM
So with a few tweaks to the above procedure I am printing again. Thank you to all for you kind indulgence.
Re: Problem z axis
May 20, 2020 11:41AM
Quote
Rhartl
So with a few tweaks to the above procedure I am printing again. Thank you to all for you kind indulgence.
Great!
here is a TIP
I would suggest flagging lines that you edit. I use //** or just add the ** to a comment. This way if you have to upload your files people can easily find what you edited and it makes it easier for you to find the items also. I also use double numbers so I can find info comments I enter or items I flag for future implementation etc.
Re: Problem z axis
May 20, 2020 11:52AM
Thanks for the tip. I will do that from now on.

I have been faked out again. When I compile and load Marlin the first print is great. Any subsequent prints the problem returns. Thoughts?
Re: Problem z axis
May 21, 2020 01:12PM
So I have followed the procedure from MMclure above. Because I cannot use M851 I use M206 to set the offset to 0. The result is an offset of -0.1. I applied that to the Z_PROBE_OFFSET_FROM_EXTRUDER and recompiled and loaded that to my machine. First print was perfect. Second print digs into the build plate. Is there any way of checking the value of the offset from maybe Pronterface?
Re: Problem z axis
May 21, 2020 03:56PM
Do you home Z with a probe or an end stop? M851 requires homing with a probe, I think.
Re: Problem z axis
May 21, 2020 05:08PM
Don’t have a probe. So must be an end stop home.
Re: Problem z axis
May 21, 2020 06:26PM
Quote
Rhartl
Z_PROBE_OFFSET_FROM_EXTRUDER

THIS NOT THE OFFSET YOU NEED!!!!!!!!!!!
Read previous post again.
The above is a LATERAL offset./////// probe here ...........nozzle here
This is the horizontal offset
//#define HOTEND_OFFSET_Z { 0.0, 0.00 } // (mm) relative Z-offset for each nozzle

Nozzle here
|
|
offset
|
|
bed here

When you change it you must do an M500 to save it

If you have a display you can change it via the display.

It sounds like you are:
1. setting the wrong item in firmware
2. setting the right item with M206
3. printing a good part
4. printing a bad part

between 3 & 4 the offset gets reset because you did not do M500.
And it doesn't get set to what you think it should be default because you set the wrong thing.
Re: Problem z axis
May 21, 2020 10:45PM
Okay. But well I think I was misled at the beginning of this saga. Here is a quote from an earlier post when I was asking how to set the z offset using Marlin:

“From Marlin Firmware you can set Z-Offset
#define Z_PROBE_OFFSET_FROM_EXTRUDER -0.5 // Z offset: -below +above [the nozzle]”

I gather this is not correct.

When you say:
“This is the horizontal offset.
//# define HOTEND_OFFSET_Z {0.0, 0.00} // (mm) relative Z offset for each nozzle.”

I’m confused. I would think that anything that applies to the Z axis would be vertical setting. Is that wrong?

I do have a display but the selections on my menu do not seem to be the same as other people have. Example I don’t have Set Z offset in my menus.

In the past whenever I tried to set the z offset with M206 for some reason the value of z on the information screen was doubled. The advice I got for that was to use M851 which my system does not recognize. I will try using M206 again with an appropriate z value and save it to eprom as you suggest. I will let you know.
Re: Problem z axis
May 22, 2020 09:42AM
I'm old, you are suppose to interpret what I write. Seems like you did. Yes. VERTICAL. Lateral and horizontal are the same thing.
You have to remember that developers are engineers and engineers can't communicate very well. I know, I am one.
I am not sure where this came from

#define Z_PROBE_OFFSET_FROM_EXTRUDER -0.5 // Z offset: -below +above [the nozzle]”

I have seen it and it is old. The latest 2.0 bugfix does not have it. Actually, I think they recently changed it within the last month.

the current definition is == spaces don't print well in forums:
=============================
* Z Probe to nozzle (X,Y) offset, relative to (0, 0).
*
* In the following example the X and Y offsets are both positive:
*
* #define NOZZLE_TO_PROBE_OFFSET { 10, 10, 0 }
*
* +-- BACK ---+
* | |
* L | (+) P | R <-- probe (20,20)
* E | | I
* F | (-) N (+) | G <-- nozzle (10,10)
* T | | H
* | (-) | T
* | |
* O-- FRONT --+
* (0,0)
*
* Specify a Probe position as { X, Y, Z }
*/
#define NOZZLE_TO_PROBE_OFFSET { 0, 0, 0 }
======================

The above numbers are mine because my probe IS the nozzle.
If you have say a BLTouch, the numbers represent the distances AWAY from the nozzle.


This is the NOZZLE to BED offset
//#define HOTEND_OFFSET_Z { 0.0, 0.00 } // (mm) relative Z-offset for each nozzle
this is for 2 extruders. If you use this the first number is for E0. I don't like the way this is setup, because it is obviously very confusing.
I also do not know why one is 1 digit and the other is 2 digit. That is another reason I don't use it.

My recommendation is not to set this VERTICAL offset in firmware. It is confusing. Instead set it on your display = unless you do not have one. You can also set it using M206. BUT you must make it permanent with an M500 or it will revert to firmware. You could set the firmware number to 5, then if you forget to M500 you will know because it will change to at 5.

Edited 2 time(s). Last edit at 05/22/2020 10:02AM by ruggb.
Re: Problem z axis
May 22, 2020 06:03PM
Well I am old too, and I understand. Thank you for the extended explanation of those values in firmware.

I am using version 1.1.9 of Marlin and the odd thing is thatI do not seem to have the menu items people refer to when they suggest that I use the LCD. So I’ve given up on that.

Focusing using M206 to set the offset, I get some very strange behavior from that command. If I change value of z offset by entering M206 Z-0.2, on the information display I see Z -0.4.
If I try a print with that setting Z on the info display has an initial value of -0.4 but when the print begins Z goes to 0.31 and the print head crashes into the build plate. If I look at the eprom file
The z offset is -0.2. Is my machine HAUNTED!!!!
Re: Problem z axis
May 22, 2020 08:44PM
I think it is sunspots. NOTHING seems to be working as it should lately.
I had and am having issues with Repetier Host displaying the correct Z height with offset.

If you home Z with no offset what is the Z distance indication and does it appear to be touching the bed?

If it is digging into the bed with a - offset, try a + one.
I have long been on ver 2 so I can't remember the details of v1.1.9
My offset is currently +0.2 so you may be going the wrong way.
Explanations in V1.1.9 on this topic were confusing to say the least and I struggled with it for a long time.
Re: Problem z axis
May 22, 2020 09:59PM
No, when I home the print head the interval between the bed and the nozzle is about the thickness of printer paper. From that position if I attempt a print it will dig into the tape.

Should I just not pay any attention to the values of z on the info screen? And keep feeding M206 values until things start to work?
Re: Problem z axis
May 23, 2020 08:41AM
OK, either you have a serious bed level issue OR your method of measuring the Z0 position is flawed OR your offset is set in the wrong direction. When you home Z, it is not positioned at the offset height. It does not go there until you issue a G0 Z0 command.
If your nozzle is at the correct level after a home Z then hits the bed I think your offset is in the wrong direction or you don't really need an offset.

The offset really is only needed if you are homing with a probe. If you are adjusting a mechanical endstop to obtain the clearance, then you do not need to set an offset. Maybe that is what you are doing. If so, set the offset to 0.

My nozzle is my probe and endstop. Therefore, I need an offset because I can't set the endstop to be anything else but on the bed.

The way I do it. I made a script in Repetier to home Z then move to Z0. With an offset set, I should get my paper under the nozzle. If not I increase my offset and retry. I also move it to a location other than X0 Y0.
So, first home all then run script which moves to x50, Y50, homes Z and moves to Z=0. Test with my paper and adjust offset as necessary. You will quickly see if you are setting the offset in the wrong direction.

The numbers on the screen may not be correct. Repetier has a problem with that and an offset until my first move command after home.

Edited 2 time(s). Last edit at 05/23/2020 08:45AM by ruggb.
Re: Problem z axis
May 23, 2020 09:39AM
So correct me if I am wrong here, but I see the Offset as a way to move the entire coordinate system used to position the extruder. So if I set the offset to z = n, when gcode positions the extruder at z=0 it is in reality at z = n. Is that right?
Re: Problem z axis
May 23, 2020 03:27PM
Yes, It is basically to compensate for probe hysteresis and trip position. IE, when my piezo nozzle probe activates, it does so when the nozzle hits the bed. I can't anticipate the bed as I can with a mechanical endstop. Therefore, I must have an offset so that when it hits the bed, Marlin declares that Z=0 is at Ztrip +- offset. My probe triggers at Z = -0.1 So, to get a 0.1 (paper thickness) clearance I must set the offset to 0.2
For BLTouch type probes, the offset is probably negative as normally they trip b4 the nozzle gets to the bed.
For mechanical probes, you do not need it since you adjust the position to stop b4 the nozzle hits the bed at your desired clearance.
You could do the same thing with a BLTouch, but it is a lot easier to set an offset in that case.

A piezo is very accurate and consistent. I get a std dev of about 0.002mm.
A BLTouch is no where near that good and a mechanical would be impossible to adjust to bed height and have it repeated.
Re: Problem z axis
May 23, 2020 08:20PM
So let me explain whats going on now that I have settled on the M206 command to set the offset value. After leveling the bed, I used Pronterface to send commands to the printer. Positive values only push the nozzle farther into the plate, negative values work. I test each setting for offset with an abbreviated gcode file that has the initial set of instructions for Cura files. It lays down a line of filament on the bed and primes the print head. I get this to work several times. Then I go to a gcode file for a part I want to print. This fails completely in that it does not adhere to the bed. So I stop the print and try again. This time it runs into the bed and tears the tape. I have executed the M500 command after each change of offset. Thoughts?
Re: Problem z axis
May 23, 2020 09:02PM
It is sounding like a mechanical issue. The gcode does not change. If it works once, it should always work the same way.

However, a Gcode file is a result of a previous slicer. No telling what the settings were on the slicer. Maybe you should try to reslice the model.

Edited 1 time(s). Last edit at 05/23/2020 09:05PM by ruggb.
Sorry, only registered users may post in this forum.

Click here to login