Welcome! Log In Create A New Profile


Auto bed leveling don't work in Marlin 1.1.9

Posted by [email protected] 
Auto bed leveling don't work in Marlin 1.1.9
October 23, 2019 05:12AM
Firmware Marlin 1.1.9.

After the commands



G0 z0

the nozzle does not reach the bed 4-5 mm.

I turn on the logging of the G29 command (M111 S32). At the end of the work gives

messages for linear and 3-point auto level

20: 21: 17.468: current_position = (200.00, 90.00, 15.35): G29 uncorrected XYZ

20: 21: 17.468: Z from Probe: 10.93 Matrix: 15.28 Discrepancy: -4.35

20: 21: 17.469: current_position = (199.99, 90.02, 10.93): G29 corrected XYZ

20: 21: 17.469: current_position = (199.99, 90.02, 10.93): clean_up_after_endstop_or_probe_move

or for bilinear auto level

20: 15: 32.184: G29 uncorrected Z: 15.41

20: 15: 32.184: corrected Z: 11.00

20: 15: 32.184: current_position = (190.00, 200.00, 11.00): clean_up_after_endstop_or_probe_move

After leveling real Z position changes to another. After moving nozzle to Z0, the nozzle does not coincide with the bed. Clearence between bed and nozzle is about 4-6mm.

Why is this happening and how to fix it?
Re: Auto bed leveling don't work in Marlin 1.1.9
October 23, 2019 01:49PM
It sounds like your Z_PROBE_OFFSET_FROM_EXTRUDER is wrong. Are you using the Z probe for homing (with Z_SAFE_HOMING)? If so:

  • Use "M851 Z0" to reset the Z offset.
  • Home the printer. Your LCD should show Z=0 at this point.
  • Execute "M121" to disable hardware endstops, and "M211 S0" to disable software endstops.
  • Jog the Z axis down with your LCD until the nozzle just grabs a piece of paper. The LCD should show Z as a negative number, for example Z=-2.1
  • Run "M851 Zwhatever you measured" - for the example above use "M851 Z-2.1"
  • Home the printer again. The nozzle should end up around 2mm above the bed (same as before) but the Z on the LCD should read the negative of whatever you set for M851 (for example Z=2.1)
  • Execute "G0 Z0" and the nozzle should just grab a piece of paper and the LCD should show Z=0
  • Save the value with M500, and copy it into your Configuration.h as Z_PROBE_OFFSET_FROM_EXTRUDER.

Only once you have your homing working correctly should you try to use bed leveling.

Edited 1 time(s). Last edit at 10/23/2019 03:04PM by MMcLure.
Sorry, only registered users may post in this forum.

Click here to login