Welcome! Log In Create A New Profile


Use E1 temp sensor pins for E0 temp readings "SOLVED"

Posted by deathguppie 
Use E1 temp sensor pins for E0 temp readings "SOLVED"
December 28, 2019 04:42PM
mks gen L v1.2 running 24v using 100k 3950 thermistors on both hotend and heatbed. Running marlin 1.1.9 firmware. PID is generated using m303 command.

Heat bed is working fine. I've used a handheld infrared sensor to check the temp on it and have good temperature readings both on the current 24v and the previous 12v.

Infrared sensor can't get a reading off the hotend as the area is too small and hard to get to while installed. (suppose I could pull it out but aarg.)

Hot end won't print PLA below 220 deg, and I get under extrusion at that temp. At 250, it sort of prints but top layers leave ragged gaps where they connect to the outside. At 260 it's better but now I'm just thinking this won't work. This problem is common among many types of PLA I've used and different thermistors/hotends. 12v and 24v. No it's not under extrusion. Tests show parts coming out a little fat if anything. There is no boiling or stringing even at 260 degrees, so it's got to be a temp issue.

What I'd like to try to do is use the thermistor input in the board for E1 as the temp reading for E0 but I cannot find anything on the web or in Configuration.h, or pins.h that make enough sense that I could do that. Does anyone know how or if this could be done?

Thanks in advance smiling smiley

Edited 1 time(s). Last edit at 12/28/2019 10:25PM by deathguppie.
Re: Use E1 temp sensor pins for E0 temp readings "SOLVED"
December 28, 2019 10:27PM
MKS Gen L uses pins_RAMPS.h to define pins. I switched them around. Didn't solve my problem but I did figure it out.
Sorry, only registered users may post in this forum.

Click here to login