Welcome! Log In Create A New Profile


Mariln firmware issue

Posted by kc8iqw 
Mariln firmware issue
April 13, 2020 01:31PM
I have been building a RAMP 1.6 system using Marlin 1.1.x-bugfix (which is 1.1.9 I believe) in an old 3D printer that had it's proprietary control board blow. For a while I've been trying to get it to print a 100mm cube without an odd layer 10-15 issue and then clears up to no avail so it's been sitting. I assumed it was mechanical and never got back into fixing it.

I've recently decided to try to print some face mask ear reliefs for our local hospitals, but the layer issue has turned into an offset issue. Regardless of the settings, layers 1-5 print near flawlessly but 6-10 are offset exactly 12mm . I would assume if it was a mechanical issue, it would vary on the layers affected, position on the bed, orientation, print speed etc.

I've looked at the gcode file with OctoPrint, Slic3r and Cura (which generated it) and none show the layer offset so I'm suspecting it's firmware, but WHY is the question. I saw a bug report on it in the Marlin bug tracker, but it was closed with no defined resolution that I could make out. I'm suspecting it's something specific with the DRV8825 drivers since some have the issue and other do not.

I'm running another test print with the pattern turned 90deg to see if the offset follows the axis or follow the pattern and changes to the X axis.

Any help would be greatly appreciated.
Re: Mariln firmware issue
April 14, 2020 01:58PM
I upgraded to the latest FW available, 2.0.5.x and the behavior has changed. Now layers 1-3 print fine and 4-10 are slightly offset but to only a minor degree. I printed 3 of the same on the same platter and all were offset exactly the same (about 2 or 3 mm)

I'm at a loss whether this is a hardware/driver/stepper issue as in it's missing steps or is this chaos being introduced from the slicer (Cura but not the latest as upgrading it is a pain)?
open | download - 20200414_134837.jpg (110 KB)
open | download - 20200414_134855.jpg (8.5 KB)
Re: Mariln firmware issue
April 20, 2020 01:04PM
I had a similar problem on my Geeetech I3 Pro C on one print job only.

It would print ok untill it reached a oparticular layer then it would shift by the same amount each time.

It was highy consistent and 100% reproducible but only for that print job (I was printing from the SDCard).

I tried a different "slicer" - it was the same shift but slightly higher up the work piece.

For me the answer was twofold - 1. Reduce the belt tension on the failing axis, and 2. Reduce the acceleration somewhat.

I suspect that at that layer of the print the slicer had issued a high acceleration command and the head couldnt keep up.

I had previously checked the stepper currents, the drive wheels, belts, idlers, bearings and rods to no avail.

Hope this helps
Re: Mariln firmware issue
April 23, 2020 05:28PM
I'd not thought of reducing the tension on the belts because tighter usually equals more precision.

I have acceleration disabled in Cura 4.5 and I've printed several test 100mm cubes at different speeds. It seems better a different speeds which again could be stepper driver optimization (I've swapped stepper drivers boards around and it stays with axis, not the board), stepper, some screwball mechanical issue or as another friend suggested, EMI. In the cube prints I'm having trouble discerning whether it's the X or Y axis causing the issue. "dents" on the back edge and front right as well at higher speeds.
Re: Mariln firmware issue
May 05, 2020 12:25PM
I, too, am having similar issues. However, depending upon yet-to-be-determined conditions, the problem has manifested itself in both X & Y directions, as well as in the Z axis. I have not tried to lower the belt tension, but it is probably a good idea. It goes along with my impression that the problem is that the motors cannot handle the sudden movement requested (I use slic3r), and that movement in one direction (for instance in the negative X, Y, or Z axes) is being hampered.

In my case, my carriage kept moving up away from the bed, until I realized that my double motors had become maligned, and the print carriage was no longer perpendicular to the two vertical screws. Realigning the horizontal carriage solved my Z problem, so it turned out to not be an issue with the firmware (I, too, had upgraded to 2.0.5.x).

However, I am still trying to determine the cause for the X and Y behavior. My prints keep moving across the bed because the motors are not moving the print head back towards the zero position.
Re: Mariln firmware issue
May 05, 2020 04:59PM
Dr. Dave
My prints keep moving across the bed because the motors are not moving the print head back towards the zero position.

Are you 100% certain you gear/teeth/belt ratio is right? That's my initial thinking (and I had that sort of issue) If it is it sounds more like the motors are missing steps for some reason (bad wiring, stepper driver etc), but the 2 could be intertwined. Might I ask what stepper motors you are using?

I've personally swapped from DRV8829s to A4988s with no effect, I switched to Repetier for a test, again no help. I can't replace/swap my stepper motors around unfortunately because, while I can likely remove the gear without damaging the motor, I don't believe I can push it back on a new motor without damage as I'm sure it takes some fancy contraption like it does to remove it.

I've added to the strangeness of my issue as well. The curve or dent starts after the slow layers and then curves back out about 5 layers later. After the 10 or 12 "curved" layers, it prints flawlessly and it's baffling as all crap. being micro-stepped 1/16th I would think the stepper would HAVE to be told to do it by the drivers/firmware.
Re: Mariln firmware issue
May 05, 2020 05:37PM


Are you 100% certain you gear/teeth/belt ratio is right?
Yes. This is a new problem which arose after I updated my Arduino build and the Marlin build. The output isn't slowly creeping across the plate, but it keeps moving right and backward. In fact, when I manually move the X or Y axis, the print head hangs in one direction, but moves OK in the other direction.


Might I ask what stepper motors you are using?
As best as I can determine, my motors are Kysan model 1024090. I've previously calibrated all the step values, and they should not have changed. I've also checked for loose wires and lowered the jerk, acceleration, and max velocity for the X & Y directions, too.
Re: Mariln firmware issue
May 17, 2020 10:26PM
it looks like it is losing steps and it occurs right after the top layer of the rest of it. Might have something to do with speed. Try slowing it down and see what changes. I had shift problems and installed flyback diodes on the axis steppers and it went away.
Re: Mariln firmware issue
May 18, 2020 11:01PM
I believe I have now solved my problem. I actually had a number of items which needed fixing.

For one, some of the screws holding my Z-axis lead screw in place were loose, so my z-axis was no longer aligned properly. Since I have two lead screws, this meant that the carriage was no longer horizontal, and it took more torque than usual to move the carriage. In fact, I was fooled into thinking that this was a velocity issue because when I lowered the z-velocity, the problem seemed to disappear. But, the fact that the carriage moved up at a different speed than it could move down led me to look at this.

In addition, one of the wires attached to my X-axis endstop had become loose. Because of the logic I was using, the machine thought it hit the endstop at random times during the print. This caused it to reset what it thought was the x-coordinate resulting in my print migrating.

Since I had lowered my accelerations and my velocities while trying to debug the issue, I am now working on readjusting these values back to their "best" values. Tom Sanlanderer (I think I got his name correct) has some good U-tubes on this process.
Sorry, only registered users may post in this forum.

Click here to login