Welcome! Log In Create A New Profile


Heating issues with Marlin

Posted by krawdawg15 
Heating issues with Marlin
May 02, 2020 11:27PM
I am working on installing a new BIQU MKS Base v1.6 mother board with chimera dual hotend in my Ender 3 which has gone well up until trying to tune the hot ends. So far, I have everything hooked up properly, and the thermal sensors are reading the hot end temperatures but when i go to tune the voltages, the opposite hot end, H1, heats as fast as possible and as hot as possible until Marlin kills the printer and stops everything (thank goodness for thermal runaway). During the test, H0 has a nice and smooth curve as it heats gradually but never gets close to calibrating thanks to H1 running away. I have looked at the settings but nothing jumps out as being the magic setting to stop this from happening. I have attached the configuration files for Marlin that I have uploaded to my printer to help. Would appreciate any feedback or settings that could help with the hot ends.

Motherboard: [www.amazon.com]

Hotend: [www.amazon.com]
open | download - Configuration.h (80.6 KB)
open | download - Configuration_adv.h (122.8 KB)
Re: Heating issues with Marlin
May 17, 2020 07:13PM
Made sure that the wiring was correct, and when I send a PID autotune to my E0 it heats as quickly and as high as possible. I usually shut it off when it hits 240 so that I can limit any damage it wants to try and inflict on itself. I am able to get the bed autotune PID command to work, but neither hot end behaves like I want it to. I have attached a screen shot showing the temperatures as I tried to autotune either hot end, as well as the logs. Configuration has not changed since the original post.
open | download - Screenshot from 2020-05-17 16-12-00.png (63.7 KB)
open | download - octoprint.log (12.9 KB)
Re: Heating issues with Marlin
May 20, 2020 11:07PM
Yep, looks like it is a runaway. The only strange thing I see is the thermistor selection of 6.
You must eliminate things so I would start by changing the thermistors to 1
If that does not help, disconnect E1 and see if you can tune E0 to get good numbers. Do the same thing for E1, then try that. Obviously, it should not heat E1 if the command is M303 C5 E0 S230.
It should also get limited at 260 per your setting. I don't have 2 extruders now so I can't try it, but it probably isn't a firmware issue.
Sorry, only registered users may post in this forum.

Click here to login