Welcome! Log In Create A New Profile


Octoprint bed heating kill called

Posted by BearcatTD 
Octoprint bed heating kill called
June 12, 2020 08:05AM
What is the problem?
Trying to print on my CR10v2 and SKR 1.4 Turbo. I have the bed temp set at 65, but it heats up to 55 and just stays there. Eventually I get this error: “Your printer’s firmware reported an error. Due to that OctoPrint will disconnect. Reported error: Heating failed, system stopped! Heater_ID: bed - Printer halted. kill() called!”

What did you already try to solve it?
I did a pid autotune and set the results Marlin and saved with an M500. I was able to start two prints…they failed but not because of the bed heating. Next time I tried a print, I got the error again.
These are essentially brand new heaters and thermistors. Thermistor connections are solid on both ends.

edit: I also replaced the existing bed thermistor with a brand new one. Same thing happened. I checked the connections mains to board and bed to board and they were both stout connections. Quit again at 55 degrees.


Additional information about your setup
OctoPi .17, OctoPrint 1.4, Raspberry Pi 3 B+, Creality CR-10 V2, SKR 1.4 Turbo with TMC 2208 drivers and a TFT35 v3 touch screen.

Thanks in advance for any help!

Re: Octoprint bed heating kill called
June 13, 2020 01:20AM
common causes include

power supply to weak to provide enough current
thermistor not secured to bed firmly.
No under bed insulation (so you just trying to heat the room)
Heated bed wires to thin.
bad heated bed connection somewhere... (broken wire?)

that fact that it gets to 55 and no more tells me it isn't any firmware issue.
Re: Octoprint bed heating kill called
June 13, 2020 09:28AM
Thanks Dust.

The thermistor is still attached to the to the center of the bed tightly held by the original tape. I had to pull up the thermal blanket to see this but everything got re-adhered quite well. Regarding the bed wires being too thin, they are the original that came on/with the machine. I will check the integrity of the wires from the board to the bed.
Re: Octoprint bed heating kill called
August 04, 2020 01:47AM
Did you get any fix for this issue?

I too have a similar error.

If I PID autotune the bed, it works great. Tunes up and down 8 times, spits out some settings. Gets to temp, its all good.

When I set to any temp, its 10C lower than set point.

It times out, and kicks the Octoprint error you reported.

Also same issue from touch screen set point or pronterface or anywhere. Doesn’t matter what’s telling it.

Bed is good. Wiring is good. Themistor is good.

All good. Seems like a setting in the firmware setting it to 10degrees cooler for some reason.

Also tried with and without a relay. But the thing is, it doesnt matter if i ask for 100C or 50C, its always 10C short. then times out waiting for the desired temp.

only thing I see with 10 as a setting relating to heat is: #define PID_FUNCTIONAL_RANGE 10, but the hot end works great?

Same setup by the way, SKR 1.4 turbo, TMC 2209's, TFT35 v3.......octopi, etc.

Thanks for any help you can provide.

Edited 3 time(s). Last edit at 08/04/2020 09:55PM by BgHurt.
Re: Octoprint bed heating kill called
August 05, 2020 03:06AM
OK, so i tried a ton of things, mostly doing a fresh marlin build only putting in board and TEMP_SENSOR s. Turns out I didn't understand how #define PID_FUNCTIONAL_RANGE works I guess.

It will basically ram up to the desires temp minus PID_FUNCTIONAL_RANGE, then start using the PID process.

So I guess that was working, as if i put it to 1, it ramps right up and works withing 1 degree.

Now I think the issue is the PID process is never getting me to temp though.

Still working it, to see what is happening after i am within 1 degree.
Re: Octoprint bed heating kill called
August 05, 2020 03:44AM
So it never bridges the gap between PID_FUNCTIONAL_RANGE and desired temp.

If i put it to 1, it holds 1 short. If I put it to 20 it holds 20 shorts.

If I comment out PIDTEMPBED, works great. I guess I have my answer, but no reason.

Can I set PID_FUNCTIONAL_RANGE to 0? Or should I just go back to BANG for the bed?
Sorry, only registered users may post in this forum.

Click here to login