Reprap full graphics controller display issue
August 15, 2020 12:05AM
When I connect my USB to laptop and give prints to 3d printer from laptop, then only my display works/I can control printing using display.
But as soon as I remove USB my printing gets OFF and display aslo goes OFF.

What could be the reason? I am using mega2560, ramps1.4, reprap full graphics controller,12V power supply for my 3D printer.

I check my voltage braker of Arduino connecting USB to laptop and it shows 2.9V and 4.9 V at its 2 pins. Is this OK?
I checked 5v pins and 3.3V pins on mega2560 and it shows correct reading.
But when I checked 5V pins on ramps1.4 It is showing lower voltage. 12V pins on ramps1.4 shows correct reading.

How to troubleshoot this problem? I am unable to find where the problem lies exactly. What should I check to relocate my problem?
Re: Reprap full graphics controller display issue
August 15, 2020 12:07AM
How can I check the voltage going for reprap full graphics controller is correct or not? And if it is lower then how can I resolve this?
The issue which I am facing is this because of Marlin settings or purely hardware/electric issue?
Re: Reprap full graphics controller display issue
August 15, 2020 02:34AM
Could it be the voltage regulator is damaged? When using USB it gets powered through USB and doesn't use the voltage regulator output. If the regulator is damaged it might show 5v without load but the voltage might drop when you out strain on it. I once had a voltage regulator work like that.

Did you measure the voltage over the LCD power lines with and without USB plugged in?


http://www.marinusdebeer.nl/
Re: Reprap full graphics controller display issue
August 15, 2020 04:11PM
There are many pins through which power goes to display. Accross which pin I need to measure voltage?
If there is difference between reading with USB and without USB , what does that mean?
Re: Reprap full graphics controller display issue
August 16, 2020 05:51AM
Here you can see the GND and VCC pins (EXP1 with pins 9 and 10):
[reprap.org]

I assume you are using the board with 12v PSU connected. Is there a difference in the voltage you read on the GND and VCC pins of the Ramps board going to the LCD panel with USB connected and disconnected?


http://www.marinusdebeer.nl/
Re: Reprap full graphics controller display issue
August 23, 2020 03:36AM
With USB connected, Voltage is 4.7 V and without USB connected Voltage is 0 V. so now what should I do?
One thing I observed that when I simply plug in the USB to laptop, display gets 4.7V but still it doesn't shows any text until I click "Connect" in pronterface.
What does this mean? How can I connect automatically to Printer without using pronterface?
Sorry, only registered users may post in this forum.

Click here to login