Marlin 2.0.6.1 with PlatformIO and VSCode
September 03, 2020 08:18PM
I was working on updating my Marlin configs today when VSCode stopped working and started throwing the error
"ModuleNotFoundError: No module named 'platformio.managers.package':". I've successfully compiled this config before, and this just started out of the blue. Does anyone have any ideas on how to help? I'd really like to still be able to use vscode...
Re: Marlin 2.0.6.1 with PlatformIO and VSCode
September 08, 2020 09:10PM
I had the same problem. PlatformIO upgraded itself and they changed the module. You can just download the latest marlin version and use that but I figured I would have to reset all the settings. So I downloaded the latest version and deleted the buildroot folder in my current version and replaced it with the buildroot folder from the new version. It then would buid correctly without having to redo all the settings.
Re: Marlin 2.0.6.1 with PlatformIO and VSCode
September 09, 2020 07:56PM
It should be sufficient to just delete the .pio folder that PlatformIO creates in the root of your Marlin folder. Then PlatformIO will re-download all of the libraries and modules required for your Marlin build.
Re: Marlin 2.0.6.1 with PlatformIO and VSCode
September 09, 2020 11:13PM
@MMcLure

Not in this case

The code in Marlins buildroot needs updated not to use platformio's managers package on the newer platformio core.
Sorry, only registered users may post in this forum.

Click here to login