Welcome! Log In Create A New Profile


Marlin 1.1.x bugfix homing issue

Posted by Johnmg 
Marlin 1.1.x bugfix homing issue
October 01, 2020 01:31PM
Hello all,
I have the Tevo Tornado 2018 gold edition printer. This printer used the MKS_Gen_L 1.0 board and A4988 Green version stepper driver chips. I upgraded this printer to a E3D v6 Gold hotend and a Zesty Nimble v1.2 Direct Drive system. I also upgraded my PWS to a MeanWell PWS. Edited and upload Marlin 1.1.x bugfix version to the printer. Board ype in the Configuration.h file is the BOARD_MKS_GEN_L I then tried just moving the printhead in each of the 3 axis X, Y, Z. I had to reedit the Configuration.h file to correct the direction of the motors. I have that fixed. I then tried homing my printer. During an auto homing G28 the print head goes to the left until it hits the min endstoip for the X direction. Then it goes to the Y min direction. Then it goes on a diagonal direction where it stops at the center of the bed. On my printers LCD display it shows X150, Y150, Z0. I tried moving the printhead to X0, Y0, Z0 which is the left front of my printer.. I first turned of the Endstops off with a M211 S0 command. And I did a M428 to set the home position offset. I did a M500 to save. Then a M211 S1 to turn Endstops back on. Then I tried a G28. The printer still homes to the middle of the print bed. Lastly, I tried from the LCD display a Home X, then Home Y, then Home Z. Home X moves the head to the X0 position. Home Y moves the print head to the Y0 position, left front. Home Z moves the printhead on a Diagonal direction to the center of the printbed. I am not quite sure what I am doing wrong or if there is a bug in the marlin firmware.

Any help will be appreciated,

Re: Marlin 1.1.x bugfix homing issue
October 01, 2020 07:00PM
If you have Z_SAFE_HOMING enabled then the behavior you are seeing is correct. Z_SAFE_HOMING is needed if homing Z with a probe to ensure that the probe is over the bed when homing Z.
Note that homing is defined as the printer determining where the 0,0 point is. Where the nozzle ends up after this is irrelevant as long as the nozzle position is correctly determined, which in your case seems to be the case (i.e. the display is correctly indicating that the nozzle is in the center of the bed).
If you are not homing with a probe you can probably disable Z_SAFE_HOMING and then the nozzle will not go to the middle of the bed when homing, but again, this is correct behavior if you have Z_SAFE_HOMING enabled.
Re: Marlin 1.1.x bugfix homing issue
October 02, 2020 04:32PM
YES, Z_SAFE_HOMING was enabled. I have a new issue. My X and E Axis motors are not working at all. Y and Z motors work fine. All motors were working when I installed Marlin 1.1.x bugfix. Then I tried installing marlin Tevo Tornado Master firmware and this is when my motor issues started. Originally, I installed the Tevo Tornado Master and it works perfectly. Then I deleted the firmware off my computer. So I had to reset up my configuration file and that's when I installed the 1.1.x bugfix version. I tried switching the cables for X and Z motors. When I went to move the Z axis it moved the X motor. So, that tells me the motor works. I do get a reading on the X A4988 Green version Stepper driver chip. It seems at least the driver is not totally dead. Is there anything you can think of that would cause this issue. I did read another thread that that person had the exact same problem which is the X and E motors are not working. I don't know what his solution was. I check all cable connections and everything is connected correctly.

Thank You,
Sorry, only registered users may post in this forum.

Click here to login