Welcome! Log In Create A New Profile


Problems Compiling Marlin on RAMBO 1.3

Posted by jspring111 
Problems Compiling Marlin on RAMBO 1.3
November 10, 2020 07:08PM
I'm having problems writing firmware for my Airwolf Axiom Printer. Airwolf won't release the firmware source files so I decided to learn how to Create firmware in Marlin using VS Code. I started this project last July and early August but then I got busy on other things and had to take a break. At that point I had it mostly working, I loaded the firmware on the board and had the steppers going in the right direction, auto homing and auto leveling.

But when I came back to it a couple days ago and tried to flash the firmware I got a bunch of errors. I think some of them were due to the fact that I updated Platform IO because when I backed up to an older version of Platform IO a bunch of the errors went away. So I decided to start over with the updated Platform IO and the newest version of Marlin Bugfix. I made the changes in configuration.h and configuration_adv.h but it wouldn't compile. So I backed out some of my settings to the defaults and now it complies. I flashed the board and I have a blank LCD and a slight bumping in the Z Axis stepper.

So this is what I'm currently trying to resolve: I had to use the default A4988 Driver types for X,Y,Z and E0 because I get the following error message when I try to compile with the proper A4982 Drivers

In file included from Marlin\src\HAL\AVR\../../inc/MarlinConfig.h:49:0,
from Marlin\src\HAL\AVR\HAL_SPI.cpp:34:
Marlin\src\HAL\AVR\../../inc/SanityCheck.h:3202:4: error: #error "X_DRIVER_TYPE is not recognized."
#error "X_DRIVER_TYPE is not recognized."

And it won't compile. When I built this a few months ago I didn't get this error or several of the other errors and my display worked. I don't know if something happened with the latest updates of Marlin of VS Code/Platform IO.

Any idea why it isn't recognizing my A4982 drivers?

This is what I have:

Core XY
Direct Drive Extruder
Rambo 1.3
Viki2 LCD

Re: Problems Compiling Marlin on RAMBO 1.3
November 10, 2020 08:00PM
As far as I know A4982 have never been supported in official Marlin. However, previously the default configuration file would simply have all of the drivers commented out (which made them act like A4988s). The good news is that the A4982s and A4988s are so similar that you can simply use the latter setting and everything will work. See for example the configuration for the AlephObjects TAZ4 which uses the RAMBO: [github.com]
Re: Problems Compiling Marlin on RAMBO 1.3
November 10, 2020 08:42PM
Thanks for the response. Interestingly when I compile using Platform IO version 1.10 it doesn't give me an error with A4982 drivers but with Platform IO version 2.2 it does. I'll try using A4988.

Any idea why my VIKI2 LCD doesn't display? I know it works because when I load the old Airwolf firmware it works. I did get it to come on upside down a couple times but now it just lights up very dimly.
Re: Problems Compiling Marlin on RAMBO 1.3
November 10, 2020 10:10PM
Only recently Marlin started to detect if invalid stepper driver types are entered. Before it silently defaulted to A4988, this caused issues when people made typos in their driver type.
Sorry, only registered users may post in this forum.

Click here to login