Welcome! Log In Create A New Profile


Marlin 1.1.9 UBL creates double height prints

Posted by BarneyG 
Marlin 1.1.9 UBL creates double height prints
December 28, 2020 09:57AM
A bit of background ... I'd been using Marlin 1.1.x for some time quite happily on an i3 style printer with an Arduino Mega/ Ramps 1.4 combo. This year I decided to update some of the printed parts add a BLTouch and replace the Wade extruder with a Titan. I'd tried Marlin 2.0 previously but downgraded again as I could never get the prints as good as with 1.1.9. I thought with my hardware upgrades and newer 2.0.x version it would be time to try 2.0.x again but alas I found the same as before I just couldn't dial in the settings - more ringing, and stringing, and small parts tended to be very blobby.

So I went back to 1.1.9 (I wonder if the Arduno Mega can't really cope with 2.0.x) but this time I got rubbish. xyzCubes that were fine in X and Y dimensions but about 40mm heigh and the layers not adhering to each other and infact getting further apart the higher up the print it got. Tried both old and new slices. Finally reset eeprom and it worked. Redid my UBL mesh and it was back to rubbish ... tried Linear ABL and while the bottom actually appeared worse than with ABL turned off it was at least dimensionally accurate.

I've attached a pic to show what I mean (not with xyzCubes as I didn't photograph those)
Left to right - no ABL, UBL, Linear.

UBL was working in 2.0.x and I just copied those settings back to 1.1.9 but I've probably missed something. Anyone seen anything like this before / any ideas how to fix ?

Edited 1 time(s). Last edit at 12/28/2020 09:58AM by BarneyG.
open | download - UBL.jpg (705.6 KB)
Sorry, only registered users may post in this forum.

Click here to login