Welcome! Log In Create A New Profile

Advanced

Marlin with Markforged_XZ

Posted by Mustang66 
Marlin with Markforged_XZ
February 24, 2021 05:41PM
Hey all. I.ve had a couple topics on Markforged_XZ and found the new marlin had Markforged_XY added. I decided to go thru the code and see if XZ would be hard to add. I actually added it and installed it on my machine. My machine is not markforged_XZ yet but when moving the x axis it moves correctly by itself. When moving the z axis it moves and the x axis moves also like it should. All's well and great until I move the Y axis and it does not move just makes a click sound. I've been trying to troubleshoot and find what is wrong but no luck yet.
I thought maybe someone out there with some knowledge of marlin would like to check it and see if they could help find what I screwed up.eye popping smiley
I'm attaching the files. You can find all the areas that I changed by searching for "Markforged_XZ".
Thanks to anyone that would like to help. If it works it could be submitted to be added to the official marlin.

I've been trying to attach the file and I keep getting to big error. It was 7.8mb so I just ziped the marlin folder and it's 5.1mb and it still gives error.
How do I attach it?

Edit: Still can't attach the file. It says up to 8mb.

Edited 1 time(s). Last edit at 02/24/2021 05:55PM by Mustang66.
Re: Marlin with Markforged_XZ
February 24, 2021 07:35PM
Well, still don't know why can't attach a file that's 5 or 7 mb when it says largest is 8mb but:

I figured out the problem with my Markforged_XZ addition to marlin.It now operates the same as _XY does except with the z axis instead of y axis.
If anyone is interested let me know.
Sorry, only registered users may post in this forum.

Click here to login