RAMP 1.6, BLTouch and a Re-ARM pin definition problem?
May 06, 2021 05:19PM
Hi all,

Bringing my old project back to live and making updates along the way, not the best sequence heh.
Anyway, having upgraded to a RAMPS 1.6+ board on a Re-Arm that previously ran smoothie, I switched to Marlin FW due to its better acceptance and support in the 3D community.
I'm running a home-made Prusa I3steel Toolson MK2 which, by todays standards, is considered old smiling smiley

I'm trying to get the BLtouch to work, using Marlin I've opted to not use the standard Z_MIN option but instead have connected the probe part to Z_MAX on the RAMPS board, white on S and black on GND.
The servo part is on Servo 0 pin and 5V is fed into it from a home made 12V to 5V regulator sporting a LM1085 regulator.

Having read the Marlin website as well as viewing multiple videos on YT, I think I have a good grasp of getting the BLtouch to work. It does its selftest, deploys and stows from the LCD menu.
It is after setting up bed levelling where the problem starts.

Running the Bilinear bed levelling, the G29 command is executed and the nozzle moves to its first position, the probe is deployed and the Y axis lowered. The probe contacts the bed and retracts but it does not light up, this repeats a couple of times and the interface throws an error, probing failed.
I enabled debugging and ran the G29 again, it comes up with Probe Fail! - no trigger.

I've set the #define Z_MIN_PROBE_PIN 19, as 19 is in the pins file for pin 1_28 which is the Z_MAX_PIN.

Things I've tried:
Set the default pin 32 but that didn't work, the probe retracted once M119 command was given.
Set the pin to 1_28 but that throws the compiler into an error, reverted back to 19
Setting the z_max_endstop_inverting to true, didn't resolve the issue.

I'm quite confident the BLtouch works as intended but either I've failed to locate the correct pins or my assumption of the Z_MAX pins is wrong, does anyone have a helpful insight to what I'm missing?

Thank you.
open | download - Configuration.h (90.4 KB)
Re: RAMP 1.6, BLTouch and a Re-ARM pin definition problem?
May 10, 2021 02:18PM
You can't use the Arduino pins numbering (19) with Re-ARM - you need to use the 'P1_28' syntax (note the 'P' - you can't just say '1_28').

On a Re-ARM you should disable ENDSTOPPULLUPS since the Re-ARM has hardwired pull ups on the board so you don't also need to enable the CPU pull ups.

May I ask why you're moving the BLTouch to the Z max pin? Most people connect it to the Z min (Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN) and use it both for homing and probing. Trying to use both a Z endstop and probe tends to cause complications.

Also, one thing you can try is to switch the BLTouch into SW mode with 'M280 P0 S60' and then use 'M119' to check the return value of the probe with the pin extended and retracted. It should show TRIGGERED when retracted and open when extended.
Re: RAMP 1.6, BLTouch and a Re-ARM pin definition problem?
May 11, 2021 03:58AM
Thank you for your answer MMcLure, I'll set the pin definition to P1_28 later tonight and try again.

I'd like to have a secondary safety built-in for the Z endstop. Currently, I use a glass plate and if the BLtouch should fail for whatever reason, I'd like the Z-axis to stop when it hits the endstop instead of crashing, and possible breaking, my glass plate.

Regarding the other things, I'm going to set-up the firmware later tonight and report back.

Edited 1 time(s). Last edit at 05/11/2021 03:58AM by LooneyT.
Re: RAMP 1.6, BLTouch and a Re-ARM pin definition problem?
May 21, 2021 08:34AM
As stated I'd report back. Having tried different pins and options I removed it altogether and installed the BLTouch as a Z-endstop and homing in the Z-min endstop and it works.

Back to getting the printer up and running.

Thank you for the advice, it was really helpful!
Sorry, only registered users may post in this forum.

Click here to login