Welcome! Log In Create A New Profile

Advanced

I need help building for Elegoo Neptune 2

Posted by RDeNatale 
I need help building for Elegoo Neptune 2
October 05, 2021 08:13PM
I'm trying to build Marlin for the Elegoo Neptune 2. I'm using the MKS fork at [github.com] using the mks_robin_nano_v3_usb_flash_drive environment.

I've manage to build something with PlatformIO on VS Code. I've copied the assets directory and firmware.bin to the sd card, and renamed firmware.bin to elegoo.bin which is what their bootloader is looking for.

when I boot the printer, it shows that it is erasing some stuff then shows a green progress bar which gets to 100% and just hangs.

How can I debug this? I suspect that something is wrong in my Configuration Files, or that I need some other files on the sd card.

Here's the output of the build using Auto Build Marlin:

platformio run -e mks_robin_nano_v3_usb_flash_drive ; echo "done" >|/var/folders/ft/vf81114d3xqdjj89xh9d5z5c0000gn/T/ipc
[email protected] Mks-Robin-Nano-Marlin2.0-Firmware % platformio run -e mks_robin_nano_v3_usb_flash_drive ; echo "done" >|/var/folders/ft/vf81114d3xqdjj89xh9d5z5c0000gn/T/ipc
Processing mks_robin_nano_v3_usb_flash_drive (platform: [email protected]~12.0; board: marlin_STM32F407VGT6_CCM; framework: arduino)
----------------------------------------------------------------------------------------------------------------------------------------
Verbose mode can be enabled via `-v, --verbose` option
CONFIGURATION: [docs.platformio.org]
PLATFORM: ST STM32 (12.0.0) > STM32F407VG (128k RAM, 64k CCM RAM, 1024k Flash
HARDWARE: STM32F407VGT6 168MHz, 128KB RAM, 1MB Flash
DEBUG: Current (jlink) External (jlink, stlink)
PACKAGES: 
 - framework-arduinoststm32 0.0.0 
 - framework-cmsis 2.50501.200527 (5.5.1) 
 - toolchain-gccarmnoneeabi 1.90201.191206 (9.2.1)
Converting Marlin.ino
LDF: Library Dependency Finder -> [bit.ly]
LDF Modes: Finder ~ chain, Compatibility ~ soft
Found 13 compatible libraries
Scanning dependencies...
Dependency Graph
|--  6.1.1
|--  0.0.0+20201117144502
|--  0.7.3
|   |--  1.0
|   |--  1.0
|--  1.0
|--  1.1.2
|--  1.0
|--  1.0.0
|--  1.0
|--  2.0.1
Building in release mode
Checking size .pio/build/mks_robin_nano_v3_usb_flash_drive/firmware.elf
Advanced Memory Usage is available via "PlatformIO Home > Project Inspect"
RAM:   [=====     ]  46.8% (used 61280 bytes from 131072 bytes)
Flash: [====      ]  36.9% (used 387296 bytes from 1048576 bytes)
===================================================== [SUCCESS] Took 10.30 seconds =====================================================

Environment                        Status    Duration
---------------------------------  --------  ------------
mks_robin_nano_v3_usb_flash_drive  SUCCESS   00:00:10.298
===================================================== 1

Any help would be appreciated
VDX
Re: I need help building for Elegoo Neptune 2
October 06, 2021 02:16AM
... I'm not familiar with your setup -- but ist there maybe a misbehave with your STM32 platform to NanoV3?


Viktor
--------
Aufruf zum Projekt "Müll-freie Meere" - [reprap.org] -- Deutsche Facebook-Gruppe - [www.facebook.com]

Call for the project "garbage-free seas" - [reprap.org]
Re: I need help building for Elegoo Neptune 2
October 06, 2021 08:36AM
This page [www.elegoo.com]
Says this controller is a stm32f103, not a STM32F407VGT6
Re: I need help building for Elegoo Neptune 2
October 06, 2021 08:42AM
[69.195.111.207] has pictures of the controller, which is a STM32F103VET6

Edited 1 time(s). Last edit at 10/06/2021 08:43AM by Dust.
Re: I need help building for Elegoo Neptune 2
October 06, 2021 01:34PM
Okay with the help of a kind user on the Neptune 2 reddit group, I've managed to install Marlin on the Neptune 2.

I needed the board BOARD_MKS_ROBIN_NANO

Biut I have two problems. One serious the other annoying.

The serious problem has to do with the BLTouch. When I home the machine, the Z-axis lowers but then keeps trying to go down.

Here's a video of what happens

I'm not sure how to fix this. The BLTouch is a Smart 3.1.

I've tried
// Safety: The probe needs time to recognize the command.
  //         Minimum command delay (ms). Enable and increase if needed.
  #define BLTOUCH_DELAY 500

  /**
   * Settings for BLTOUCH Classic 1.2, 1.3 or BLTouch Smart 1.0, 2.0, 2.2, 3.0, 3.1, and most clones:
   */

  // Feature: Switch into SW mode after a deploy. It makes the output pulse longer. Can be useful
  //          in special cases, like noisy or filtered input configurations.
  #define BLTOUCH_FORCE_SW_MODE

. in Configuration_adv.h but it still does the same thing.


I'd appreciate any ideas.
Re: I need help building for Elegoo Neptune 2
October 06, 2021 07:10PM
Okay, I fixed it. It turned out to be a mechanical problem. There was a ball of hardened filament on the end of the nozzle.

That said. I never mentioned my annoying problem which is that the touchscreen response is sluggish. Is there anything to configure to address that. The UI is less atttactive than the elegoo stock firmware. I guess I'll have a look at TFT_LVGL_UI, but it's not so big a deal, since I tend to use Octoprint.

I'm printing again now, but I had a bed temp failure. I increased THERMAL_PROTECTION_BED_HYSTERESIS from 2 to 4 and I got sa good first layer and it's printing the second layer now.

But after that change it seemed to take forever to heat the bed. The target temperature is 60 c, but it slowly got up to 58 an then 59 before proceeding. Only into the second layer it's at 60 I'm not sure what if anything I can tweak here. MAX_BED_POWER is the default at 255.
Re: I need help building for Elegoo Neptune 2
October 18, 2021 11:03PM
A follow up.[

I couldn’t figure out how to fix the problems with the bed heating slowly and getting heating failures. I don’t know if I mentioned it but I did do paid auto tuning.

I went back to the Elegoo firmware and haven’t seen the bed temp issues since. So this seems to be a configuration rather than a hardware problem. So I must have some hardware related settings in Configuration.h and or Configuration_adv.h wrong.

However I’d really like to get regular Marlin running, I’m not completely satisfied with the Elegoo firmware because:

  • It follows G29 with their own interactive setting of the z-offset instead of having the normal Z-Probe Wizard.
  • They don’t support the M412 H parameter so Octoprint isn’t told about filament runout, and the printer ignores it when printing from Octoprint
  • When I reinstalled the stock firmware, it claimed to be processing the font and image files on the SD card, but the UI just shows blank boxes with labels, no icons


Any ideas on how to figure this out. The printer uses a clone? of the MKS Robin Nano

Edited 2 time(s). Last edit at 10/18/2021 11:05PM by RDeNatale.
Sorry, only registered users may post in this forum.

Click here to login