Welcome! Log In Create A New Profile


PID Autotune Heats Briefly Then Heater Goes Dead - (Heats Normally During Print and Via M109)

Posted by WBILLETT 
I recently changed my custom build setup from a RAMPS REARM to a BIGTREETECH GTR 1.0 with TFT70 running at 24v. Also went from a Aero to a Volcano-Hemera extruder/hotend combination (stock E3D thermistor and 50w 24v heater).
Control and print is via Raspberry Pi and Octoprint (most recent version 1.7)
So far everything works as expected and can hold temperature pretty precisely with an M109 E0 S210. I have been able to print several parts with out any temp errors.
However, I noticed a little overshoot initially (10C - 20C at the start of prints and decided to use PID autotune

PID autotune via M303 E0 S210 appears to start normally, voltage at the heater increases to 24v, the extruder heats to about 40 or 50C then heating abruptly stops. Voltage at the heater drops to 0 and with thermal protection disabled
it enters an endless loop. With thermal protection enabled it gives a heating error and halts the printer as expected. I have not used PID autotune in awhile so I cannot say when this started. I have tried the most recent release of Marlin 2.0 ( and the most recent Marlin 2.0 bugfix (Oct 12, 2021) with the same behavior. I have tried varying the initial default PID parameters and the PID_FUNCTIONAL_RANGE prior to initiating the autotune always with the same behavior. I have seen issues regarding failure to heat entirely and stopping short of target but not this issue as far as I can tell so maybe it's hardware specific related to autotune only? Seems like this is a Marlin bug in the autotune routines since all the other heating functions work normally. However, I was wondering if anyone else has had a problem like this or if anyone has ideas for a fix.

BTT GTR 1.0 with TFT70 LCD
TMC5160 and TMC 2209
Hemera extruder
Volcano hotend
E3D stock thermistor
50w 24v Heater
BTT filament detector
open | download - Marlin Config Files.zip (83.7 KB)
M303 S temperature C cycles

Try M303 E0 S210 C8

Edited 1 time(s). Last edit at 10/14/2021 10:41AM by obewan.
Thanks for the reply but not sure what to make of it. Yes that is the correct command. leaving off the C parameter means it will default to 5 cycles but it does not matter how many cycles are specified it never makes it through the first one.
Sorry, only registered users may post in this forum.

Click here to login