Welcome! Log In Create A New Profile


Endstops suddenly ignored by firmware

Posted by reach 
Endstops suddenly ignored by firmware
November 14, 2021 05:18PM
I bricked my mainboard, MKS GEN L v1. So I ordered a new one and installed it.
When testing everything, I found that the endstops (all 3) are ignored by the firmware. Means I have moved the head via the display controls, blocked the switch with some metal, the switche's LED went red, but the head still moved in its direction.

My firmware is the latest from Github, only with modifications for a different extruder (Hemera).
So, having no better ideas, I tried the orig. HEX file from Evnovo, installed it and, voila, it worked. Head doesn't move towards the switch any more when blocked.

But the Hemera-modified FW also worked until now!
Any idea how this could happen? Is it maybe a difference if the head is driven via the display or via USB?

Here is the only difference I found in the supposedly relevant config section:



AFAIK the orig. FW is Marlin 1, while the Github one is v2, so I suspect these settings are doing the same thing and can't cause the described issue, can it?
Re: Endstops suddenly ignored by firmware
November 14, 2021 05:47PM
Endstops by default are only used during homing. Not during moves

// If you want endstops to stay on (by default) even when not homing
// enable this option. Override at any time with M120, M121.
Re: Endstops suddenly ignored by firmware
November 15, 2021 04:33PM
Bingo!! Thanks a lot!

The original configuration didn't have that string in and it still worked. However, putting it in the new config does the trick, that should be good enough. I don't have to understand everything :-)
Sorry, only registered users may post in this forum.

Click here to login