Welcome! Log In Create A New Profile


Delta Failing G33 Part 1

Posted by Rowdynk 
Delta Failing G33 Part 1
July 18, 2022 05:09PM
Overview of issue:
Hey so I am pretty close to successfully updating the mainboard and thus the firmware on my Monoprice mini delta. However when I try to do input a G33 command, the printer homes, then the effector moves down about halfway, then makes its way bit by bit to the top where it once again homes, then moves only one axis down moderately fast and it fails saying error probing failed. fix delta parameters with M665 and M666.

-If I try to increase the delta height value it only goes a tiny bit more down (I have tried changing it from 110mm the default all the way to 200mm)
-I have saved the settings to eeprom
-The steps/mm values for the xyz are all set correctly. I have measured the actual/inputted movement to make sure.

So I'm not sure exactly what is happening here. I can't find anything on the subject so any bit of help would be great!

I have attached the configuration.h and configurationadv.h files that have all of the settings configured to eeprom

Please and Thank You
open | download - Configuration.h (118.5 KB)
open | download - Configuration_adv.h (178.7 KB)
Re: Delta Failing G33 Part 1
July 18, 2022 10:43PM
What does M119 report? If the ZMIN probe is always triggered you'll get this type of behavior.

What do you have for a ZMIN probe? The settings in configuration.h are unusual.
Re: Delta Failing G33 Part 1
July 19, 2022 12:14AM
Hey so the z “probe” that comes off the shelf on these printers are actually 3 microswitches that the bed rests on and trigger when the nozzle touches the bed. Thus the weird probe offset because all you need to account for is the distance the bed moves down when the switches are triggered(basically your standard z offset in a new setting)

When I do an m119 it shows that those switches are always triggered. This is almost guaranteed to be the issue as I did do a pretty bad job of soldering these switches up to work with the new motherboard.

I will fix this tomorrow and report back. However I am pretty confident that this is going to be the issue.

Re: Delta Failing G33 Part 1
July 19, 2022 07:29AM
When you setup your microswitches we recommend the following. That way, if a cable falls off or opens, the system will think the endstop is triggered and you know there is a problem.
  • COM to ground
  • NC to signal
  • xxxx_ENDSTOP_INVERTING false
  • enable #define ENDSTOPPULLUPS
Re: Delta Failing G33 Part 1
July 19, 2022 03:39PM
I just realized that I gave you bad advice for three bed sensing switches. The above recommendation is for a single switch.

For the three bed switches there are two options: series and parallel.

  • all COMs to ground
  • all NOs to signal
  • enable #define ENDSTOPPULLUPS

Series (has the advantage that a cable fault will show up automatically):
  • COM on switch A to ground
  • NC on switch A to COM on switch B
  • NC on switch B to COM on switch C
  • NC on switch C to to signal
  • enable #define ENDSTOPPULLUPS
Re: Delta Failing G33 Part 1
July 19, 2022 05:54PM
Alright it seems as though this issue presents itself whether or not Zmin endstop inverting is enabled or not. As well as when the z probe plug is disconnected from the mainboard with/without endstop inverting. This brings me to the conclusion that either:

1. The Board is trying to use a different pin for monitoring the probe than the signal pin on the board.


2. The board has an issue with it.
Re: Delta Failing G33 Part 1
July 19, 2022 06:27PM
Can you see the ZMIN probe go from triggered to open and back via M119?
Re: Delta Failing G33 Part 1
July 19, 2022 06:40PM
Alright so the issue was that I was using the wrong pin as the signal pin (PA5 rather than PC14). Got that figured out and now I can switch the z probe on and off while monitoring with m119. Thanks for that. Now the only weird thing is that the probe is triggered by default and goes to open when pushed on. I have tried to set zmin endstop inverting to false and it still does the same thing; which is quite counterintuitive.

Edited 1 time(s). Last edit at 07/19/2022 07:13PM by Rowdynk.
Re: Delta Failing G33 Part 1
July 19, 2022 07:34PM
Flipping zmin endstop inverting from true to false should invert the operation. I think something got confused or over looked. Please try flipping it back and forth to verify.
Re: Delta Failing G33 Part 1
July 19, 2022 07:53PM
So apparently they changed the inverting setting from the z min endstop one to the z min probe one that is all the way at the bottom of the list. Anyways that fixed it and now everything is done and G33 worked!

Thank you so much for your time!

Re: Delta Failing G33 Part 1
July 19, 2022 11:24PM
Sorry, only registered users may post in this forum.

Click here to login