Welcome! Log In Create A New Profile


UBL causing weird behaviour with tool changer printer

Posted by JanJans 
UBL causing weird behaviour with tool changer printer
February 17, 2023 03:53PM
Dear all,

I am having a really odd problem when I was trying to add a bed leveling system to my tool changer 3D printer. My printer is somewhat unique so bear with me.

First of all. I am running Marlin Updating this firmware is hugely time consuming due to large amount of modifications I have in my current firmware. Advising me to update my firmware is not really what I am hoping for winking smiley

There was no room for a bed leveling sensor on my tool changing printer. So I made a tool with just sensor. I made sure this tool has the same weight as the tool with a print head.
The tool with bed leveling sensor has a Z offset of 3.125mm. This is tool 3 (T3)
My first print head has an Z offset of 0.675mm. This is tool 0 (T0).

When changing tools the T command is automatically called by my modified firmware. My tool offsets are.
T0 (0,0,0) Firmware demands this
T3 (0,0,0)

So no weird Z offset are generated by switching tool T0 and T3 with the T commands.

My NOZZLE_TO_PROBE_OFFSET has been set to -2.45 (0.675 - 3.125 = -2.45). This seams logical to me because this is my real offset between T0 and T3.

At the beginning of the print, my axis are homed. Tool 3 (bed leveling sensor) is picked and G29 J command is used with the idea of telling the printer my printhead (T0) is at not at Z=0 but actually Z=0.675mm. Before all this, the bed mesh was already made off course. After the G29 J command, the tool is changed to T0 and the print can begin.

Here the problem begins. My printhead (T0) is rammed into the bed surface. So I used babystepping to get some more distance and to figure out what the offset should be. I was expecting the babystep value to be 0.675mm because apparently the G29 J command does not compensate Z offsets? However, the babystepping value I had to use was more like 0.3mm. After that, the printer works perfectly

The 0.3mm value makes absolutely no sense to me. This is not a value I can explain.
I have no idea whats causing this problem and how to fix this. Any help would be greatly appreciated.

Just for fun, an old video of my printer. Without a bed leveling sensor and without more efficient tool changing code.

Edited 3 time(s). Last edit at 02/17/2023 04:02PM by JanJans.
Re: UBL causing weird behaviour with tool changer printer
February 18, 2023 07:20AM
I think I am making progress.
I found a good article on the Marlin website about the whole endstop en probe challenges.

This document said I should use MANUAL_Z_HOME_POS to tell at which height the Z min end stop is located. So I set the value to -0.675mm. This is the value between the Z min end stop and T0 (print nozzle). The NOZZLE_TO_PROBE_OFFSET is still set to -2.4mm. This worked. I got an excellent first layer!

Then I swopped the build surface for a surface which is thicker than the one I had before. This one failed. It seams I have to manual set MANUAL_Z_HOME_POS for each print surface that I got. That is undesirable.

I think the basic problem here is that my Z min end stop is located on the bed carriage, not the top of print surface. Therefore the position of the Z min end stop is not compensated for different bed thicknesses. This is where everything falls apart.

I am going to explore the option of using my bed level sensor as z min end stop. By doing so my printer does automatically compensate for the different thickness of print bed surfaces.
Re: UBL causing weird behaviour with tool changer printer
February 18, 2023 08:15AM
The newest Marlin has a USE_PROBE_FOR_Z_HOMING option. Maybe your version has it.

What custom coding did you do? The later Marlin releases have a lot of multi-tool enhancements. Maybe your custom coding is no longer needed.
Re: UBL causing weird behaviour with tool changer printer
February 18, 2023 09:06AM
My firmware has the Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN option.
I think I have to modify something anyway. I am OK with using my probe as Z min endstop. However I still want my normal z min endstop to be there. I will figure something out.

I think the new firmware will be better. However, I doubt if the firmware is going to work without several modifications. I don't think many printers have a tool elevator for parked tools winking smiley Perhaps some day I will put in the effort. Not right now smiling smiley
Re: UBL causing weird behaviour with tool changer printer
February 19, 2023 10:55AM
Indeed tying the Z min probe and the Z min endstop together on 1 pin, activating Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN fixes everything! smiling smiley
Problems solved winking smiley
Sorry, only registered users may post in this forum.

Click here to login