Missing files from manufacturer marlin source
November 12, 2023 07:20PM
Hi all, thanks for reading and I hope you can help!

I'm trying to build this version of marlin:

[github.com]

with just a couple of small changes, but I'm unable to make the vscode auto-build plugin work.

I first received errors about "platformio.ini" missing. Platformio.ini is not present on the github, nor is the "marlin.ino" file that allows platformio to import the project.

I then tried taking the marlin.ino from a previous tenlog TLD3 firmware (marlin 1.x) version, but this didn't help. I only ended up with a blank platformio.ini and no idea what to input there. The marlin 1.x github doesn't include a platformio.ini file either.

There are a number of entirely missing directories & files in the TLD3V2 (marlin 2.0) github, so I tried taking default marlin 2.0.x source code and copying Tenlog's configuration.h and configuration_adv.h.

That got me a little closer, but I was still stuck. When I tried to build, I got a terminal error stating that boards.h does not include the motherboard defined in configuration.h (BOARD_TL_V101).

Seemed like a logical move to grab the boards.h from /source/Marlin/src/core
/boards.h on tenlog's github, so I did. This got rid of the last error, but now I get "unknown motherboard" in the auto-build pane.

This led me to the Marlin-2.0.x\buildroot\share\PlatformIO\boards folder, where there are .json files for several different boards, but obviously tenlog's board is not included.

I dunno what my next step should be, so I'm begging for mercy from the smarter folks in this forum lol

For reference, I am attempting to flash the firmware to this tenlog-manufactured bespoke board:
[www.tenlog3dprinter.com]



Sorry for the infodump! Hope one of you can help me ease this headache smiling bouncing smiley

Edited 1 time(s). Last edit at 11/12/2023 07:21PM by terbospaghetti.
Re: Missing files from manufacturer marlin source
November 12, 2023 11:48PM
You miss understand

From the source page you linked.
MCU: HC32F460
IDE: Keil uVision5

This code is not meant for platformio. PlatformIO has no inbuilt support for the HC32F460 MCU, this code is designed to be built with Keil uVision5 IDE

Now in saying that, some very cleaver person just added [github.com] to add HC32F460 support into standard marlin under platformio. (this is a PULL request, ie the code has not be merged with Marlin code as yet)
Its only been tried on Voxelab Aquila V1.0.1 controller

Once this PR has been added, it will be much easier to add additional HC32F460 based controllers.

Edited 6 time(s). Last edit at 11/13/2023 12:20AM by Dust.
Re: Missing files from manufacturer marlin source
November 13, 2023 12:30AM
Should I just go ahead and compile it with keil 5 if the PR hasn't been incorporated into the code?
I've checked into what it takes and I think it's within my limited code-related skills
Sorry, only registered users may post in this forum.

Click here to login