Welcome! Log In Create A New Profile

Advanced

Z homing with bltouch problem

Posted by mopar 
Z homing with bltouch problem
May 25, 2024 11:30PM
So I got my bltouch working correctly thanks to Dust.

No my problem is my Z steppers when homing. They lock up when moving in Z+ after the 1st touch of the probe. It sounds like a belt slipping. It's a pretty ugly sound. I've tried a few different things but haven't zero'd in on the problem yet and hoping someone could point me in right direction.

Printer is a Makerfarm Pegasus. It's been working for years with Colins original firmware, but I have no idea which version of Marlin it was as the pc I did the original compiling on died years ago.

Ive attached my full config.h file.

I should mention that I wrote down all the settings I could find thru the lcd before I started on this project. However I was using the reprap discount graphic display versus the full graphic display now and with the newer firmware the verbage for the settings don't match and I don't know what some of them are.

Accel - 500

Vxy_jerk - 20

Vmax_X - 250
Y - 250
Z - 2
E - 22

Vmin - 0

Vtrav_min - 0

Amax_x - 1000
y - 1000
z - 5
e - 1000

A-retract - 500

Xsteps - 80
Ystesp - 80
Zsteps - 4000
Esteps - 411.8

Auto_temp - Off

Hotend min - 210
Hotend max - 250
Fact .1

Most I figured out and transferred them to my new config, but one or two I'm not sure what exactly they are. I did change my hotend min and max in new firmware as I know my E3D V6 hotend is rated for a higher temp then what Colin had them set for.

Edited 1 time(s). Last edit at 05/25/2024 11:42PM by mopar.
Attachments:
open | download - Configuration.txt (122.9 KB)
Re: Z homing with bltouch problem
May 26, 2024 10:54AM
Here's a video of what my printer is doing.
Attachments:
open | download - 20240526_105317.mp4 (4.83 MB)
Re: Z homing with bltouch problem
May 26, 2024 10:20PM
you have #define DEFAULT_MAX_FEEDRATE { 250, 250, 5, 22 }
but your notes say #define DEFAULT_MAX_FEEDRATE { 250, 250, 2, 22 }

This is he max speed of Z, which seems to be what is broken.

Also note this is settable via eeprom, so changing this in Configuration.h will not work as it now uses the values in eeprom
#define EEPROM_INIT_NOW will reset eeprom to the firmware defaults every firmware upload

Edited 2 time(s). Last edit at 05/26/2024 10:57PM by Dust.
Re: Z homing with bltouch problem
May 27, 2024 08:49PM
Figured it would be something I missed.

So if I wanted to make sure all eeprom settings are updated with a firmware update I need to uncomment #define eeprom_init_now?

I will still be able to update the eeprom from pronterface though correct?

Thanks again Dust.
Sorry, only registered users may post in this forum.

Click here to login