Fan 0 always ON
February 19, 2016 11:14AM
Hello ,

I have a DUET 0.8.5 and i have a problem with my layer fan 0 , i can't stop them...
I can change the PWM of the fan 0 but when i ask him to stop : M106 S0 , the led on the DUET stay On and the fan don't stop.

I've try to put the fan on the fan1 output and everything is just working fine.. i can start and stop the fan with M106 P1 S0-255 and i can see the led on the DUEt going on or off.

I've attach my config.g file
Attachments:
open | download - config.g (4.9 KB)
Re: Fan 0 always ON
February 19, 2016 12:29PM
If you're either on my or dc42's latest firmware, you need to remove

M106 I1 ; fans are inverting

from your config file.
Re: Fan 0 always ON
February 19, 2016 01:03PM
thx for the reply but...

Nothing change when i remove the lines... i can not stop the fan but i can change the speed.

I try different firmware on my delta printer (DC42) and i have always the same problem
Re: Fan 0 always ON
February 19, 2016 02:23PM
When you use increasing S values in the M106 command such as S0.1, S0.2, S0.3 and so on up to S1.0, what is the effect on the fan speed?

EDIT: you said in your post you are using M106 P1 S0-255 to control the fan. The P1 parameter specifies the FAN1 output instead of FAN0. So I deduce that you have your fan connected to the FAN1 connector instead of the FAN0 connector.

Edited 1 time(s). Last edit at 02/19/2016 02:25PM by dc42.



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Fan 0 always ON
February 19, 2016 02:30PM
I will try s0.1, s0.2 s0.3.

I said that i've try my fan my on the fan1 connector and everything was working fine. i've only got the problem on the fan0 connector

EDIT : just tried the M106 S0.1 S0.2 ,etc... with this command, i can change the fan speed as i do with M106 S0-255. Result is the same , I can't stop the fan.

Edited 2 time(s). Last edit at 02/19/2016 02:38PM by Cammi.
Re: Fan 0 always ON
February 19, 2016 03:12PM
Another strange thing that i've see with all the try i've done :

Firmware 1.09 k and m : I can control fan0: increase and decrease the speed but can't stop it. Everything ok on Fan1
Latest firmware 1.09 r :I can control fan0 , increase and decrease the speed but can't stop it . Fan1 did not respond...
Re: Fan 0 always ON
February 19, 2016 03:39PM
Quote
Cammi
Another strange thing that i've see with all the try i've done :

Firmware 1.09 k and m : I can control fan0: increase and decrease the speed but can't stop it. Everything ok on Fan1
Latest firmware 1.09 r :I can control fan0 , increase and decrease the speed but can't stop it . Fan1 did not respond...

In 1.09r, FAN1 is configured as a thermostatic hot end fan by default. Send M106 P1 H-1 to disable thermostatic mode.

Are you by any chance using a 4-wire PWM fan, and using the FAN0 output to control the PWM line? If so, the reason is that PWM fans are only controllable down to about 30% off full speed. I published a schematic a while back to allow a PWM-controllable fan to be turned off completely, on the Ormerod forum.



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Fan 0 always ON
February 19, 2016 03:45PM
I have done all my test with a simple 2 wire 40 mm fan.
Re: Fan 0 always ON
February 19, 2016 03:57PM
Quote
Cammi
I have done all my test with a simple 2 wire 40 mm fan.

That's very strange then. My delta has a 2-wire 40mm fan connected to FAN0, and it turns off if I send M106 S0 or even M106 S20. Then it needs M106 S80 or higher to restart it. Can you confirm that you have the fan connected directly to the FAN0 pins, and nothing else connected to those pins?



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Fan 0 always ON
February 19, 2016 04:59PM
Yes i can comfirn that i have only a 2 wire fan on Fan0. When i power on the board , the led near the fan0 pins is On and the fan start spining.
I'm at work for now. Will do more test tomorow.
Re: Fan 0 always ON
February 19, 2016 06:20PM
Quote
Cammi
Yes i can comfirn that i have only a 2 wire fan on Fan0. When i power on the board , the led near the fan0 pins is On and the fan start spining.
I'm at work for now. Will do more test tomorow.

Can you confirm that you are using firmware 1.09r-dc42 and that you have removed the M106 I1 command from config.g?



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Fan 0 always ON
February 19, 2016 07:47PM
Yes i confirm for the firmware and the config file. Very strange problem. Is it possible that this pins are defect? I don't think so because I can increase and decrease the speed.
Re: Fan 0 always ON
February 20, 2016 03:02AM
I guess it's possible that there is a fault on the board, but it seems unlikely to me.

What happens when you use smaller and smaller S values, e.g. 0.1, 0.01, 0.001? Does the led get dimmer and dimmer but then return to full on when you use S0, or something else? If you send M106 S0 and then just M106, what does it report?



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Fan 0 always ON
February 20, 2016 07:41AM
i have try smaller increment with S . I can see the light brightness changing.

I have made a small video where i'm changing the speed of the fan0 :[youtu.be]

M106 state after M106 S0 in attachement.
Attachments:
open | download - IMG_20160220_133122.png (312.9 KB)
Re: Fan 0 always ON
February 20, 2016 10:05AM
Quote
Cammi
i have try smaller increment with S . I can see the light brightness changing.

I have made a small video where i'm changing the speed of the fan0 :[youtu.be]

M106 state after M106 S0 in attachement.

Sorry, I have no broadband at present so I can't watch videos.



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Fan 0 always ON
February 20, 2016 10:10AM
On the video , we can just hear the fan increase /decrease and th led that is changing a little.

Is there a way to use fan1 instead of fan0 for my layer fan? With Marlin/repetier firmware , i know how to change pin assignation but with reprapfirmware...
Sorry, only registered users may post in this forum.

Click here to login