Welcome! Log In Create A New Profile


Z-probe problem on Duet

Posted by frek.32 
Z-probe problem on Duet
September 23, 2016 05:05AM
I have a problem with the Z probe.

My configuration:
Duet 0.6 with expansion board
3-Wire Inductive Proximity Sensor NPN LJ12A3-4-Z/AX

E0 motor is connected to the expansion board (E1 pin header) and I use M584 E4 in the config.g to map it to the suitable driver.
Following the documentation I connect the output wire of the sensor (black cable) to the cathode of a diode, the anode of the diode to the E0 STP pin (in my case is the STOP pin on the E1 pin header on the expansion board), the sensor ground wire(blue) to ground and the sensor power wire (brown) to Vin pin on the E1 pin header on the expansion board. In the config.g I also add:

M574 X1 Y1 E1 S1 ; set endstop configuration
M558 P4 X0 Y0 Z1 ; enable Z probe, mode 4 for NPN inductive sensor

The problem is that when I try M119 command in pronterface Z probe is always at min stop, even when the sensor doesn't touch the bed. The LED of E1 pin header seems to work because every time the Zprobe touches the bed the LED goes off.

Any ideas what I am doing wrong? Thank you!
Re: Z-probe problem on Duet
September 23, 2016 06:28AM
Remapping the E0 extruder drive to E1 doesn't remap the E0 endstop input. So you should connect the inductive sensor to E0 not to E1.

Large delta printer [miscsolutions.wordpress.com], E3D tool changer, Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Z-probe problem on Duet
September 23, 2016 07:52AM
Thanks dc42 for your quick response!

I tried connect it to the E0_Mot but again it didnt work. Then I connect it at the Z_MOT and it seems that the Z probe is working now (change the state from "at min stop" to "not stopped".

It there a pin in Duet board that I can use for Vin??

Edited 1 time(s). Last edit at 09/23/2016 11:15AM by frek.32.
Sorry, only registered users may post in this forum.

Click here to login