Welcome! Log In Create A New Profile

Advanced

My endstops do not work? (RADDS + Kossel Delta)

Posted by Lobotomy 
My endstops do not work? (RADDS + Kossel Delta)
December 17, 2017 03:23PM
Hi, I have been scouring the internet for weeks trying to get my Arduino Due + RADDS 1.5 + PanelDue set up for my Kossel printer. I am using the dc42 fork of RRF, and I must say, if you're reading this, dc42, your work on the firmware and PanelDue are absolutely fantastic.

I have everything but two things working just fine, my nozzle heats up, my motors move, my bed (theoretically) heats up, and my steppers are moving in the correct direction.
The only things I have left to do are figure out how to assign my bowden motor to a "tool", and more importantly, get my endstops to register any kind of input.

When I put in my M119 code, this is output when M574 is set to S1, and the printer behaves as though it has hit all of the endstops, and is moving down to deactivate the switches:



Setting M574 to S0 shows opposite results for X Y Z, and the motors move the effector up in an attempt to home. However, inputting the code with one of the microswitches held down, does absolutely nothing to affect the result. Trying to home the printer this way also obviously results in carriage crash.
I don't know if it's worth mentioning, but my Z-Probe is NOT currently plugged in, and I have it disabled via M558 P0 anyway, so I don't know what to make of it.

This is my endstops portion of config.g:
; Endstops
M211 X1 Y1 Z1 S1               ; enables endstops XYZ max
M574 X2 Y2 Z2 S1               ; all endstops at high end, active high
M558 P0 X0 Y0 Z0 H5 F120 T6000 ; Set Z probe type to unmodulated, the axes for which it is used and the dive height + speeds P4 for Z Probe, P0 for none
G31 P500 X0 Y0 Z2.5 ; Set Z probe trigger value, offset and trigger height
M557 R116 S20 ; Define mesh grid

Does anyone know why my endstops would register absolutely nothing, regardless of their open/closed status? I also included my config.g, on the off chance that someone finds anything wrong with it that could be causing this.

Thanks in advance for the help. Moving from Marlin/RAMPS, to 32-bit is a LOT to take in!

Edited 4 time(s). Last edit at 12/17/2017 03:38PM by Lobotomy.
Attachments:
open | download - config.g (2.5 KB)
Re: My endstops do not work? (RADDS + Kossel Delta)
December 17, 2017 04:35PM
Remove the M211 command, it does nothing. RRF uses the same endstop connections whether you are using min or max endstops. So if RADDS provides separate min and max endstop inputs, you may need to use the min endstop inputs not the max ones.


Delta printer calibration calculator, mini IR Z probe, and colour touch screen control panel: [escher3d.com]

Large delta printer, and other 3D printer blog postings: [miscsolutions.wordpress.com]

Disclosure: I have a financial interest in sales of the Panel Due, Mini IR height sensor, and Duet WiFi/Duet Ethernet.
Re: My endstops do not work? (RADDS + Kossel Delta)
December 17, 2017 08:59PM
Thank you, dc42, that did end up working. Weird how it's set up like that, I thought of moving all of my endstops to min, but decided against it because it sounded stupid! Shows what I know!

It now homes correctly. Do you know if there's any way to have Marlin-Style delta homing, where it homes each tower individually in the first pass, then doing all of them at once in the second? Also, does this mean I should put my Z-Probe in the Z Max slot then, or am I just unable to use one at all now?

Edited 2 time(s). Last edit at 12/17/2017 09:01PM by Lobotomy.
Re: My endstops do not work? (RADDS + Kossel Delta)
December 18, 2017 02:25AM
Quote

It now homes correctly. Do you know if there's any way to have Marlin-Style delta homing, where it homes each tower individually in the first pass, then doing all of them at once in the second? Also, does this mean I should put my Z-Probe in the Z Max slot then, or am I just unable to use one at all now?

The Z-probe on RADDS goes to "PWM3" header on the Servo header bank ( usually unpopulated, so soldering is required )


You also have to change the line to Z1 to enable z-probe.
M558 P0 X0 Y0 Z1 H5 F120 T6000 ;

Re: My endstops do not work? (RADDS + Kossel Delta)
December 18, 2017 05:06AM
You can home the printer however you like, because the homing sequence is defined in the homedelta.g file on the SD card.

Homing all the towers individually to start with sounds like a very bad idea to me, because it can't be done from some starting positions. What I think you mean is home the towers together in the first pass and separately in the second pass. You could modify homedelta.g to do that, but what would be the point?


Delta printer calibration calculator, mini IR Z probe, and colour touch screen control panel: [escher3d.com]

Large delta printer, and other 3D printer blog postings: [miscsolutions.wordpress.com]

Disclosure: I have a financial interest in sales of the Panel Due, Mini IR height sensor, and Duet WiFi/Duet Ethernet.
Re: My endstops do not work? (RADDS + Kossel Delta)
December 18, 2017 11:04PM
@o lampe Unusual that it would be in the PWM header instead of just having it done though endstop pins, but I suppose that does free things up for printers that actually do use min and max endstops. I guess I have more soldering to do. It's a good thing I think this hobby is fun.

@dc42 Yes, I did mean the reverse of what I said. Oh, and I want the behaviour for purely aesthetic reasons. I just think it looks neat. I'll look into making it work on my own later.
Re: My endstops do not work? (RADDS + Kossel Delta)
December 19, 2017 03:19AM
Quote

@o lampe Unusual that it would be in the PWM header instead of just having it done though endstop pins, but I suppose that does free things up for printers that actually do use min and max endstops. I guess I have more soldering to do. It's a good thing I think this hobby is fun.

RADDS was made to run with a different FW. ( Repetier IIRC ) and then got adapted to RRF. It was so successful, that the guy who made the adaption got cold feed and left the building. Maybe we overwhelmed him with add on requests and questions....?
Sorry, only registered users may post in this forum.

Click here to login