Welcome! Log In Create A New Profile

Advanced

So many problems

Posted by JustSumGuy 
So many problems
April 20, 2018 05:35PM
Ok, so after getting my Duet Wifi HyperCube EVO actually up and running and even printing after I got the BL-Touch calibrated M31 z offset bed mesh and everything I was walking on air.
Then I shut it down, came back the next day and NOTHING I could figure out would solve the issue, I would home all, them move the head to bed center, lower to Z0 and test, it was touching the build plate.
start the gcode file that I had printed the day before, print head was 2mm or so high.
After f*&^% with that for a few days I gave up, decided to start from point ZERO!!
Some reading on others issues with BLT and FW 1.21 I decided to downgrade to 1.20
I flashed in webcontrol and wifi server fine, they are now 1.20 but I cannot get the DuetWiFiFirmware.bin to flash in. It uploads fine, but when I Perform Firmware upgrade I get:


× M997 S0

Error: M997: Firmware binary "Duet2CombinedFirmware.bin" not found

any ideas?

also how should I go about restoring the system to "out of the box" config?
Just use the web interface and delete every file in the system editor tab?

I am still impressed with the Duet, dont get me wrong. I am just not that good with it yet smiling smiley
Re: So many problems
April 21, 2018 04:03AM
At version 1.21 we moved to a single firmware binary for the Duet WiFi and Duet Ethernet. As part of that change, the file name that the firmware expects to see was changed. So to downgrade 1.21 to 1.20, rename the 1.20 version of file DuetWiFiFirmware.bin to Duet2CombinedFirmware.bin, then upload it through the Settings General page of DuetWebControl.


Delta printer calibration calculator, mini IR Z probe, and colour touch screen control panel: [escher3d.com]

Large delta printer, and other 3D printer blog postings: [miscsolutions.wordpress.com]

Disclosure: I have a financial interest in sales of the Panel Due, Mini IR height sensor, and Duet WiFi/Duet Ethernet.
Re: So many problems
April 21, 2018 10:08AM
Thanx DC42 but I still got:

× M997 S0

Error: M997: In-application programming binary "iap4e.bin" not found

SO I took that file from 1.21 and uploaded it, then it took the renamed 1.20 file

After that I deleted all files showing in the system editor tab and rebooted. Now showing 1.20 on firmware.

Have I created any problems with this procedure?

I have connected by USB now and re-setup my wifi connection. I have to M552 S1 on every boot tho?
I am guessing this is because I have no config.g yet. Confirmed
Starting at the RRF config tool now.

When useing BL Touch is it normal to have to rewrite the homez.g file with BLT commands?

Is there any intent to add Bl Touch to the RRF Configuration Tool?

Edited 1 time(s). Last edit at 04/21/2018 11:10AM by JustSumGuy.
Re: So many problems
April 21, 2018 02:23PM
Not getting anywhere in the last 5 hrs

BLT works:
M280 P3 S10 I1 - YUP pin goes down
M280 P3 S90 I1 - YUP pin goes up
Z-Probe Value always = 1000 EDIT: I found the I1 value in config G on the M558 line, I got a Z home finally, I gotta stop now, to frustrated, take this win and start over again tomorrow...
created deploybrob.g and retractprobe.g so all good on that.

Discovered the P9 setting for 1.21 and BL Touch, I was using P5 so I figured I would go back to 1.21 try that.
In the last five hours I have not been able to home Z even once.

G28 Z

Error: Z probe already triggered at start of probing move
Error: Homing failed

I do recall that back when I did get it going under 1.21 I had to edit the homeall.g and homez.g files, I forgot to save what I did before I wiped it all.
I dont recall what I did, so many tests tries so many things I have read, I am now a jumble of 4 months worth of information, trial and error, and VERY limited success....

Information overload... one successful bed mesh working print.. I know its all connected properly, I just dont know how to make it work...

Four months man..... I may just go back to marlin 8 bit controller.....


Attached is my full system folder...

Edited 2 time(s). Last edit at 04/21/2018 02:37PM by JustSumGuy.
Attachments:
open | download - download.zip (75 KB)
Re: So many problems
April 21, 2018 03:24PM
Why did you delete all the files in /sys? Now you need to re-create the config.g and homing files. I suggest you use the configurator at [configurator.reprapfirmware.org].

PS - you will get a faster response to your questions if you post them on the forum at [forum.duet3d.com].

Edited 1 time(s). Last edit at 04/21/2018 03:27PM by dc42.


Delta printer calibration calculator, mini IR Z probe, and colour touch screen control panel: [escher3d.com]

Large delta printer, and other 3D printer blog postings: [miscsolutions.wordpress.com]

Disclosure: I have a financial interest in sales of the Panel Due, Mini IR height sensor, and Duet WiFi/Duet Ethernet.
Re: So many problems
April 21, 2018 06:12PM
Quote
dc42
Why did you delete all the files in /sys? Now you need to re-create the config.g and homing files. I suggest you use the configurator at [configurator.reprapfirmware.org].

PS - you will get a faster response to your questions if you post them on the forum at [forum.duet3d.com].

I wiped my system folder because I could not figure out what I did wrong, decided to start from a fresh configuration, as per the second question in my first post.

I am just more comfortable in this forum after working my knowledge up via the marlin assistance here.
I have two printers now, well, one and a half..... a full working marlin based printer and a half working Duet based one smiling smiley
I would like to work in one forum rather than split it up.
Re: So many problems
April 22, 2018 12:00PM
Ok. Todays work turned out quite fruitful...

Turns out going back to point zero was a good idea. Got rid of a bunch of leftover bad info and worked only with things I was happy with.
Found that there was a type 9 probe in 1.21 ( I was using type 5 in 1.21 b4) so I decided to go back to 1.21 after messing with 1.20 and type 5
Used the RRF tool to build my basic setup and then changed probe type to 9 followed up on the rest of the setting info for BL Touch.
LEFT homz.g alone and homeall.g as well, no changes this time....

Today I got a proper bed level, proper mesh and a small test print.
After that I powered it down for a bit and brought it back up and my bed mesh was still visible, but it was not being used, I ran bed mesh again and it used it fine. My problem of the print head being 2mm high on print regardless that Z0 was touching the plate is resolved!!

Question:
How can I call on the stored bed mesh on boot up?

Thanx
Re: So many problems
May 13, 2018 05:39PM
M375 ; Load heightmap.csv
Re: So many problems
May 14, 2018 01:23AM
Quote

Question:
How can I call on the stored bed mesh on boot up?

G29 S1 in slic3r start code

Edited 1 time(s). Last edit at 05/14/2018 01:23AM by o_lampe.
Re: So many problems
May 14, 2018 05:29PM
TQVM!!
Sorry, only registered users may post in this forum.

Click here to login