Welcome! Log In Create A New Profile


babystep problem happened on release 2.02

Posted by Brummie 
babystep problem happened on release 2.02
January 06, 2019 12:39AM

this time, the step-misunderstanding happened after successfully completing a print job (without any action from me).
I uploaded a new file for the next print job and on start the webapp raised the error, that some axis could not be homed.
I didn't have that error bevor - so I stopped the print job and tried to home the axis manually.
Motorsound startet, but no axis moved (well, the move may be so small, that I didn't noticed).

I had to reset the firmware to get it working again. After reset the firmware worked as expected.
Re: babystep problem happened on release 2.02
January 22, 2019 01:27AM

this night another multiday printjob failed with "babysteps".
I turned the printer off in the night.
Today in the morning I turned the printer on and everything looks ok.

While it may be my fault, when this happens with prereleases, it should not happen with final releases.
I have no idea, about the source of evil and I was willing to help.
But I was told that debugging does not help on finding the cause ...

So - although I love all functionality of duet3D I have to think for replacement, since it is not reliable.
Together with the temperature issue it seems, that duet3D is not, what I expected it to be.
I'm so sorry about that!
Re: babystep problem happened on release 2.02
January 22, 2019 02:55AM

this night another multiday printjob failed with "babysteps".

Please explain what you mean by that.

Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: babystep problem happened on release 2.02
January 22, 2019 06:59AM

its the same failure as described here.

During print software reduces stepsize for steppers, but forgets to adapt the software stepsize.
(well, from my understanding, changing stepsize during printjob should not be possible).

Printjob was ok for about 6 hours, than I went to bed and don't know what happens.
When I woke up tonight, printer was less loud than expected - so I checked and printhead has arised about 5mm and was moving outside of printarea with microsteps (so small, that no movement can be noted visibly).

As no unordered filament was there, I thought, that extruder might have destroyed filament.
But today in the morning I heated the nozzle to printing temperature and extrusion by printer management buttons worked fine.

So the change of stepsize during print is nothing stable - I don't have a gcode where I could state: error will happen here.
But it happens - more often, than I like to. Four times in two months - too much for me (well, two of them happened with prerelease, so my fault).
Sorry, only registered users may post in this forum.

Click here to login