Didn't find anything in troubleshooting, but Smoothieboard not connecting to Pronter?
February 17, 2017 08:17PM
Kossel style delta printer, I can connect via USB and was able to change over the config file from the stock it's shipped with to a Delta file updated with my specs so there's no issue with the connection there, but when I open Pronterface and try to connect I get:
[ERROR] Could not connect to COM3 at baudrate 115200:
Serial error: could not open port COM3: [Error 5] Access is denied.

I've tried playing around with the baudrate, playing with the COM ports, nothing seems to be working.

Anyone have any thoughts?
Hrm. Changing to some random com port I get:
Traceback (most recent call last):
File "printrun\pronterface.pyc", line 1053, in connect
File "printrun\pronsole.pyc", line 720, in connect_to_printer
File "printrun\printcore.pyc", line 46, in inner
File "printrun\printcore.pyc", line 197, in connect
File "serial\serialwin32.pyc", line 31, in init
File "serial\serialutil.pyc", line 261, in init
File "serial\serialwin32.pyc", line 71, in open
File "serial\serialwin32.pyc", line 186, in _reconfigurePort
ValueError: Cannot configure port, some setting was wrong. Original message: [Error 31] A device attached to the system is not functioning.
That's not a smoothie problem. That's an extremely common windows problem. Disconnect and power down the smoothieboard and log out of windows. Log back in then plug the smoothieboard back in.

Did you set the baud rate in the config file to 115200?

This sort of BS is why I prefer to print from SD cards.

Edited 1 time(s). Last edit at 02/17/2017 10:00PM by the_digital_dentist.

Ultra MegaMax Dominator 3D printer: [drmrehorst.blogspot.com]
I'll try that. Does it make sense that using pronsole I can connect?
If I do, I get:

Welcome to the printer console! Type "help" for a list of available commands.
[01moffline>[00m help

Documented commands (type help ):
bedtemp exit home move resume set upload
block_until_online extrude load off reverse settemp
connect gcodes ls pause run_gcode_script shell
disconnect gettemp macro print run_script slice
eta help monitor reset sdprint tool

Undocumented commands:

[01moffline>[00m shell
[01moffline>[00m connect
No port specified - connecting to COM10 at 115200bps
Printer is now online
[01mT:23>[00m home
[01mT:23>[00m [ERROR] Not printing, cannot pause.
[01mT:23>[00m [ERROR] Not printing, cannot pause.
[01mT:23>[00m pause
[ERROR] Not printing, cannot pause.
[01mT:23>[00m gettemp
Hotend: 23.7/0.0
Bed: 23.9/0.0
[01mT:23>[00m reset
[01mT:23>[00m home
[01mT:23>[00m [ERROR] Not printing, cannot pause.
[01mT:23>[00m [ERROR] Not printing, cannot pause.

I didn't change anything to 115200, so I will say that the config file was already set to that rate
Ok, connection established, reading sensors, all that fun stuff.

Now I try to move the extruder head and I get "Print paused at:blah blah blah"
Now it's connecting and I've apparently got some issue with the settings. I think I can fix that on my own, hopefully.

Is there any more info you can give me on the connection issues that are a common problem? I'd like to be able to try out fixes in an attempt to get one be permanent.
If you reset the controller via pronterface and don't disconnect before the board actually resets, the computer OS will assign the board to a different com port when it boots up because pronterface is using the original port that was assigned. Also, you should "eject" the uSD card on the controller board before you reset the controller. If you don't, the file system on the uSD card will get corrupted by the computer OS (especially Windows) and the printer will start to misbehave in mysterious ways. If the printer ever starts doing weird things that don't seem to respond to config changes, you will need to reformat the uSD card and recopy your config and firmware files back to it to restore normal behavior. Keep your config and firmware files backed up! The proper sequence for rebooting the controller via pronterface is
1) eject the uSD card (if your OS automatically mounts it),
2) send the @reset command via pronterface,
3) disconnect pronterface from the printer (within 5 sec of having sent the reset command!)

A computer has about 100 ways to kill/ruin your print, and is completely unnecessary. You can try to ferret out all the necessary config changes to your computer to prevent it from doing things like going to sleep in the middle of a print, but the longer your prints get, the more obscure the computer OS problems get. You'll get it working for a 20 hour print, then you'll try a 36 hour print that will fail 35 hours in. Failures invariably occur in the last hour of long prints (thank Murphy for that), so you waste maximum time and materials. Forgetting weird OS issues, USB cables can be problematic- someone can disconnect them, your cat might chew through them, etc. Your cat or kid may come along and bang on the keyboard, knock the computer on the floor, disconnect power, etc.

This is why I prefer printing from SD card via an LCD panel instead of using a computer. The potential for failure is greatly reduced.

Ultra MegaMax Dominator 3D printer: [drmrehorst.blogspot.com]
Interesting, I'll look into using an SD card later on, but I still have some config issues I'm trying to straighten out.
I have an LCD screen and an associated SD card holder that came with the printer, but I haven't looked into how to connect it to the Smoothieboard.

Thanks for your thoughts on it.
I'm running under WinXP. The process for updating the config file, as I understand it is:
1) edit the config file (gedit is the editor I use)
2) eject the uSD card - windows complains "An Error occurred trying to Eject 'Removable Disk F:'
the card has been mounted directly on my desktop & scanned by windows it's ok!
3) send the @reset command via pronterface,
4) disconnect pronterface from the printer (within 5 sec of having sent the reset command!) - done before the beep!
following these steps I get the classic Windows Error message "Could not connect to COM8...".. The system cannot find the specified file.
has anyone else gotten this to work? Am I missing a step?

I have used the more tedious process, (ie not using pronterface to initiate the reset)
1) edit config
2) if connected, disconnect Pronterface
3) unplug smoothie USB cable from computer
4) using plastic tool, hit reset on smoothieboard
5) wait for reset to complete
6) plug USB cable back in
7) wait for windows to recognize disk drive
8) re-connect via pronterface..

it's easier than rebooting windows every time, but still not fun..

Frank Pirz
Media Conversions LLC
Have you loaded the Windows drivers?
Sorry, only registered users may post in this forum.

Click here to login