Welcome! Log In Create A New Profile


Migrating setup endstop issues

Posted by jonawald 
Migrating setup endstop issues
November 03, 2017 04:15PM
Hi all. I'm migrating my printer from Ramps 1.4 to MKS 1.3. For some reason my optical endstops do not work with the smoothie board. They worked fine with ramps. The endstops are opto devices from an old photocopier. with a small board with resistors and an LED that I added. The LED is on when the light is not interrupted and off when it is interrupted. I have tried with the jumper on 5v and on 3V I have also tried reversing the plug.

I have inverted the endstop signal in configure. I have also tried with and with out a pullup resistor. What am I missing?

I would simply switch out to mechanical endstops but these are wired in and ready to go. I know they work.

EDIT: I know they don't look the greatest underneath, but they did work for about half a year before this upgrade.

Edited 1 time(s). Last edit at 11/03/2017 04:16PM by jonawald.
open | download - IMG_20171103_151058264.jpg (474.5 KB)
open | download - IMG_20171103_151046414.jpg (346.1 KB)
Re: Migrating setup endstop issues (Solved)
November 21, 2017 01:27PM
I got around this problem by changing back to the old mechanical endstops. It got the printer going. Sorry I couldn't help anybody work this issue out.
Sorry, only registered users may post in this forum.

Click here to login