Welcome! Log In Create A New Profile

Advanced

Auto level does not seem to be working

Posted by StlLooking 
Auto level does not seem to be working
August 23, 2018 07:00PM
Hi All,

It is the latest Smoothie version from GitHub, edge-24da5ce

The pic is what I got. It's a glass bed on top of shiny aluminum so please ignore the double images.
The important part is the thinning at the back. The glass is perfectly flat. And, yes I do have the M375 command in the GCode file.

Am I doing something wrong with the sequence below?

This is what I did with micro-switch probe.

PROBE LEVELS
G28 (Home XYZ)
 1:    G32       Calibrate the machine
 2:    M500      Save probe results
 3:    G28       Home XYZ and the Jog down and Touch Bed
 4:    M306 Z0   Set and Save the Z-Offset
 5:    M500      Save homing offset
 6:    G28

GRID MESH
 1:    G28       Home XYZ
 2:    G31       Probe the grid
 3:    M374      Save grid to SD card
 4:    M500      Save probe results
 5:    M375      Add Grid command to SD card
 6:    G28       Home XYZ and the Jog down and Touch Bed
 7:    M306 Z0   Set and Save the Z-Offset
 8:    M500      Save homing offset
 9:    G28

Edited 2 time(s). Last edit at 08/23/2018 07:05PM by StlLooking.
Attachments:
open | download - smoothie-01.jpg (43.8 KB)
Re: Auto level does not seem to be working
August 24, 2018 07:48AM
This could simply be something with how the probe measurements are done, interracting in a weird way with your machine geometry. Can you try changing ( increasing or reducing ) the grid resolution and seeing if it changes the effect ?
Re: Auto level does not seem to be working
August 24, 2018 11:44AM
Thanks for th reply, I am redesigning the probe to give a more direct switching motion for the micro-switch.

The current version uses a sliding rod to trip the switch. I am now mounting the switch directly at the bottom of the probe and that will contact the glass directly.

Will try again when new mount is done and get back you.
Re: Auto level does not seem to be working
August 28, 2018 02:29PM
Quote
arthurwolf
This could simply be something with how the probe measurements are done, interracting in a weird way with your machine geometry. Can you try changing ( increasing or reducing ) the grid resolution and seeing if it changes the effect ?

OK, it might have been partly the probe as I made a rigid mounted micro-switch version using a special Omron switch designed for such probing use. Like the one shown in this assembly.
[www.amazon.com]

Anyway, the leveling improved a little but the first layer is still thin in the rear as the OP-pic showed. It is definitely not the glass as I checked that on my granite surface plate. The only thing that changed when using different grid resolutions etc was that the thin section rotated slightly (about 5-deg) to the right or left.

For it to be thin over such a short section -and- rotating slightly left/right, seems to indicate the algorithm.
Re: Auto level does not seem to be working
August 28, 2018 06:01PM
Well, the algorithm is known to work perfectly on perfect surfaces.

It might be over-reacting to something barely detectable though, maybe due to some lack of luck with how the grid aligns with the physical thing ? Maybe .. it's all speculation really, I can't really think of anything obvious.
Re: Auto level does not seem to be working
August 30, 2018 02:32PM
Thanks, about ready to give up on the Deltas. Time to experiment with the CoreXY. Seems like it might be the best of both worlds for Delta-speed and Cartesian-accuracy.
Re: Auto level does not seem to be working
August 30, 2018 02:47PM
I think the effect you are seeing is really the result of an extremely small height difference, and if you just increased your initial layer height by a very small value ( maybe 0.05mm or even less ) you wouldn't see it anymore and you could print just fine. Sometimes "a bit less than perfect" is good enough smiling smiley
Re: Auto level does not seem to be working
December 18, 2018 03:04PM
I have been using Smoothie on my Anycubic Delta without the auto-level after adjusting my bed to be level with the head. I am still using the same heated bed and Borocilcate glass and decided to move up to a 110v Silicon heating for faster warm up times. This meant resetting the bed level.

After the 110v install and being somewhat tenacious, I decided to give the auto-level one more try. I downloaded the latest Stable .bin and installed it. Hooked the probe in and let Smoothie G31 it have at it. It seems like a lot more touch-points have been added, a good start I thought.

But the first test print with 0.2mm Initial-layer and 0.15mm run-layer height gave me pic 1, the same as the first time around many months back.


I turned the glass around CCW through about 90 degrees and tried again and viola, high point is still off the back column. Pic 2.


Taking AW's above suggestion to heart, I added 0.05mm to the Z-offset and got Pic 3 as the Z offset for the "good" sections is too high for a reliable stick.


Oh, well, back to levelling the glass to the head manually and abandoning all hope for auto-levelling.

I really like a lot about Smoothieware, but the auto-levelling and PID-tuning are not on that list, well, not yet. smiling smiley

Edited 1 time(s). Last edit at 12/18/2018 03:05PM by StlLooking.
Re: Auto level does not seem to be working
December 21, 2018 09:06AM
@arthurwolf: Anything? Ignoring? No idea? Anyone reading these anymore?

It just occurred to me that where that light-spot is, is where the probe stops at the end of the G31 cycle. Could this be something not being recorded correctly before it lifts at that last position and then waits for me to do the M374+M500 etc?
Re: Auto level does not seem to be working
December 21, 2018 09:08AM
Can I see your config ? Do you have calibration enabled or both calibration and grid levelling ?
Re: Auto level does not seem to be working
December 22, 2018 11:18AM
Quote
arthurwolf
Can I see your config ? Do you have calibration enabled or both calibration and grid levelling ?

Thanks, I have both Calibration and Grid Levelling set to True as I described the process in the OP above.

Should I only have ONE defined? I will turn off Calibration, do another Levelling and get back to you with the Config if still no joy.
Re: Auto level does not seem to be working
December 22, 2018 11:21AM
No you probably should have both, just trying to understand your setup to be able to help. Will wait for config.
Re: Auto level does not seem to be working
December 23, 2018 11:25AM
OK, as to the the config: I took Smoothieboard.delta/config from GitHub and changed the Steps from 100 to 80, the arm length to 251.5 and the offset 114.14 and that's it. More of the same ol', same ol'. Exact same high spot. Not sure why you seem to keep thinking this is my printer's fault. Clearly turning the glass 90-degrees and the high-spot staying there means something.

I printed up (on my old Marlin-based and reliable, but slow, i3) a holder for a dial indicator to replace the hotend in the effector. I wrote some GCode to probe the bed and have adjusted it level to the Delta mechanism using pieces of metal shims under the bed. The thickest shim is 0.006" (Inches, about 0.15mm) so clearly, not far not off level to start with. For now it is printing OK.

BUT - The point is now moot as I will not waste any more time on this. I am going to rip out the board and install a Duet.
Re: Auto level does not seem to be working
December 23, 2018 01:13PM
Hey.

* Please give me your config. Just use pastebin.com and post the link here, it's very easy. I can't help you without your full cooperation.
* I have never said anything was your printer's fault, at this point I don't know enough to make a determination anyway. From experience, relating to problems like this I've seen before, this is likely a small problem with frame squareness ( the "turn glass 90 degrees" test indicates this strongly ) ( again : I'm not sure, this is just my best bet at this point ), but correctly setting up calibration and levelling *should* compensate for it, and if we work together it's likely we'll get it to work.
* You seem to get upset and jump boats way too easily, if you could explain what led to this I'd appreciate it, because I have no idea why you'd get upset here, I certainly didn't mean to offend, just to help ...
* I help thousands of Smoothie users a year, for years now, I'm yet to find one that we can't make happy, *as long* as they don't give up way before it is reasonable to do so ...
Re: Auto level does not seem to be working
December 23, 2018 03:12PM
Although I'd love you to buy a Duet, in fairness to Arthur you haven't given him the information he has asked for about your configuration. It's also not clear whether you are using a genuine Smoothieboard or one of the parasitic clones of the Smoothieboard design. If your Z probe is offset from the nozzle, then the problems you describe could be due to the tilt of the effector varying with XY position, which is a very common problem on delta printers.



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Sorry, only registered users may post in this forum.

Click here to login