Welcome! Log In Create A New Profile


[Solved] Azteeg x5 GT with BSD2660, dual Z axis problems.

Posted by xnopasaranx 
[Solved] Azteeg x5 GT with BSD2660, dual Z axis problems.
May 10, 2020 08:33AM
Hi dear reprap people,
I tried to compile marlin 2.x.x for my new azteeg X5 gt, but had severe problems that I was not able to debug as of yet, so I decided to give smoothieware another shot. I flashed the latest stable release.

@Diggr gave me a tipp on how to get dual Z axis working with smoothieware so I am trying to get that running.
Dual Z in smoothieware isn't too hard once you find the near impossible to find clues. LOL
Herculien's machine gave me the clues, as his has a dual z.

First, Copy your config.txt off to the side or add a 1 to the copy's filename, so you have an untouched/unchanged reference.
There's 3 jumpers next to the E1 driver socket [JM6]. Connect them with 3 jumpers. This locks both E sockets in step with each other.
Then you swap numbers in the config.txt, the E1 pin numbers go in the Z part of the config, and Z pin numbers into the E1 part.
Your extruder motor will plug into the Z socket, and your two Z motors will plug into the two E sockets.
If your config.txt has the section for a second extruder, comment all those lines out. Mentioning the E2 pins anywhere will cause problems.
No need to increase current for Z, both are set to what you set for Z in config.txt (aka a single motors current needs).

As for the 2660's, I wasn't that successful with them. I use the 6128's.
I have everything configured regarding the axis and stepper drivers, but I have problems on my dual Z axis. I am using pronterface to test, sadly smoothieware does not seem to have an option for TMC2660 debugging, like marlin has or I haven't found it yet.

Following Diggrs advice and some sparse info I found in online, I bridged JM6 with 3 jumpers to drive E1 and E2 in sync and map those drivers to the Z in my config.
I can drive my X and Y axis no problem, but when I test the Z, console shows an error: "Channel A seems to be unconnected"... But what does channel A mean? Is this a reference to the A and B coils in one of the steppers? Does this mean the driver E1 as in channel A of the synchronous setup (E1 being channel A and E2 channel B )?

I am unsure if this is just an electrical problem, as I tested everything for continuity. I will need to test more though.
UPDATE: with both motors disconnected, the same error is thrown. I guess it's not electrical. Will switch the drivers now to rule out a bad one.
UPDATE2: fresh drivers in E1 and E2, still the same error. Maybe the socket on the azteeg pcb? But I would like to know if that is what his error message means first before I rip everything apart again...

The stepper motors in use are some creality "branded" motors, as I am trying to upgrade a heavily modded CR-10s here.

It would be really great if someone could take a look at my config and check if everything is correct here.

Edited 5 time(s). Last edit at 05/10/2020 11:17AM by xnopasaranx.
open | download - config (25 KB)
Re: Azteeg x5 GT with BSD2660, dual Z axis problems.
May 10, 2020 09:13AM
Oh that was embarrassing... I found the problem myself in the config file. I made a copy and paste error when reassigning the pins of the drivers and thus delta driver was not responding.
It was late last night, I am testing the Z axis now.

UPDATE: error is gone but the Z still does not move. Wiring is correct, I checked continuity again.

Would be nice if someone still took a look at my current config though, just to reassure me I am not doing anything else stupid. Thermistors and hot parts have not been configured yet, that will be next.

Attached is my current config with the fix. Note the changes in line 135/136

Edited 1 time(s). Last edit at 05/10/2020 09:23AM by xnopasaranx.
open | download - config (25 KB)
Re: Azteeg x5 GT with BSD2660, dual Z axis problems.
May 10, 2020 11:16AM
Good, more confusion about pin remapping... apparently I had totally overseen to switch the gamma and extruder step and dir pins. The Z axis is moving now.

On to getting the sensors, heaters and extruder working. Although noone was able to answer while I was testing and I super quickly found my own mistakes, I still think I will upload my config here in case anyone tries to achieve the same slave stepper setup and would like a peek. Maybe it will be helpful to another confused sould.
open | download - config (25.4 KB)
Re: [Solved] Azteeg x5 GT with BSD2660, dual Z axis problems.
May 19, 2020 01:24PM
Nice work!
Sorry, only registered users may post in this forum.

Click here to login