Welcome! Log In Create A New Profile

Advanced

Mika 3D Hilfe ich komme nicht weiter sad smiley

Posted by Elektroniker 
Mika 3D Hilfe ich komme nicht weiter sad smiley
January 27, 2019 02:57PM
Hallo liebe User,

ich habe mir den Mika 3D von Behnke Engineerings nachgebaut. Die Software wird auch von Behnke Engineerings bereitgestellt.
Der Drucker ist soweit fertig, bloß komme ich nicht mit der Einrichtung der Software und mit der Einstellung des Induktiven Sensor für die Z-Achse zurecht.

Die Tests habe ich mit dem Repetier Host und Pronterface gemacht. Die Motoren fahren zwar alle, das Hot End und das Bett heizen sich auch auf.

Allerdings funktioniert das Homing nicht. Der Druckkopf sollte ja auf die zwei bzw. drei Endschalter fahren um seinen Bezugspunkt zu haben oder?
Leider fahren meine Achsen nur immer ein Stück und verwirrt irgendwo hin. Hab auch schon die Stecker gedreht aber nichts funktioniert.

Dann habe ich mal einen Druck gestartet, er macht schon die richtige Bewegung für das Druckstück, war aber sinnlos, da die Düse und das Druckbett einen falschen Abstand haben.
Auch das extrudieren geht anscheinend zu schnell, da das Antriebsrad das Filament abhobelt und Staub produziert.

Und wie läuft das mit dem Sensor von der Z-Achse? Die fährt immer zu hoch in die Düse und geht dann ein paar mal hoch und runter.


Im Anhang mal die Configuration.h

Bin da echt verwirrt und habe keinen Durchblick mehr. Für Hilfe wäre ich echt dankbar.

Gruß vom Elektroniker



Maschinendaten:

- Arduino Mega und Ramps 1.4 aus China.
- Nema 17 Schrittmotoren
- Filafarm Heizbett 230V
- 1x Sparklab Extruder
- Carlo Gavazzi Induktiver Schalter
- Mechanische Endschalter
- 1,75mm Filament

[www.behnke-engineering.de]

Edited 1 time(s). Last edit at 01/27/2019 02:57PM by Elektroniker.
Attachments:
open | download - Configuration.h (59.1 KB)
Re: Mika 3D Hilfe ich komme nicht weiter sad smiley
January 28, 2019 08:45AM
Hallo,
da du einen induktiven Endschalter (für die Z-Achse?) hast brauchst du natürlich Metall damit dieser Schaltet. Kenne jetzt dein Druckbett nicht aber wenn du ein PCB mit Glasauflage benutzt wird das nicht funktionieren. Dann barauchst du einen kapazativen Endschalter.
Sonst habe ich noch folgenden Eintrag in deiner Config gefunden:
#define DEFAULT_MAX_FEEDRATE          { 300, 300, 5, 8 }
Der sollte laut Behnke sein:
#define DEFAULT_MAX_FEEDRATE          { 300, 300, 5, 800 }

Das hat aber nichts mit deinem Extruderproblem zu tun. Kann es sein, dass die Temperatur deines Hotends zu niedrig ist oder die Einstellungen für die Termistoren in der cofiguration.h falsch sind?

Und ist es richtig, dass du X und Y auf max homen willst?

// @section homing

// Specify here all the endstop connectors that are connected to any endstop or probe.
// Almost all printers will be using one per axis. Probes will use one or more of the
// extra connectors. Leave undefined any used for non-endstop and non-probe purposes.
//#define USE_XMIN_PLUG
//#define USE_YMIN_PLUG
#define USE_ZMIN_PLUG
#define USE_XMAX_PLUG
#define USE_YMAX_PLUG
//#define USE_ZMAX_PLUG

Ich würde auf min homen (wenn die Endschalter auf min. sein können).

// @section homing

// Specify here all the endstop connectors that are connected to any endstop or probe.
// Almost all printers will be using one per axis. Probes will use one or more of the
// extra connectors. Leave undefined any used for non-endstop and non-probe purposes.
#define USE_XMIN_PLUG
#define USE_YMIN_PLUG
#define USE_ZMIN_PLUG
//#define USE_XMAX_PLUG
//#define USE_YMAX_PLUG
//#define USE_ZMAX_PLUG


Drucker: 3D-Cube Eigenentwicklung, Ender3
Re: Mika 3D Hilfe ich komme nicht weiter sad smiley
January 29, 2019 01:55PM
Danke für deine Antwort smiling smiley

Also der Sensor schaltet da es ein Alubett ist. Mir geht es eher um die Einstellerei, damit der Abstand passt.

Wie heiß sollte das Hotend denn sein?
Was müsste ich denn bei Min und Max ändern?
Gruß
Re: Mika 3D Hilfe ich komme nicht weiter sad smiley
January 29, 2019 05:37PM
Du wirst hier schwerlich eine Antwort erhalten. Einfach die falsche Rubrik gewählt. Merkt man, wenn man den ersten Beitrag hier liest. Vielleicht kann Viktor hier mal etwas aufräumen. Dann merken es die Leute auch, wenn sie falsch liegen.

Edited 1 time(s). Last edit at 01/29/2019 05:39PM by Fridi.


Liebe Grüße aus Henstedt-Ulzburg.
Frithjof
Meine Seite
[www.facebook.com]
Das Monster kaufen bei EBAY.
[www.ebay.de]
Re: Mika 3D Hilfe ich komme nicht weiter sad smiley
January 30, 2019 05:14AM
Quote
Elektroniker
Danke für deine Antwort smiling smiley

Also der Sensor schaltet da es ein Alubett ist. Mir geht es eher um die Einstellerei, damit der Abstand passt.

Wie heiß sollte das Hotend denn sein?
Was müsste ich denn bei Min und Max ändern?
Gruß

Die Induktiven Sensoren werden eigendlich nicht großartig eingestellt. Man stellt die Höhe so ein, dass er schaltet bevor die Düse das Bett berührt und er höher ist als die Düse. Danach ermittelst du einen Z-Offset welchen du in Marlin speicherst.
Das die Endschalter 2x angefahren werden ist so. Einmal schneller und dann mit langsammer Geschwindigkeit.

Das Hotend sollte mindestens 170°C sein siehe:
#define PREVENT_COLD_EXTRUSION
#define EXTRUDE_MINTEMP 170

Bei min und max müsstest du die Endschalter so setzen, dass diese für die X- Achse links und für die Y-Achse vorne sind und dann in der Firmware:

// @section homing

// Specify here all the endstop connectors that are connected to any endstop or probe.
// Almost all printers will be using one per axis. Probes will use one or more of the
// extra connectors. Leave undefined any used for non-endstop and non-probe purposes.
#define USE_XMIN_PLUG
#define USE_YMIN_PLUG
#define USE_ZMIN_PLUG
//#define USE_XMAX_PLUG
//#define USE_YMAX_PLUG
//#define USE_ZMAX_PLUG

Edited 1 time(s). Last edit at 01/30/2019 05:14AM by Viper-666.


Drucker: 3D-Cube Eigenentwicklung, Ender3
Sorry, only registered users may post in this forum.

Click here to login