Welcome! Log In Create A New Profile

Advanced

Drucker fährt richtig auf Home, aber beim Druck startet Z auf +3

Posted by Ojeh-3D 
Drucker fährt richtig auf Home, aber beim Druck startet Z auf +3
July 08, 2019 09:45AM
Hallo - weiß jemand Rat?
Ich habe einen gebrauchten Prusa i3, den ich über meinen MacBook Pro (OS 10.13.6) ansteuere: Arduino Mega 2560, Ramps V1.4, RepRapDiscount Full Graphic Smart Controller.
Das Homing macht der Drucker astrein, alle 3 Achsen auf Null, und wenn er zu drucken beginnt, steht die Z-Achse plötzlich auf + 3 mm ... auch im Display bestätigt. Der Druck beginnt daher 3mm weit in der Luft ...
Hat jemand eine Vorstellung, was der Grund sein könnte? Nebenbei bemerkt: Mit diesem "in der Luft Drucken" hat das System irgendwann angefangen - nicht von Anfang an ...
Hat jemand einen Tipp??

Aus meinem Arduino - Configuration.h ein paar vielleicht wichtige Zeilen:
2 Marlin 3D Printer Firmware
(...)
38 #ifndef CONFIGURATION_H
39 #define CONFIGURATION_H
40 #define CONFIGURATION_H_VERSION 010109
(...)
49 * [reprap.org]
50 * [youtu.be]
51 * [calculator.josefprusa.cz]
52 * [reprap.org]
53 * [www.thingiverse.com]
54 * [sites.google.com]
55 * [www.thingiverse.com]
56 */
(...)
115 #define SERIAL_PORT 0
(...)
126 #define BAUDRATE 115000
(...)
133 #ifndef MOTHERBOARD
134 #define MOTHERBOARD BOARD_RAMPS_14_EFB
135 #endif
(...)
149 #define EXTRUDERS 1
(...)
152 #define DEFAULT_NOMINAL_FILAMENT_DIA 1.75
(...)
199 #if ENABLED(PARKING_EXTRUDER)
200 #define PARKING_EXTRUDER_SOLENOIDS_INVERT // If enabled, the solenoid is NOT magnetized with applied voltage
201 #define PARKING_EXTRUDER_SOLENOIDS_PINS_ACTIVE LOW // LOW or HIGH pin signal energizes the coil
202 #define PARKING_EXTRUDER_SOLENOIDS_DELAY 250 // Delay (ms) for magnetic field. No delay if 0 or not defined.
203 #define PARKING_EXTRUDER_PARKING_X { -78, 184 } // X positions for parking the extruders
204 #define PARKING_EXTRUDER_GRAB_DISTANCE 1 // mm to move beyond the parking point to grab the extruder
205 #define PARKING_EXTRUDER_SECURITY_RAISE 5 // Z-raise before parking
206 #define HOTEND_OFFSET_Z { 0.0, 1.3 } // Z-offsets of the two hotends. The first must be 0.
207 #endif
(...)
363 // PID Tuning Guide here: [reprap.org]
(...)
382 // Ultimaker
383 #define DEFAULT_Kp 22.2
384 #define DEFAULT_Ki 1.08
385 #define DEFAULT_Kd 114
(...)
510 #define USE_XMIN_PLUG
511 #define USE_YMIN_PLUG
512 #define USE_ZMIN_PLUG
(...)
542 * These settings allow Marlin to tune stepper driver timing and enable advanced options for
543 * stepper drivers that support them. You may also override timing options in Configuration_adv.h.
544 *
545 * A4988 is assumed for unspecified drivers.
(...)
553 //#define X_DRIVER_TYPE A4988
554 //#define Y_DRIVER_TYPE A4988
555 //#define Z_DRIVER_TYPE A4988 [Das sind aber die Treiber]
(...)
611 #define DEFAULT_AXIS_STEPS_PER_UNIT { 100, 100, 4000, 105 }
(...)
618 #define DEFAULT_MAX_FEEDRATE { 300, 300, 2, 25 }
619 // am 22.06.2019 y = 5 auf y = 2 geändert ... und damit lief die Y-Achse ohne Piepsen
(...)
624 #define DEFAULT_MAX_ACCELERATION { 3000, 3000, 100, 10000 }
(...)
634 define DEFAULT_ACCELERATION 3000 // X, Y, Z and E acceleration for printing moves
635 #define DEFAULT_RETRACT_ACCELERATION 3000 // E acceleration for retracts
636 #define DEFAULT_TRAVEL_ACCELERATION 3000 // X, Y, Z acceleration for travel (non printing) moves
(...)
646 define DEFAULT_XJERK 10.0
647 #define DEFAULT_YJERK 10.0
648 #define DEFAULT_ZJERK 0.3
649 #define DEFAULT_EJERK 5.0
(...)
777 #define X_PROBE_OFFSET_FROM_EXTRUDER -70 // X offset: -left +right [of the nozzle]
778 #define Y_PROBE_OFFSET_FROM_EXTRUDER 10 // Y offset: -front +behind [the nozzle]
779 #define Z_PROBE_OFFSET_FROM_EXTRUDER 0 // Z offset: -below +above [the nozzle]
(...)
812 define Z_CLEARANCE_DEPLOY_PROBE 10 // Z Clearance for Deploy/Stow
813 #define Z_CLEARANCE_BETWEEN_PROBES 5 // Z Clearance between probe points
814 #define Z_CLEARANCE_MULTI_PROBE 5 // Z Clearance between multiple probes
815 //#define Z_AFTER_PROBING 5 // Z position after probing is done
816
817 #define Z_PROBE_LOW_POINT -2 // Farthest distance below the trigger-point to go before stopping
(...)
1655 #define REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER
(...)
1923 #endif // CONFIGURATION_H
Re: Drucker fährt richtig auf Home, aber beim Druck startet Z auf +3
July 08, 2019 09:51AM
Hallo (hier bitte Namen einfügen),

Dein Start-gCode wird die Z-Achse dorthin verfahren lassen, Du wärst nicht der Erste bei dem das so ist.
Ist ein Anfängerfehler, aber keine große Angelegenheit smiling smiley.

Poste bitte einmal die ersten 30 Zeilen eines Codes (wo das Problem auftritt), oder hänge die komplette Datei hier an.

Gruß
Julien


Wer rasiert mit mir KingKong? Der wichtigste Guide - Triffid Hunter's Calibration Guide

Drucker: Eigenbau I3 - V6-Clone - Profilrahmen - Ramps 1.4 24V - TMC2208 - Simplify3D - Octoprint - Marlin 1.1.8
Re: Drucker fährt richtig auf Home, aber beim Druck startet Z auf +3
July 08, 2019 01:09PM
Danke, Julien, für Deinen Tipp:
>>Poste bitte einmal die ersten 30 Zeilen eines Codes (wo das Problem auftritt), oder hänge die komplette Datei hier an<<

Jetzt hoffe ich, dass ich die richtigen Zeilen hier poste:

Loading file: /Users/Oberliebling/Desktop/PI_Passteil_m_Tasche185Grad.gcode
Loaded /Users/Oberliebling/Desktop/PI_Passteil_m_Tasche185Grad.gcode, 8374 lines
1044.50mm of filament used in this print
The print goes:
- from 0.00 mm to 127.80 mm in X and is 127.80 mm wide
- from 0.00 mm to 118.80 mm in Y and is 118.80 mm deep
- from 0.00 mm to 15.00 mm in Z and is 15.00 mm high
Estimated duration: 39 layers, 0:24:45

... allerdings scheinen mir das keine 30 Zeilen zu sein ...
Was mache ich falsch? Welche Zeilen hätte ich posten sollen?
Mit Dank für die Mühen im Voraus

Helmut
Re: Drucker fährt richtig auf Home, aber beim Druck startet Z auf +3
July 08, 2019 02:02PM
Poste die ganze datei, ich finde mich schon darin zurecht.

/Julien


Wer rasiert mit mir KingKong? Der wichtigste Guide - Triffid Hunter's Calibration Guide

Drucker: Eigenbau I3 - V6-Clone - Profilrahmen - Ramps 1.4 24V - TMC2208 - Simplify3D - Octoprint - Marlin 1.1.8
Re: Drucker fährt richtig auf Home, aber beim Druck startet Z auf +3
July 08, 2019 02:04PM
Noch'n Nachtrag, Julien:
Ich bin jetzt auf die Idee gekommen, dass Du vielleicht den Code meinst, der generiert wird, wenn ich auf "Print" drücke ... habe ich gemacht, und der ist deutlich umfangreicher, sodass ich leicht die ersten 30 Zeilen hier posten kann.
Und: ich habe tatsächlich gesehen, dass da steht, und habe sie hier - wie auch weiter unten - rot gehighlightet:
=> echo: M205 Q20000 S0.00 T0.00 X10.00 Y10.00 Z0.30 E5.00

... aber wieso steht das da, und nicht Z0.00 ?? Und wie bekomme ich das wieder auf Null?

Hier erst mal der Code, wie er nach dem Drücken von "Print" dasteht - mit nochmaligem Dank für die Mühen!
Helmut

Connecting...
start
Printer is now online.
echo:Marlin 1.1.9
echo: Last Updated: 2018-08-01 | Author: (none, default config)
echo:Compiled: Jul 2 2019
echo: Free Memory: 4973 PlannerBufferBytes: 1232
echo:Hardcoded Default Settings Loaded
echo: G21 ; (mm)
echo: M149 C ; Units in Celsius
echo:Filament settings: Disabled
echo: M200 D1.75
echo: M200 D0
echoconfused smileyteps per unit:
echo: M92 X100.00 Y100.00 Z4000.00 E105.00
echo:Maximum feedrates (units/s):
echo: M203 X300.00 Y300.00 Z2.00 E25.00
echo:Maximum Acceleration (units/s2):
echo: M201 X3000 Y3000 Z100 E10000
echo:Acceleration (units/s2): P R T
echo: M204 P3000.00 R3000.00 T3000.00
echo:Advanced: Q S T X Y Z E
echo: M205 Q20000 S0.00 T0.00 X10.00 Y10.00 Z0.30 E5.00
echo:Home offset:
echo: M206 X0.00 Y0.00 Z0.00
echo:Material heatup parameters:
echo: M145 S0 H180 B70 F0
echo: M145 S1 H240 B110 F0
echotongue sticking out smileyID settings:
echo: M301 P22.20 I1.08 D114.00
Loading file: /Users/Oberliebling/Desktop/PI_Passteil_m_Tasche185Grad.gcode
Loaded /Users/Oberliebling/Desktop/PI_Passteil_m_Tasche185Grad.gcode, 8374 lines
1044.50mm of filament used in this print
The print goes:
- from 0.00 mm to 127.80 mm in X and is 127.80 mm wide
- from 0.00 mm to 118.80 mm in Y and is 118.80 mm deep
- from 0.00 mm to 15.00 mm in Z and is 15.00 mm high
Estimated duration: 39 layers, 0:24:45
Print started at: 19:49:28
Failed to set power settings:
Traceback (most recent call last):
File "printrun/pronsole.py", line 1219, in startcb
File "printrun/power/__init__.py", line 130, in powerset_print_start
File "printrun/power/osx.py", line 75, in inhibit_sleep_osx
File "printrun/power/osx.py", line 52, in AssertionCreateWithName
File "printrun/power/osx.py", line 44, in StringToCFString
ValueError: Expecting byte string of length 1, got a 'str'

echo:Unknown command: "M190 S60"
Re: Drucker fährt richtig auf Home, aber beim Druck startet Z auf +3
July 08, 2019 02:12PM
Der gesuchte Punk ist weiter unten, bitte hänge die Datei hier an einen Post an.

/Julien


Wer rasiert mit mir KingKong? Der wichtigste Guide - Triffid Hunter's Calibration Guide

Drucker: Eigenbau I3 - V6-Clone - Profilrahmen - Ramps 1.4 24V - TMC2208 - Simplify3D - Octoprint - Marlin 1.1.8
Re: Drucker fährt richtig auf Home, aber beim Druck startet Z auf +3
July 08, 2019 03:46PM
Hallo, Julien,
ich habe die Datei jetzt mit cmd+A insgesamt markiert, kopiert und als libreOffice-Datei hänge ich sie an - in der Hoffnung, dass die für eine Lösung notwendigen Zeilen dabei sind.
Falls nicht: was habe ich denn falsch gemacht, dass sie nicht dabei sind?
Jetzt bin ich mal gespannt, ob die angehängte Datei eine Hilfe für Deine Hilfe sein kann, für die ich mich jetzt schon bedanke!
Helmut
Attachments:
open | download - G-Code anhängen.odt (19.5 KB)
Re: Drucker fährt richtig auf Home, aber beim Druck startet Z auf +3
July 10, 2019 02:28AM
Guten Morgen Helmut,

jetzt noch einmal smiling smiley:

Wenn Du aus dem Slicer eine Codedatei generierst (also das STL-Modell in eine Druckbare Datei umwandelst), die Du in den Drucker einspielst (Per Pronterface, Repetier-Host oder einfach über die SD-Karte) damit er diese druckt.
Diese Datei möchte ich haben. Das ist in der Regel eine XXX.txt Datei. Hier musst Du nichts markieren oder kopieren, die Datei kommt fertig aus dem Slicer heraus.
Dein Fehler hat mit der Firmware an sich rein gar nichts zu tun, da kannst Du komplett entspannt sein. Dein Start-gCode ist einfach noch nicht eingerichtet, das ist alles.

Gruß
Julien


Wer rasiert mit mir KingKong? Der wichtigste Guide - Triffid Hunter's Calibration Guide

Drucker: Eigenbau I3 - V6-Clone - Profilrahmen - Ramps 1.4 24V - TMC2208 - Simplify3D - Octoprint - Marlin 1.1.8
Re: Drucker fährt richtig auf Home, aber beim Druck startet Z auf +3
July 10, 2019 09:24AM
Hallo, Julien!
Vielen Dank für Deinen Hinweis, von dem ich jedes Wort verstehe, aber nicht komplett, was damit gemeint ist:
Du schreibst:
a) "Wenn Du aus dem Slicer eine Codedatei generierst (also das STL-Modell in eine Druckbare Datei umwandelst)"
b) "die Du in den Drucker einspielst (Per Pronterface, Repetier-Host oder einfach über die SD-Karte) damit er diese druckt.
Diese Datei möchte ich haben."
a) ist mir verständlich ... die STL-Datei erstelle ich mit FreeCad ... und DIE lade ich dann in Cura hoch, um damit den G-Code zu generieren.
VON CURA AUS übertrage ich den von Cura generierten G-Code auf Pronterface, weil Pronterface meine Schnittstelle zum Drucker ist. Ich würde ja gerne von Cura direkt in den Drucker, weiß aber nicht, wie das gehen könnte .. und auf eine optionale SD-Karte

Von a) nach b) entsteht mir eine Schwierigkeit:
Cura habe ich offen, gehe auf "Open File" und suche mir die gewünschte STL-Datei ... aber NOCH habe ich doch nirgendwo eine XXX.txt-Datei ... alles, was ich finde, ist das STL-Icon - oder gibt's die XXX.txt-Datei doch? Wo finde ich die denn??
Wenn Du mir diesen Tipp geben könntest, kämen wir der Lösung meines "Anfängerproblems" (Ich wäre ja froh, wenn das stimmt!!) einen Schritt näher ...
In meiner Ungewissheit habe ich Dir mal die gesamte STL-Datei angehängt ... hilft Dir die weiter?
Mit Dank im Voraus für Deine geduldigen Mühen
Helmut
Attachments:
open | download - Passteil_m_Tasche.stl (13.9 KB)
Re: Drucker fährt richtig auf Home, aber beim Druck startet Z auf +3
July 12, 2019 02:06AM
Moin Helmut,

das, was Du machst ist ein möglicher Weg.
Ein anderer (auch normaler) ist das Exportieren des gCodes und manuelles einspielen in den Drucker (o.ä.).
Wenn Du eine Datei gesliced hast, müsste das ganze so aussehen:



Da gibt es unten rechts einen Button "Save to File", den drückst Du. Dabei hast Du die Möglichkeit die Datei zwischenzuspeichern, anstatt sie direkt in einen Host oder Ähnliches einzufügen (es entsteht eine Textdatei).
Und genau diese Datei möchte ich haben. Dann kann ich Dir zeigen, was es mit dem Start-gCode auf sich hat.

Durch das zwischenspeichern hast Du die Möglichkeit, auch ohne laufenden PC zu drucken, also von einer SD-Karte direkt (sofern Dein Drucker das unterstützt, tun aber die allermeisten). Manchmal bietet das sogar Vorteile, da die Verbindung von PC-zu-Drucker in einigen Fällen sehr langsam sein kann, dann "stockt und hakt" der Druck manchmal.


Gruß
Julien


Wer rasiert mit mir KingKong? Der wichtigste Guide - Triffid Hunter's Calibration Guide

Drucker: Eigenbau I3 - V6-Clone - Profilrahmen - Ramps 1.4 24V - TMC2208 - Simplify3D - Octoprint - Marlin 1.1.8
Re: Drucker fährt richtig auf Home, aber beim Druck startet Z auf +3
July 12, 2019 10:52AM
Hallo, Julien,
und wieder kann ich Dir für Deine nette Hilfe danken!
Ja - ich habe die Datei gesliced, und dann sieht sie so aus, wie Deine etwa, nur einfacher ... habe ich dir im Anhang vollständigkeitshalber als "gesliced.png" mitgeschickt.
Ebenfalls im Anhang findest Du (als "STL-Datei speichern.png" ) meinen Screenshot von den Möglichkeiten, die sich mir auftun, wenn ich an meinem Macbook in Cura auf „Save to File“ gehe. Mache ich da etwas falsch? Oder was genau meinst Du mit der „Möglichkeit, die Dateien zwischenzuspeichern, anstatt sie direkt in einen Host oder Ähnliches einzufügen (es entsteht eine Textdatei)“?
Bei mir nämlich bietet sich keine Möglichkeit einer Textdatei an … oder was meinst Du mit „Zwischenspeichern“?
In der Hoffnung, Deine Geduld nicht überzustrapazieren und mit Grüßen aus Bensheim

Helmut
Attachments:
open | download - STL-Datei speichern.png (266.6 KB)
open | download - gesliced.png (286.8 KB)
Re: Drucker fährt richtig auf Home, aber beim Druck startet Z auf +3
July 12, 2019 10:58AM
Der Fehler liegt bei mir...

Deine Datei soll .gcode heißen.
Diese kann man per Texteditor öffnen, darum habe ich im Automatismus immer .txt gemeint.
Bitte als gcode exportieren und anhängen.

/Julien


Wer rasiert mit mir KingKong? Der wichtigste Guide - Triffid Hunter's Calibration Guide

Drucker: Eigenbau I3 - V6-Clone - Profilrahmen - Ramps 1.4 24V - TMC2208 - Simplify3D - Octoprint - Marlin 1.1.8
Re: Drucker fährt richtig auf Home, aber beim Druck startet Z auf +3
July 12, 2019 12:43PM
OK, Julien,
DAS war der richtige Hinweis, mit dem es mir gelungen ist, den G-Code als Text-Datei zu exportieren ... Du findest den Code als Text im Anhang unter dem Namen "STL alsTEXT.text".
Jetzt bin ich sehr gespannt, was Du in dem Code findest und ob sich damit mein Problem mit dem Prusa lösen lässt.
Immer wieder mit Dank für Deine Mühen
Helmut
Attachments:
open | download - STL alsTEXT.txt (216.1 KB)
Re: Drucker fährt richtig auf Home, aber beim Druck startet Z auf +3
July 13, 2019 01:19PM
Also jetzt bin ich verärgert.
Im Code ist es definitiv nicht erkennbar, also ist meine anfänliche Vermutung hinüber...


Bitte hänge deine Configuration.h hier an, ebenso tippe in Pronterface mal M503 ein (dadurch wird das EEPROM ausgelesen, quasi das Gedächtnis des Gerätes) und kopiere alles, was danach ausgespuckt wird in eine Textdatei - auch diese bitte anhängen.

Lege diesen letzten gCode bitte einmal in deinen Drucker und starte den Druck, tritt das Problem dann ebenfalls auf?

Gruß
Julien


Wer rasiert mit mir KingKong? Der wichtigste Guide - Triffid Hunter's Calibration Guide

Drucker: Eigenbau I3 - V6-Clone - Profilrahmen - Ramps 1.4 24V - TMC2208 - Simplify3D - Octoprint - Marlin 1.1.8
Re: Drucker fährt richtig auf Home, aber beim Druck startet Z auf +3
July 14, 2019 04:47PM
Vielen Dank, Julien,
für die schnelle und ehrliche Rückmeldung ... jetzt bist DU verärgert, den Fehler nicht erwartungsgemäß gefunden zu haben, und ICH bin verängstigt, ihn nie beheben zu können. - Um Deine nette Hilfe aber so weit als möglich nutzen zu können, habe ich natürlich getan, was Du geraten hast:
Im Anhang findest Du die Configuration.h und das, was der Drucker geantwortet hat, nachdem ich das M503 eingegeben habe.
Von Deiner letzten Anweisung habe ich nicht begriffen, was ich genau tun soll:
"Lege diesen letzten gCode bitte einmal in deinen Drucker und starte den Druck, tritt das Problem dann ebenfalls auf?"
=> Welchen letzten gCode meinst Du denn? Doch nicht, was der Drucker auf das M503 hin ausspuckt - oder?
Mit gespannten Grüßen aus Bensheim
Helmut
Attachments:
open | download - configuration_h.odt (43.1 KB)
open | download - M503.odt (18.1 KB)
Re: Drucker fährt richtig auf Home, aber beim Druck startet Z auf +3
July 14, 2019 05:03PM
N'Abend Helmut,

mach Dir nicht so einen Kopf, ich vermute immer noch eine (total behämmerte) Kleinigkeit ist die Ursache.

Mit Code einspielen meinte ich, spiele den gCode von Deinem geslicten Teil (ist im Anhang) über Pronterface in Deinen Drucker, also quasi ausdrucken.
Im Code selbst kann ich nichts erkennen, darum möchte ich diese Fehlerquelle ausschließen und wissen, ob exakt dieser Code im Drucker zu Deinem Fehler führt.
Wenn das so ist, dann müssen wir halt weitersuchen.

Die anderen Beiden Dateien gucke ich mir morgen an, es ist schon spät winking smiley.

Eine Hausaufgabe habe ich aber für Dich.
Mache Dich im Internet bitte über die folgenden Ausdrücke/Begriffe schlau:

Slicer (Cura, Slic3r, S3D, uvm.) - was ist ein Slicer und was kann er? Welche Möglichkeiten zur Dateiausgabe gibt es?
Host-Programm (Pronterface, Repetier-Host, uvm.) - wozu wird das benötigt?
Druck von SD-Karte - Wie bekomme ich aus dem Slicer meine Datei? Wie spiele ich diese in den Drucker ein?

Damit möchte ich Dir die grundlegenden Verhältnisse dieser drei Dinge näher bringen, dann verstehst Du auch, warum ich immer eine druckbare Datei haben möchte.
Welche Art von Drucker (möglichst genaue Typenbezeichnung) hast Du denn, oder ist das ein Eigenbau? Je mehr wir über Dein Gerät und die verwendete Software wissen, desto einfacher ist es für uns Dir zu helfen.


Gruß
Julien

Edited 1 time(s). Last edit at 07/14/2019 05:13PM by ZipZap.


Wer rasiert mit mir KingKong? Der wichtigste Guide - Triffid Hunter's Calibration Guide

Drucker: Eigenbau I3 - V6-Clone - Profilrahmen - Ramps 1.4 24V - TMC2208 - Simplify3D - Octoprint - Marlin 1.1.8
Attachments:
open | download - STL alsTEXT.txt (216.1 KB)
Re: Drucker fährt richtig auf Home, aber beim Druck startet Z auf +3
July 15, 2019 05:20PM
Hi, Julien,
ja – gute Idee mit der „Hausaufgabe“.

- Was ein Slicer ist, sagt das Wort ja schon: Ein Programm, das den STL-Code in dünne Scheiben (slices) „schneidet“, die dem Drucker die Koordinaten angeben, an denen er was tun soll – 3D natürlich, in X-, Y- und Z-Richtung. Das ist mir klar.

=> Druck von SD-Karte - Wie bekomme ich aus dem Slicer meine Datei? Wie spiele ich diese in den Drucker ein?
=> Dass diese Option in meinem RepRapDiscount GraphicSmartController vorgesehen ist, weiß ich, sehe ja auch die für die Karte angebrachte Halterung … WIE man das aber macht, habe ich noch nicht ergründen können ...

- Pronterface ist ein Programm, mit dem ich per USB-Schnittstelle den Drucker steuern kann. Über Pronterface gebe ich in meinem Fall Druckaufträge durch, aber ich habe über Pronterface auch die Achsen kalibriert, fahre auf die Home-Position und wundere mich schließlich immer wieder, warum der Drucker die Home-Position mit Z = Null ansteuert, und kaum, dass es zum Druckauftrag kommt, er selbst im Display für Z = 0,3 angibt und den Druck in der Luft beginnen lässt ...
… Womit gleich die andere Frage beantwortet wäre: Ja, das hat er heute Abend wieder getan, als ich denselben, genannten G-Code als Druckauftrag abgesendet habe.

Alternativ zu diesem G-Code habe ich mir eine beliebige Druckvorlage aus dem Netz runtergeladen, in meinem Cura 3.03 zu einem G-Code umgewandelt, und nachdem ich den Druckauftrag durch Pronterface abgesendet habe, ist auch wieder das gleiche passiert: Z-Achse auf 0,3, der Druck beginnt in der Luft … an meinem ursprünglichen G-Code kann es also wohl kaum gelegen haben.

Zum Drucker selbst:
Ich habe ihn als China-Import-Eigenbau gebraucht gekauft, alle Teile waren schon dran, und er hat funktioniert. Das mit dem „in der Luft Beginnen“ hat er sich plötzlich einfallen lassen … und ich habe keine Ahnung, warum.
Ebenso keine Ahnung habe ich, welche speziellen Teile in dem Drucker verbaut wurden – Ausnahmen sind die, an denen es dransteht, z.B. die Schrittmotoren der Z-Achse.
Aber z.B. wie der Temperaturfühler im Bett heißt, verrät er mir nicht … Eine Typenbezeichnung des Druckers kenne ich daher auch nicht ... Prusa i3 gebe ich immer an, habe ich auch immer gemacht, als er noch funktionierte - und damit hat Cura bestens gearbeitet.
Die verwendete Software ist, was Ramps 1.4 sich gewünscht hat …

Hat Dir diese Antwort beim Helfen weiterhelfen können??
Bin sehr neugierig … mit Dank und Grüßen aus Bensheim

Helmut
Re: Drucker fährt richtig auf Home, aber beim Druck startet Z auf +3
July 16, 2019 01:35AM
Quote
Ojeh-3D
[...] er selbst im Display für Z = 0,3 angibt und den Druck in der Luft beginnen lässt ... [...]

[...] ist auch wieder das gleiche passiert: Z-Achse auf 0,3, der Druck beginnt in der Luft … an meinem ursprünglichen G-Code kann es also wohl kaum gelegen haben. [...]

So, stopp.
Es ging die ganze Zeit (und auch im Titel) darum, dass die Achse bei 3,0mm steht, nicht bei 0,3mm - was ist denn nun richtig?


Wer rasiert mit mir KingKong? Der wichtigste Guide - Triffid Hunter's Calibration Guide

Drucker: Eigenbau I3 - V6-Clone - Profilrahmen - Ramps 1.4 24V - TMC2208 - Simplify3D - Octoprint - Marlin 1.1.8
Re: Drucker fährt richtig auf Home, aber beim Druck startet Z auf +3
July 16, 2019 04:13AM
Oh - da war ich im letzten Post etwas unklar: 0,3 waren cm, während ich vorher in mm angegeben hatte ... sorry ...
Fakt ist: Die Z--Achse startet in 3 mm über Null, in der Luft ...

Gruß zurück
Helmut
Re: Drucker fährt richtig auf Home, aber beim Druck startet Z auf +3
July 26, 2019 04:49PM
N'Abend Helmut,

die letzen zwei Wochen musste ich auf strikte Drucker-Diät gehen, die Semesterprüfungen in der Hochschule wurden langsam ernst.

Dein Drucker läuft immer noch nicht korrekt nehme ich an? Leider habe ich (so direkt) nichts in der Config noch im GCode erkennen können.
Die Z-Achse sollte vor Druckbeginn auf Z=0,3mm fahren und loslegen...

Was war das letzte, was Du mit dem Gerät gemacht hast, bevor dieses Problem auftrat?
Bitte exportiere einmal dein Druckprofil aus Cura und hänge das hier an, vllt. kann ich ja darin etwas verdächtiges finden (ich tippe immer noch auf eine ungewollte Verstellung von Dir).

Gruß
Julien


Wer rasiert mit mir KingKong? Der wichtigste Guide - Triffid Hunter's Calibration Guide

Drucker: Eigenbau I3 - V6-Clone - Profilrahmen - Ramps 1.4 24V - TMC2208 - Simplify3D - Octoprint - Marlin 1.1.8
Re: Drucker fährt richtig auf Home, aber beim Druck startet Z auf +3
July 27, 2019 05:41AM
Hallo, Julien,
ich hatte mir schon gedacht, dass Du entweder im Urlaub oder anderweitig beschäftigt bist ... wofür ich selbstverständlich vollstes Verständnis habe.
Du hast recht: mein Drucker funktioniert nach wie vor nicht .
Du schreibst:
"Bitte exportiere einmal dein Druckprofil aus Cura"
Was ist ein Druckprofil? Finde ich das mit einem Klick, kopiere es und hänge es an?

Mit Dank für Deine Mühen
Helmut
Re: Drucker fährt richtig auf Home, aber beim Druck startet Z auf +3
July 27, 2019 05:43AM
P.S.: Würde es Dir helfen, wenn ich ein kurzes Filmchen anhänge, der zeigt, wie der Drucker sich verhält? Wenn ja: Worauf müsste ich da achten, dass man es sieht?
Nochmaliger Gruß aus Bensheim
Helmut
Re: Drucker fährt richtig auf Home, aber beim Druck startet Z auf +3
July 27, 2019 06:04AM
Quote
Ojeh-3D

"Bitte exportiere einmal dein Druckprofil aus Cura"
Was ist ein Druckprofil?

Das Druckerprofil enthält die Einstellungen, mit denen du sliced, den Rest findest Du hier.

Gruß
Julien


Wer rasiert mit mir KingKong? Der wichtigste Guide - Triffid Hunter's Calibration Guide

Drucker: Eigenbau I3 - V6-Clone - Profilrahmen - Ramps 1.4 24V - TMC2208 - Simplify3D - Octoprint - Marlin 1.1.8
Re: Drucker fährt richtig auf Home, aber beim Druck startet Z auf +3
July 29, 2019 06:03PM
Hi, Julien,
vielen Dank für Deinen Tipp ... der sich allerdings nicht so ohne weiteres befolgen lässt.
Ohne erfahren zu haben, ob Dich ein kurzes Video interessiert, das den traurigen Zustand des Druckers darstellt, habe ich Dir einen Zweieinhalbminüter bei youtube hochgeladen ... hier anhängen kann ich nur Dateien bis 8 MB, habe in den 150 Sekunden aber etwa 60 verbraten ...
Wenn Du Dir also die kurze Zeit nehmen und einen Blick auf das Filmchen werfen würdest - würde das Deinem Kennerblick die Lage klarer machen?
Auch das Problem lösen, wie ich Deinem Tipp mit dem Profil folgen kann?
Hier ist die youtube-Adresse für den Kurzfilm:
[youtu.be]
Mit Grüßen aus Bensheim

Helmut
Re: Drucker fährt richtig auf Home, aber beim Druck startet Z auf +3
July 30, 2019 02:01PM
Ich mische mich hier kurz mit ein.
Dein Drucker macht zu beginn wirklich seltsame Gymnastikübungen grinning smiley

In deinem GCode ist ziemlich weit oben die Zeile
G0 F3600 X74.623 Y83.349 Z0.3
Wenn du das von Hand korrigierst, sollte es passen. Die Frage bleibt aber, woher kommt das? Wahrscheinlich hast du im Slicer etwas verstellt...

Einige Zeilen weiter oben steht noch das
G1 F200 E3 ;extrude 3mm of feed stock
Sofern du nicht 4 Extruder hast, ist das schlicht falsch. Da sollte E0 stehen, so wie bei den anderen Zeilen auch.


Gruass us dr Schwiiz
Hansjürg
Re: Drucker fährt richtig auf Home, aber beim Druck startet Z auf +3
July 30, 2019 03:13PM
Wegen alledem möchte ich ja das Druckerprofil aus Cura haben...
Lies dir den Link durch, den ich gepostet habe, da steht drin, wie man das ganze EXPORTiert (kleiner Hinweis).

So wie ich das im Video sehe, steht auf dem Display rein gar nix von 3mm (so wie es immer behauptet wurde), sondern so wie es soll nur 0,3mm. Darum gehe ich jetzt erst als nächster Angriffspunkt von Schrittverlusten auf der Z-Achse aus, die ist (zumindest bei meinem Gerät) etwas empfindlich. Deine Achse verläuft massig schnell, möglicherweise sind Jerk/Beschleunigung einfach zu hoch eingestellt, das kann ebenfalls zu solchen Phänomenen führen.

Quote
hafo
[...]
G0 F3600 X74.623 Y83.349 Z0.3
Wenn du das von Hand korrigierst, sollte es passen. Die Frage bleibt aber, woher kommt das? Wahrscheinlich hast du im Slicer etwas verstellt...
[...]

Das ist der Eilgang zum Startpunkt der Extrusion, das sieht ganz normal, darum verstehe ich die Aussage von Hansjürg nicht.

Quote
hafo
[...]
G1 F200 E3 ;extrude 3mm of feed stock
Sofern du nicht 4 Extruder hast, ist das schlicht falsch. Da sollte E0 stehen, so wie bei den anderen Zeilen auch.
[...]

Erst einmal richtig. Das beeinflusst die Z-Achse aber nicht, wenn die Motoren richtig angeschlossen sind (und davon gehe ich aus, sonst passieren noch ganz andere Dinge mit Deinem Drucker eye popping smiley...).

Bitte probiere noch einmal, das Profil aus Cura zu exportieren, dann wissen wir mehr.

Gruß
Julien


Wer rasiert mit mir KingKong? Der wichtigste Guide - Triffid Hunter's Calibration Guide

Drucker: Eigenbau I3 - V6-Clone - Profilrahmen - Ramps 1.4 24V - TMC2208 - Simplify3D - Octoprint - Marlin 1.1.8
Re: Drucker fährt richtig auf Home, aber beim Druck startet Z auf +3
July 30, 2019 04:13PM
Oops, er hat mich mit seinen 3 und 0.3 etwas verwirrt confused smiley
Aber auf dem Video sieht es auch nach mehr als 3mm aus.
Ist das was da hinten links klickt der Z min Endschalter? Kannst du den nicht einfach etwas nach unten verschieben?


Gruass us dr Schwiiz
Hansjürg
Re: Drucker fährt richtig auf Home, aber beim Druck startet Z auf +3
July 30, 2019 06:56PM
Hallo Helmut,

ich mische mich hier auch mal kurz ein.
Ist denn der Z-Endstop richtig justiert?
Fahre mal x/y in die Bettmitte und dann Z auf Home.
Der Düsenabsbstand zum Bett sollte <=0,1mm sein.
Wenn größer--> Z-Endstop justieren.

Gruß Andreas
Re: Drucker fährt richtig auf Home, aber beim Druck startet Z auf +3
July 31, 2019 01:48AM
So, irgendwas stimmt hier nicht:

Laut Helmut (Anfangspost) zeigt das Display auch +3,0mm an, im Video sind es jetzt +0,3mm obwohl die Nadel deutlich über dem Bett schwebt - was stimmt denn nun?
Beim ersten tippe ich auf einen Softwarefehler, beim zweiten kann es entweder der Endschalter sein, oder Schrittverluste.

Angeblich trat das Problem ganz plötzlich auf, was für mich erstmal den Endschalter ausschließt, denn den verstellt man nicht mal eben um gute 3mm - und dann auch noch nach oben, wenn schon drückt man den unglücklich nach unten. Das Resultat ist aber eine Drucknadel, die tiefer liegt als das Bett, also einen Crash fährt. Hier ist aber das Gegenteil der Fall.

Ich drehe mich hier seit Wochen im Kreis, ich bitte jetzt einmal um ein paar vernünftige und ehrliche Infos.

Gruß
Julien


Wer rasiert mit mir KingKong? Der wichtigste Guide - Triffid Hunter's Calibration Guide

Drucker: Eigenbau I3 - V6-Clone - Profilrahmen - Ramps 1.4 24V - TMC2208 - Simplify3D - Octoprint - Marlin 1.1.8
Re: Drucker fährt richtig auf Home, aber beim Druck startet Z auf +3
August 01, 2019 02:43PM
Hallo, Julien,
Danke wiedermals für Deine geduldigen Mühen!
Du schreibst:
„So wie ich das im Video sehe, steht auf dem Display rein gar nix von 3mm (so wie es immer behauptet wurde), sondern so wie es soll nur 0,3mm. “

=> Ich habe im Video-Kommentar zwar erwähnt, dass der Drucker mit 0,3 hier Zentimeter meint und es sich um einen Spalt von 3 Millimetern zwischen Düse und Bett handelt, aber offenbar sind meine Bemerkungen nicht alle angekommen.
Ich habe gestern noch ein zweites Video gepostet, in dem ich zweifelsfrei dieses Missverständnis auszuräumen versuche … wobei ich allerdings nicht verstehe, warum der Drucker für die Z-Achse plötzlich in Zentimetern denkt, für die X- und die Y-Achse aber in Millimetern.

Die Adresse meines zweiten Videos lautet:
[youtu.be]
Weiter unten schreibst Du:
„Deine Achse verläuft massig schnell, möglicherweise sind Jerk/Beschleunigung einfach zu hoch eingestellt, das kann ebenfalls zu solchen Phänomenen führen.“
=> Wie wäre die Jerk/Beschleunigung denn richtig eingestellt? Oder: Wie finde ich raus, welcher Wert der optimale ist? Und wie und wo stelle ich das ein?

Schließlich den Export des Cura-Profils betreffend:
Ja, Du hast mir einen Link geschickt. Den habe ich auch probiert und in meinem ersten Video vorgeführt, was in meinem Mac aufgeht, wenn ich in Cura das Profil suche. Wörtlich lese ich in der von Dir verlinkten Beschreibung:
"Exporting a profile can also be done in a few simple steps:
1. Click on Profile in the menu bar or in the settings panel and select Manage profiles." => Das mache ich.
"2. Select the profile you want to export and click on Export." => Welches Profil soll ich denn auswählen, wenn ich doch erst eines suche??? Ist doch zum Weinen, wie diese Beschreibung an dem, was ich brauche, vorbeierkärt ...
"3. Enter a name and save the profile on your computer." => Das klappt dann schon gar nicht, weil ich gar kein Profil gefunden habe … heul!!!
Könntest Du Dir nochmal die entsprechende Sequenz in meinem ersten zweieinhalbminütigen Video ansehen und die Seiten, die dort aufgehen, mit denen vergleichen, die gemeint sind? … und mir sagen, wie ich herausfinde, wie man das Profil in meinem unerklärlich schweren Fall exportiert? Was mache ich denn so falsch?
Mit nochmaligem Dank für Deine Geduld und schon bald verzweifelten Grüßen
Helmut
Sorry, only registered users may post in this forum.

Click here to login