Welcome! Log In Create A New Profile


Precision piezo on BTT SKR E DIP V1.1 issue

Posted by Kanten 
Precision piezo on BTT SKR E DIP V1.1 issue
April 09, 2022 07:04PM
Hey everyone,
so I bought a orion precision piezo and tried to install it into my CR10S with a BTT SKR E3 DIP V1.1 but the printer doesn't use it to probe the bed or home.
I made a cable for it that connects to the servo pins on the board like I did with my BLTouch before, but instead of the two extra wires that went to the Z-endstops on the board the piezo board has nothing. I tried to write that into marlin by activating "#define Z_MIN_PROBE_PIN PC14" but it doesnt work. I read on another website that this board has to have something connected to the z-endstop plug but I dont know how to wire it then because It has only three wires instead of the five of from the BLTouch. The probe lights blue if I tap the nozzle like it should. It is just that the printer ignores it when I try to home it.
The manual for this ABL it pretty slim and the community for it is smal so I hope that someone on here can help me.

Here is a link to the current not working Marlin that I try to fix:

I would be very greatfull for a tip if this is a mistake I made with the wirering or the firmware.
Sorry, only registered users may post in this forum.

Click here to login