Welcome! Log In Create A New Profile


Problem with the A4899 drivers

Posted by master1900 
Problem with the A4899 drivers
March 25, 2017 12:43PM
Hi, until a few days ago, I've never been able to make a functioning 3D printer with my
1.4 board, so I've decided to do some manual tests with my Arduino on the motor drivers (the

First of all I've placed it on a breakboard. I've connected VDD and GND to 5V rail of the Arduino,
the VMO and GND to a 9V battery with a 100μF capactitor, I've connected the two pairs of the
motor, the STEP and DIR pins to two digital pins on the Arduino and lastly I've shorted
together RESET and SLEEP. After all of this the motor worked fine.
(Photo od the breadboard attached )
Here's the code by the way

#define STEP 3
#define DIR 4

void setup()
  pinMode(STEP, OUTPUT);
  pinMode(DIR, OUTPUT);

void loop()
  digitalWrite(DIR, HIGH);
  for(int i = 0; i < 10; i++)
    digitalWrite(STEP, HIGH);
    digitalWrite(STEP, LOW);
  digitalWrite(DIR, LOW);

So, I've put a single stepper driver (and nothing else) on the Ramp board, and it didn't work at
all. After some tests I've decided that, instead of placing the driver directly on the
socket, I would attacch it with some jumper wires (photo attached ). With a multimeter
I've found that the DIR pin on the E0 socket was connected to the pin 28 on my Arduino and
the STEP to pin 26, so it was easy to change the code based on that.

Of course it didn't work, so I've started disconnecting some of the wires and biapssing
the RepRap board, first of all I've connected the VMO and GND to the same 9V battery, but it
didn't change anything. Then I've started leaving disconnected some of the cables and I've
found that without the ENABLE pin attached it worked fine and I could control the motor.

After some researching on the datasheet, I figured out that when the ENABLE pin is set to
high the driver will not work, so I've done some inspecion with the multimeter and found that
the ENABLE pin on the driver socket is actually connected to the 5V rail on the Arduino, which
means that the driver will never function.

Is my inference correct? If yes, how can I fix it? Is my board faulty?
Re: Problem with the A4899 drivers
September 03, 2017 07:20AM
Try disconnecting the pin. While not connected, the driver may detect a low level on the enable input. If it does not detect a low level, connect the ENABLE pin to GND via a solder bridge.

For more information, visit our website www.ingeniotriana.com or access the 3D printing section on the link:
Sorry, only registered users may post in this forum.

Click here to login