Using Blender for making print-sheets

From RepRapWiki
Jump to: navigation, search

This is a wiki, please add tips or improve this tutorial if something is not clear!

Blender is frequently used for arranging multiple objects to print in one batch. This can save a lot of setup time if you want many small parts. While Blender can be useful, it can be pretty intimidating for beginners because it does not have an intuitive interface. Arguably, it does have an powerful user interface once you go along the learning curve.

There are many good tutorials on blender basics though. I didn't learn it overnight either, but the investment does pay of if you continue to work with 3D printers and stuff.

This video by Josef Prusa also shows many of the operations that are mentioned below. If you're unfamiliar with all of them and have 7 minutes to spare, you should watch that. One thing that's not needed (anymore) is joining the objects before export. Just make sure you've selected the objects you want to include in one STL.

Getting multiple parts in one build (picture: Allan Ecker)

Contents

Getting objects into the scene

Importing objects

  • You can import objects with: "File" -> "Import" -> "STL...".
  • Browse to the file. It will be added to your scene.
  • Repeat this process for every kind of objects you want to print. If you want multiple copies of the same object, see below.

Multiple copies

If you want multiple copies of the same object:

  • make sure you are in the top view (numpad 7). This way you will ensure that you move objects only in the horizontal plane.
  • press the D key to duplicate.

Arranging selected objects

Selecting one or multiple objects

  • Right click on a single objects that you want to select. If you want multiple objects:
  • Hold the SHIFT key and right-click more objects.

To select all objects that are in a certain area:

  • With the B key you can select a boundary, everything within it is selected. This is useful for selecting a whole bunch of objects for exporting to STL, or if you want to move a set of objects at ones.

Moving selected objects

If you don't constrain movement of objects along the X-Y plane, you will get floating objects.

  • If you move objects, you can also constrain it to one dimension/axis by specifying: G-key (move), X or Y-key (constrain movement to X axis).
  • This will make sure the objects all start on the first layer that is printed. "Floating" objects will not attach to the platform well, and you will risk getting a messed up print.

Rotating

In order to get more objects in a single build, you probably need to rotate them.

Note: You can rotate in any of 3 dimensions, but usually the objects are already in the STL file in the orientation in which the can best be printed. If this is not the case yet, you can constrain rotation to any spatial axis (X, Y or Z).

  • Select the object you want to rotate, e.g. by right clicking on it.
  • Press the "R" key.
  • Press the X, Y or Z key to constrain rotation to this axis. You usually just want to rotate them along the Z axis.
  • Either drag your mouse across the object for free rotation or
  • enter an amount of degrees of rotation (e.g. 90 for 90 degree rotation)

Other properties

Press the N key to show or hide the "Transform Properties" window. You can use this to inspect sizes and/or change them. Use the locks if you want to scale an object proportionally (instead of stretching it along a single axis).

Exporting a sheet of objects as one STL file

Convention: use millimeters as the standard unit.

Rationale: For exporting to STL, you can choose whether you want your unit in inches, mm, meter or anything. But skeinforge assumes it's in mm. Blender is also 'unitless', there is not absolute reference, it is what you decide yourself. For a single 'blender unit', you should use 1 mm to be compatible with the other processes (namely, Skeinforge which will make your toolpaths).

  • Follow the above steps: Select all the objects that you've oriented that you want to include in a build. If it's a sheet, you can use the "B" key to select a whole sheet at once.
  • Use "File" -> "Export" -> "STL..."
  • Choose a filename and hit the "Export STL" key. Make sure it doesn't end in .blend (which by default it does)

Next steps

SHARE IT!

Let others benefit from your work!

If you have the STLs and you think that at least one other person on the planet could potentially use your files, upload them to RepRap.org.

Tips:

  • CHECK THE LICENSE: The source material (the stuff you're including) has to be compliant with the license that you're using.
  • USE SOURCE FORMATS: It's best to also upload the .blend file, because that's most convenient for other people to re-arranging things. You and others will benefit from these improvements, so you should definitely make it as easy as possible.
  • ATTRIBUTION: Make sure you give credit where credit is due, but that goes without saying. Use the derivative feature if you're basing it on someone's work, this way people will be able to find the sheet of the thing they want to print.

Print it!

  • Load it in your STL to G-Code parser of choice (e.g. Skeinforge, replicatorG, RepRap Java host, etc.).
  • Print it!
  • Assemble! Upload pictures to RepRap.

Other useful tips for making print-batches

Reference sheet

A reference sheet is useful to know what will fit in a single print job.

You can create a cube, make it thinner than half of a single layer (otherwise it gets printed). You can use that for reference. You can select multiple objects and then the export to STL will include them. Step by step, this is how you do this:

  • From the Menu, select "Add" -> "Mesh" -> "Cube".
  • If the "Transform Properties" window is avaiable, use that to make it very thin (less than 0.1 thick).
  • You can also use the "S" (for changing the scale) key, press X and type how wide you want it in millimeters. Do the same for Y to make it longer or shorter. Make the Z-height 0.1 tick.

Add your tips!

This is a wiki, add things you've learned that are useful for beginners and for 3D printing!