Welcome! Log In Create A New Profile


Hostsoftware 0.9 doesn's start on Ubuntu 7.10

Posted by fulltilt 

I'm sorry to open up a another thread with this topic, but I didn't found any results for this problem.

I tried to install the Java JDK with all components but it still doesnt work.
When starting the reprap-host.sh file some errors are shown, which I don't understand:

$ ./reprap-host.sh
Experimental: JNI_OnLoad called.
Stable Library
Native lib Version = RXTX-2.1-7
Java lib Version = RXTX-2.1-7
Exception in thread "AWT-EventQueue-0" java.lang.NoClassDefFoundError: javax/swing/GroupLayout$Group
at org.reprap.Main$22.run(Unknown Source)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:461)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:242)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:163)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:157)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:149)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)

$ java -version
java version "1.5.0_16"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_16-b02)
Java HotSpot(TM) Client VM (build 1.5.0_16-b02, mixed mode, sharing)

All rights each of file has been set to read and write even for the current user, to avoid errors depending on this.
I'm a real nooby in working with linux but I tried to follow the instructions of [reprap.org].

All the files has been installed. Maybe I've made a stupid mistake while using Linux.

Thank you for reading this post.
Would be glad about any suggestions to solve this problem.

Anonymous User
Re: Hostsoftware 0.9 doesn's start on Ubuntu 7.10
September 24, 2008 05:37AM
Hi Marius,

The error message looks to be similar to the one found in this earlier post:


I don't know if the 1.5 compatability option is still an issue with the more recent version of the java host software
Thanks fool.
Now it is working. I changed the version of jdk from 5 to 6 and started the hostsoftware as root.
Anonymous User
Re: Hostsoftware 0.9 doesn's start on Ubuntu 7.10
September 25, 2008 05:23AM
I've never had to run the host software as root to get it going - why do you find you have to do this? USB permissions, perhaps?
Sorry, only registered users may post in this forum.

Click here to login