Welcome! Log In Create A New Profile


Motherboard ATX power problem

Posted by Cblair 
Motherboard ATX power problem
August 03, 2010 07:57PM

I'm building a mendel with Gen 3 electronics. I'm presently working on programming the motherboard. I'm doing as few mods to the boards as possible as they were pre-built by MakerBot. The only soldering mods I've done have been to add two 2-pin headers to the SDA&SCL lines to connect the motherboard to the extruder board; and to add one 2-pin header to allow for the programming jumper (headers are shown here at A and B: [reprap.org]).

I am following these directions on how to program it: [reprap.org]. The only difference is that I am using a USB:TTL 5V cable which was prefabbed, and I am using an ATX power supply to power the board instead of the custom mendel USB<->serial cable.

There does not appear to be any power to my board, as the ATX supply fan is not turning on, neither is the power LED on the motherboard.

This is what I have done:
- Install a jumper on the programming header. Select tools->board->sanguino in arduino.exe and compile.
- Plug the TTL end of the USB:TTL cable into the motherboard
- In arduino.exe select tools->serial ports and check what is available.
- Plug the USB end into the computer. When plugged into the computer, Windows detected the USB device and "installed drivers". No lights on the board at all.
- In arduino.exe select tools->serial ports and select the new device (for us, COM3).
- The Power LED (labelled power, next to the TTL connection) did not turn on on our board as expected.
- Plugged in an ATX supply, debug light flickered three times fast, pause, two times fast, off. Cycled power; no lights. Nothing on the board is warm so I dont think anything is fried. There is the correct voltage from the ATX power supply when not connected to the RepRap. When the reset button on the motherboard is pressed, the debug light again flashes the same pattern. The ATX supply fan does not turn on at all. Same behavior with or without the jumper installed next to the TTL connection. No lights on the board when the ATX supply is connected before the serial cable.
- Select upload. It will say "Uploading to board...". For us, it then had an error:
Problem uploading to board.
Binary sketch size: 22514 bytes (of a 63488 byte maximum)
avrdude: stk500_getsync(): not in sync: resp=0x48
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x48

When no ATX supply is connected, the error is as follows:
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

Any thoughts would be great!
Re: Motherboard ATX power problem
August 04, 2010 01:10AM
For starters you do NOT need the power supply to program.. Try flipping it around (the connector) and see if you get power to the mb if not you may have a bad one... also try the extruder... you don't have 2 bad parts right? that will give you a control..
Re: Motherboard ATX power problem
August 05, 2010 06:22PM
Thanks Daniel.

Solved! The problem was I hadn't flipped the power switch on the motherboard... doh!

- The extruder control board does not need the ATX supply to be programmed.
- For the extruder board, uploading only worked when I clicked upload, held reset button on the extruder board until "Binary sketch size..." appeared, and then immediately released reset.
- I do need the ATX supply for the motherboard to be programmed (I'd imagine some of the mods you can do to the motherboard eliminates this necessity.. or maybe my TTL:USB cable is busted, measured 5V across it though.... or maybe I didnt test programming with the power switch flipped and without the ATX, regardless the power LED does not turn on without the ATX supply)
- Program uploaded successfully first time without any need to fiddle with the reset button and timing for the motherboard.

Flipping the TTL cable around will connect 5V to TX and ground to RTS - be careful it's actually backwards first. To check if you think the cable is backwards, plug in your USB and measure the voltage from pin 1 (ground, black) to pin3 (VCC) with nothing else connected; it should be 5V; if not, assume your cable is backwards and measure it from the other end (pin 6, green, to pin 4). Or at least, that's how you do it if you're (like me) using [www.ftdichip.com] this cable or similar; I'd imagine you can do the same measurements when using the custom mendel USB<->serial & power cable [reprap.org] .

Sorry, only registered users may post in this forum.

Click here to login