Welcome! Log In Create A New Profile


Z axis not working with Marlin

Posted by miro87043 
Z axis not working with Marlin
December 25, 2011 03:18AM
I've decided to try marlin as it seems that others are getting smoother perimeters than with sprinter.
I've got everything working as expected except while printing my Z axis moves inconsistently. Sometimes it's fine and rises for each layer as expected, but sometimes the motors wine but don't move. I read this topic [forums.reprap.org] and tried the suggestions with no success. I lowered my Z acceleration to 25 mm/s2 and max feed to 4 mm/s, both less than I was using in sprinter.
BTW this is not a problem when using spinter FW

any ideas?

Re: Z axis not working with Marlin
December 25, 2011 06:46PM
After messing around a bit I found a unexpected solution. I changed the minimum feed speed in Marlin FW to 1 mm/sec (previously 0) and Z axis now moves as it should. However, I'm baffled as to why this worked. If for some reason the Z axis was told to move at 0 mm/sec this action would pause the printer as it would take an infinate amount of time to reach the specified distance (right?), but instead the printer would continue and print the next layer at the previous layer height.

If anybody understands whats going on, please educate me!

With that said, my problem is solved and prints with Marlin FW have much smoother perimeters than with Sprinter FW.
I've posted an issue about this to see if we can get to the bottom of it smiling smiley [github.com]
Sorry, only registered users may post in this forum.

Click here to login