Welcome! Log In Create A New Profile


Current marlin support for G29 and deltabot?

Posted by andrea.rimo 
Current marlin support for G29 and deltabot?
August 19, 2014 09:38AM
I have built and calibrated a 3DR printer. after a while I got interested into auto bed levelling using FSR so I bought 3. I connected them to RUMBA ZMIN endstop, configured the endstop to use the pull-up resistor and checked it worked by manually pushing on the print bed and confirming the FSR triggers the endstop. everything seems ok, so I enable auto_bed_levelling on the firmware.
at first It throws a compile error regarding some variables not defined (ABL_PROBE_PT_....). I found the variables in the NON delta configuration.h so I added those in the delta version of the configuration.h and it compiled.
after uploading, I homed (G28) and everything work as expected.
as soon as I sent G29 only one motor (the one connected to the Z motor driver) started to move down, the other 2 stayed still, throwing the effector completely out of the printer. it was as if it did not know it was dealing with a delta printer and just tried to move down the Z axis.
another strange behaviour was when sending G30. this time the effector went down correctly (all axis moving down) , hit the bed and stopped, setting the current Z to 196.3 (my Z_HOME_POS is 163.3). I was expecting it to set the Z to zero when hitting the bed...

Does anyone have a clue?


Edited 1 time(s). Last edit at 08/20/2014 01:50PM by andrea.rimo.
Sorry, only registered users may post in this forum.

Click here to login