Welcome! Log In Create A New Profile

Advanced

Can't figure out where to put Azteeg Sanguino addons so they're recognized by Arduino 1.6.12

Posted by Pointedstick 
On OS X (10.12 Sierra) I'm trying to get Marlin 1.1.0-RC7 to work for my Azteeg X1 board and I'm getting the following error when I try to compile it:

In file included from sketch/pins_AZTEEG_X1.h:30:0,
                 from sketch/pins.h:87,
                 from sketch/MarlinConfig.h:33,
                 from ~/Documents/3D_printing/Sketchbooks/Marlin-1.1.0-RC7-Azteeg-Blue-MendelMax/Marlin-1.1.0-RC7-Azteeg-Blue-MendelMax.ino:37:
pins_SANGUINOLOLU_11.h:28: error: #error "Oops!  Make sure you have 'Sanguino' selected from the 'Tools -> Boards' menu."
   #error "Oops!  Make sure you have 'Sanguino' selected from the 'Tools -> Boards' menu."
    ^
exit status 1
#error "Oops!  Make sure you have 'Sanguino' selected from the 'Tools -> Boards' menu."

However I do have that selected:




Here's what I did:

1. Downloaded a zipball from the Marlin GitHub page at [github.com]

2. Edited configuration.h appropriately, selecting "BOARD_AZTEEG_X1" for the motherboard (#define MOTHERBOARD BOARD_AZTEEG_X1)

3. Downloaded and installed Arduino 1.6.x, as directed by the sketch (Arduino 1.6.12 to be precise).

4. Opened the sketch in the Arduino IDE.

5. Downloaded the Sanguino addons using the instructions found here: [dustsreprap.blogspot.com]

6. Installed the Azteeg addons (http://reprap.org/wiki/File:Azteeg_x1_sang_patch.zip) at ~Library/Arduino15/packages/Sanguino

7. Selected "Sanguino" under Tools > Boards

8. Attempted to compile the sketch and got the error. I looked and here's the code that generates the error:

#if !defined(__AVR_ATmega644P__) && !defined(__AVR_ATmega1284P__)
  #error "Oops!  Make sure you have 'Sanguino' selected from the 'Tools -> Boards' menu."
#endif

So it looks like __AVR_ATmega644P__ and __AVR_ATmega1284P__ aren't defined somewhere. I can see definitions for those in the Azteeg addon that I placed at ~Library/Arduino15/packages/Sanguino, so it's likely I haven't put them in the right place. Does anybody know where those files go in Arduino 1.6.12? The wiki page (http://reprap.org/wiki/Azteeg_X1) is not especially helpful because it has instructions for an older Arduino version (Arduino 0023) that are correct, but that version isn't supported for the latest Marlin builds.
your part 6 is not compatible with arduino ide > 1.0

docs from the zip file

"Sanguino Patch for Axteeg X1 v1.0 and v1.5

This patch allows the Arduino IDE to recognize the Atmega644P and Atmega1284P used on the Azteeg X1 3D printer controller. It may also be used on Sanguinololu controllers.

Installation.

1. Download and install Arduino IDE 0022/0023(will not work with Arduino 1.0 and above) from this link.
[arduino.cc]
"
I would start with a fresh ardunio install and dont do #6, its not needed (as far as I can tell)

UPDATE:

I just replicated your install without #6, got the same error. (missed something obvious)

The issue is that you need to select the correct processor, you have a ATmega644 selected
This is invalid, it needs to be a ATmega644p or ATmega1284p

(ATmega 1284P on v1.5, ATmega 644P on v1.0 on a Azteeg X1)

Edited 3 time(s). Last edit at 10/13/2016 03:19AM by Dust.
Quote
Dust
I just replicated your install without #6, got the same error. (missed something obvious)

The issue is that you need to select the correct processor, you have a ATmega644 selected
This is invalid, it needs to be a ATmega644p or ATmega1284p

(ATmega 1284P on v1.5, ATmega 644P on v1.0 on a Azteeg X1)

Ah, duh! I selected the correct processor and everything worked like clockwork. Thanks for your help.
Sorry, only registered users may post in this forum.

Click here to login