Welcome! Log In Create A New Profile


Blank screen on RepRapDiscount FullGraphicsLCD/Ramps 1.4

Posted by olev 
Blank screen on RepRapDiscount FullGraphicsLCD/Ramps 1.4
February 24, 2017 05:13PM

I'm having "issues" with my first RAMPS and Marlin. It's a chinese Ramps 1.4 kit and the RepRapDiscount full graphics LCD. I configured, compiled and installed Marlin 1.1.0-RC8 on it. Everything was good except there was nothing on the screen. Backlight is on, I can connect to the board via PC (pronterface), read SD card connected to the LCD, it beeps when rotary knob is pressed etc... so the cabling is correct. Basically everything else I tested looks OK, besides no info on display.

What I tried: a lot. Power via USB and 12V pins, latest stable Marlin (1.0.2-1), different versions of U8glib, different versions of Arduino IDE, verified 2-3-5 times that the correct controller is selected in configuration.h (#define REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER), tried setting Ramps 1.4 and 1.3 motherboards (shouldn't really matter), no difference.
I have NOT yet tried connecting motors/thermistors/heaters to it. Just a Mega + RAMPS + DRV8825 drivers + LCD.

I wasn't sure if it's something with my RAMPS boards, display/controller or FW... since I didn't have other HW to test, I changed FW to Repetier, and BANG, it works perfectly. No issues with the display.

Now comes the "funny" part - I re-uploaded Marlin to Ramps (while it had working Repetier on it). And I got something on the screen when upload completed! A bit gibberish, but something (see attached). It only lasts until next reboot though, then the screen is all blank again. And it's repeatable - upload Repetier, screen works, upload Marlin, gibberish until reboot, then blank after reboot. Repetier keeps working after reboots as well.

I have read that some RAMPS display issues are related to lack of 5V delivery to Arduino, I measured mine on the Arduino and it's 4.88V, seems good enough to me. Now I'm not sure - is there something wrong with Marlin or is it really some weird power delivery issues with my RAMPS that for some reason doesn't affect Repetier, but affects Marlin? Any thoughts?
open | download - Configuration.h (55.2 KB)
open | download - IMG_20170224_232934.jpg (70.9 KB)
Re: Blank screen on RepRapDiscount FullGraphicsLCD/Ramps 1.4
February 28, 2017 07:30AM
OK... I was ready to give up Marlin and just live with Repetier, then got REALLY fed up with Repetier stupidity regarding autolevel and Z offset tuning and gave Marlin another go. I was able to get it working by selecting the "old" way of working, bypassing U8GLIB_ST7920_128X64_RRD.

This is what I did:

1) found this Marlin issue and followed the suggestion https://github.com/MarlinFirmware/Marlin/issues/5270, which said:
All you have to do is to go in to the u8glib library and navigate to:
There you will find an arduino file named "GraphicsTest".
Open it with your favorite text editor and add the following constructor call to the list which begins in line 43 and ends in line 140.
U8GLIB_ST7920_128X64_1X u8g(23, 17, 16); // SPI Com: SCK = en = 23, MOSI = rw = 17, CS = di = 16

2) Of course life is never that simple. This did not change anything for me, so in "ultralcd_impl_DOGM.h" I also uncommented this to actually USE the old ways:
U8GLIB_ST7920_128X64_1X u8g(LCD_PINS_D4, LCD_PINS_ENABLE, LCD_PINS_RS);    // Original u8glib device. 8 stripes

and commented this:
//U8GLIB_ST7920_128X64_RRD u8g(0); // Number of stripes can be adjusted in ultralcd_st7920_u8glib_rrd.h with PAGE_HEIGHT

3)Profit! I now have a working LCD, although it is updating very slowly, I suppose this is related to the fact that it's using the "original u8glib device" settings instead of more modern "RRD" one. Anyway, a slow screen beats a blank screen any day in my books. Not sure if I'll ever bother to troubleshoot it any further smiling smiley
Re: Blank screen on RepRapDiscount FullGraphicsLCD/Ramps 1.4
February 28, 2017 10:00AM
What a journey!
Let's hope the slow updating doesn't affect printing later. Always was an issue with Deltas and graphic LCDs...
Re: Blank screen on RepRapDiscount FullGraphicsLCD/Ramps 1.4
November 13, 2018 08:57AM
Aaaand over a year later, another poor fellow (me) has fallen into the same trap.

I was able to reverse the orientation of cables to even get the backlight to illuminate (step 1 of many, I'm sure)

I'm using the Marlin 1.1.8 and MKS Gen L v1.0 board and still only see the backlight.
Arduino board chosen is Arduino/Genuino Mega2560 with AT2560 processor.

I'm not sure commenting the lines mentioned above apply to this board.
If any of you have seen the resolution I'm looking for, help a guy out.
((I'm looking in other areas for solutions, including: other references ))

Now onto other issues.

fix for me was to undo changes in this post and apply Jinx fix from here: https://reprap.org/forum/read.php?1,824129,838483#msg-838483

Edited 1 time(s). Last edit at 11/13/2018 06:12PM by velvetbrain.
open | download - mks1.png (259.8 KB)
Sorry, only registered users may post in this forum.

Click here to login