Welcome! Log In Create A New Profile


Sanguinololu & opto endstops confused smiley

Posted by Eriksen 
Sanguinololu & opto endstops confused smiley
July 03, 2014 05:40PM
Hi there,

I am modernising my old Prusa, which involves a newly-soldered sanguinololu board. I used to have Gen 3 electronics and I want to re-use the old opto endstops (v2.1).

When no endstops are attached to the electronics board, I read 5V between GND and V+ (or SIG if I switch it in the firmware). But when I plug in the endstop, I read ~1.8V at SIG and ~0.9V at V+. The LED does not light up on the endstop board and nothing happens when I trigger the opto switch. These endstops worked just fine with the old electronics, so why not with the Sanguinololu?

Re: Sanguinololu & opto endstops confused smiley
July 04, 2014 03:03AM
By default the endstops on sanguinololu have no power on the v+ endstop pins.

Take a look at the bottom of your board eg Bottom of PCB

Between the exp pins on the left and the and the endstops pins on the right is voltage selector pads, put a solder blob from the middle pad to the +5 pad. (make sure not to cross all 3 pads)

Edited 1 time(s). Last edit at 07/04/2014 03:04AM by Dust.
Re: Sanguinololu & opto endstops confused smiley
July 04, 2014 06:39AM
Also check pinout of these connectors. IIRC pinout of Gen3 and Sanguinololu are different and shorting 5V to GND isn't exactly a good idea smiling smiley

Generation 7 Electronics Teacup Firmware RepRap DIY
Re: Sanguinololu & opto endstops confused smiley
July 05, 2014 03:31AM
Thanks Dust, that worked perfectly smiling smiley

I am a bit embarrased since I missed this info on the wiki page.

And Traumflug, yes, I had already switched two wires on my cables, as the pinout is a bit different, but thank you for the heads-up winking smiley

Now to make all the rest work...
Sorry, only registered users may post in this forum.

Click here to login