Welcome! Log In Create A New Profile


Motherboard firmware / Sanguino problem

Posted by Tom Frisch 
Motherboard firmware / Sanguino problem
April 12, 2010 01:36AM
Got my mendel motherboard soldered up, and successfully burned the bootloader with USBTinyISP. Now I'm having trouble installing the firmware on the motherboard from the arduino environment.

I installed a fresh copy of Aurdino 018, and installed the Sanguino folder into the hardware directory.

I downloaded a fresh copy of the firmware, and duplicated the configuration.h file, renamed it, and successfully verified the compile.

When I hook up my FTDI USB cable to the motherboard, the power lights up, but if I hit reset I get 3 fast flashes, and 1 more flash after a pause. Does that mean the bootloader is really running?

When I upload the sketch from arduino environment, I get the following error:
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

Same thing happens when I follow the unplug/reset instructions on the reprap wiki.

Any help would be greatly appreciated.

Also, I was able to successfully re-flash an old MEGA-8 chip in my Arduino NG board with the same USBTinyISP, but was not able to flash a brand new MEGA168P20U when seated in the same NG board. So I'm not sure if that proves the USBTiny is working correctly or not.
Re: Motherboard firmware / Sanguino problem
April 12, 2010 11:30AM
Yes it sounds like the boot loader is successfully loaded.

Depending on your enviroment the Aurdino IDE is supposed to reset the target board and put into bootloader mode.

When in bootloader mode it listens to the serial port for a new program, if no program is sensed it executes the previous program.

Try clicking on the upload button (which triggers a recompile of the sketch) and then press the reset button on your motherboard.
Re: Motherboard firmware / Sanguino problem
April 12, 2010 12:24PM
I've tried hitting reset before, at the same time, and just after hitting the upload button in Arduino IDE, but none of those worked, same result.

Any more things I could test? On the Sanguino, does the 3 fast, 1 slow red LED blink on boot mean the bootloader is installed correctly? Are there any pins I could read to test this?

Re: Motherboard firmware / Sanguino problem
April 12, 2010 03:02PM
Problem solved. Rebooted my laptop, reset sanguino just after I hit the upload button in Arduino IDE. Successful firmware install.

Thanks for the tip.
Re: Motherboard firmware / Sanguino problem
April 12, 2010 10:49PM
Yeah it can be fussy on the timing, what is wierd is that I have access to three Sanguino's.

The orginal and two of the expanded versions with breakout conectors.

The orginal works great no timing dance with the reset button and the other two you have to do the dance. Supposed to the same ciruit, parts, etc.
Re: Motherboard firmware / Sanguino problem
April 13, 2010 10:44AM
When uploading firmware to the Motherboard, I jumper the two "autoreset enable" holes near the serial connector. This allows avrdude to automatically reset the Sanguino at the right time. If I ever have to take the Motherboard off I'll slder a couple of pins in those holes and have a jumper handy.
I bought a reprap motherboard (Sanguino Master), and extruder board (Arduino Slave) from Makerbot, downloaded the firmware, arduino, sanguino software, installed, compiled the SanguinoMaster and received the following error message, tried lot of things but didn’t work.
---- Error: variable or field ‘send_tool_command’ declared void In function ‘void init_commands()’;
I tried in two computers one Window XP the other Window Vista, received same error message. The Arduino 18 environment compiled fine the code downloaded here in the RepRap Subversion repository.
The problem is this version doesn’t support the Master Slave configuration I purchased from Makerbot.
I emailed Makerbot for help but …
C:\Program Files\reprap>rem reprap-host -- runs Reprap Java host code with an ap
propriate classpath

C:\Program Files\reprap>rem Amount of RAM to allow Java VM to use

C:\Program Files\reprap>set REPRAP_RAM_SIZE=1024M

C:\Program Files\reprap>rem reprap.jar file and stl file

C:\Program Files\reprap>set REPRAP_DIR=C:\Program Files\Reprap

C:\Program Files\reprap>rem Java3D and j3d.org libraries

C:\Program Files\reprap>rem set JAVA_LIBRARY_DIR=C:\Program Files\Reprap

C:\Program Files\reprap>rem cd so we can find the reprap-wv.stl file. Can we av
oid this??

C:\Program Files\reprap>IF NOT EXIST reprap-wv.stl cd "C:\Program Files\Reprap"

C:\Program Files\reprap>java -cp ".\reprap.jar;.\RXTXcomm.jar;.\j3dcore.jar;.\j3
d-org-java3d-all.jar;.\j3dutils.jar;.\swing-layout-1.0.3.jar;.\vecmath.jar;." -X
mx1024M org/reprap/Main
DEBUG: The distribution preferences file and yours match. This is good. [0.010s
DEBUG: GCode opening port COM1 [0.178s/168ms]
WARNING: RXTX Version mismatch
Jar version = RXTX-2.2pre1
native lib Version = RXTX-2.2pre2
DEBUG: Attempting to initialize Arduino/Sanguino [1.623s/1445ms]
comms: G-code: N0 T0 *26 dequeued and sent [6.415s/4792ms]

Gen 3 and host software. Any help helps
Re: Motherboard firmware / Sanguino problem
May 02, 2011 12:39PM
the line shown "DEBUG: GCode opening port COM1 [0.178s/168ms] "

make sure you setting a right COM port at reprap host. if your using windows system go to searching

C:\Documents and Settings\Administrator\.reprap

inside there your need to open a file " reprap.PROPERTIES" and change a BaudRate setting from 19200 --> 57600
Re: Motherboard firmware / Sanguino problem
October 18, 2011 02:27AM
I found that there needs to be a header with a jumper on it in the gap between the Pololu drivers and the main big chip then it uploads every time

Experimenting in 3D in New Zealand
Sorry, only registered users may post in this forum.

Click here to login