Welcome! Log In Create A New Profile

Advanced

Reprap Discount Smart Controller Not Working

Posted by Flightless 
Reprap Discount Smart Controller Not Working
May 04, 2015 10:42AM
Hi All,

Have a mendelmax 1.5 using sanguino 1.3a & latest Marlin firmware.

Frustrated with the smart controller I bought from here.

According to guys like this, it should be just as easy as uncommenting a few lines in Marlin (granted he is using RAMPS but the same principle should apply, right?)

No matter what I try when this thing powers on it just shows black rectangles instead of getting to the start screen as it should.

Any ideas??

Thanks.

P.S. Sanguino doesn't seem to be so popular these days, seems to be quite hard to find info for them.
Re: Reprap Discount Smart Controller Not Working
May 04, 2015 01:04PM
This could well be a contrast issue. Have you tried adjusting the contrast trimpot on the rear?

This thread is about full graphic LCD displays having contrast problems, but it might be useful for 2004 LCDs, too: [forums.reprap.org]
Re: Reprap Discount Smart Controller Not Working
May 05, 2015 07:55AM
Tried adjusting the contrast, still just get this (see attached).
Attachments:
open | download - 20150505_212624 (800x480).jpg (198.6 KB)
Re: Reprap Discount Smart Controller Not Working
May 05, 2015 08:59AM
Thats either cabled swapped or firmware not setup for that lcd. (could be a hardware fault to... but not likely)

Please post your configiration.h to pastebin.com and link to it here...

Edited 1 time(s). Last edit at 05/05/2015 09:00AM by Dust.
Re: Reprap Discount Smart Controller Not Working
May 09, 2015 08:11PM
Hi Dust,

Please find the config file here.

Thanks
Sorry, only registered users may post in this forum.

Click here to login