Welcome! Log In Create A New Profile


Prontoface not connecting

Posted by Keithrhodes 
Prontoface not connecting
December 08, 2015 10:48AM
I'm using Windows7, a Sanguinololu 1.3a and prontoface on a machine I have built myself.
I have had this machine printing out successfully in the past but now it refuses to work.p
When I attempt to connect the 3D printer to Prontoface the screen comes up on the computer but the graphics for moving the
3 axes remains grayed out IE. The machine is not connecting. I am using COM3 and 115200 Baud rate.
Power supply is OK. Red LED comes on.
When I hit the connect button Prontoface says "connecting " then every second it prints M105 on successive lines. (This is trying to read the
Temperature sensor every second).
I have checked all of the wiring connections and tried new stepsticks and have spent LOTS of time trying to find the problem.
I don't know if this is a software problem; a wiring disconnect or short or a driver problem or anything else.
Has anyone experienced a similar problem and has found the solution.
I would appreciate any help.
Many thanks, Keith.
Re: Prontoface not connecting
December 08, 2015 12:09PM
Does the Windows hardware manager recognize the FTDI USB port?

Can you see Marlin's boot message in the Arduino serial monitor? (You need to "disconnect" pronterface first.)

Have you tried reflashing the Marlin firmware onto the Sanguinololu?

Have you tried on another USB port?

Have you tried with a different USB cable?
Re: Prontoface not connecting
December 08, 2015 05:07PM
Thank you, Enif
No recognition of the USB port on the windows device manager.
I am not using Marlin.
I have never had to flash the Marlin firmware onto the Sanguinololu.
Only two ports COM1 and COM3 are shown on Prontoface and I have always
used COM3 before when the machine was working.
Yes I have tried a different USB cable but this made no difference.
Thank you for your comments.
Re: Prontoface not connecting
December 08, 2015 06:41PM
Any unknown devices appear in device manager when you plug in the controller?

There was a spate of controlers (well the clone ftdi chip on them) having their usb id's reset to 0000 so the system couldnt recognise which drivers to use

(google ftdigate for more info)

Failing that the ftdi chip on your controler seems to have died... Wich is a pain as its the small surface mount chip on the bottom.
Sorry, only registered users may post in this forum.

Click here to login