Welcome! Log In Create A New Profile


Fried stepper drivers!

Posted by T-Carbs 
Fried stepper drivers!
November 26, 2011 12:36AM
I've recently started trying to upload my software onto my reprap etc..
Before doing this I used the RAMPS 1.4 test code. At first both my extruder and z axis worked properly (up and down) however my X and Y just seemed to vibrate.
I've adjusted the pots and all this seemed to do was to make the vibrating more/less violent.
I've since switched the drivers around to test whether it wad the actual stepper motor or drivers that was the problem, and have successfully got the X and Y axis to move by using the drivers that worked on the Z and E. However... By doing so, I believe I may have fried the other two stepper drivers. I couldn't help but notice my connections were slightly loose and now my problem is the following.

When I start the test code, all axis and E just vibrate and all of their corresponding stepper drivers get VERY hot.
Have I fried these drivers? Would loose connectione have caused this problem? Or does the vibration suggest there is still life?
Otherwise it appears I might have to change my name to 'The Chef'

Any help is appreciated
Re: Fried stepper drivers!
November 26, 2011 02:25AM
Yes loose connections can cause a spark that destroys the drivers. If the motor just vibrates it probably means one coil is not being driven so one half of the driver is not working. You can test that theory by connecting one coil at a time.

Sorry, only registered users may post in this forum.

Click here to login