Welcome! Log In Create A New Profile


Stepper Motor loosing torque

Posted by fra.orolo 
Stepper Motor loosing torque
June 20, 2015 04:58PM

I built a Prusa i3 from a kit, which worked well for over a year.
But recently I found that my y-axis is loosing steps very often.

X and Y axis use identical Nema 17 motors and A4988 stepsticks.
The current was tuned to be minimal:
* Potis were turned left, so that motors would not run
* Then I searched the point when motors were starting to work and increased to
a safety margin of 15 degrees past this point
* both motors worked smooth and with low noise, getting about 40 degrees while printing for hours

But now the Y-motor failed, therefore I tried to increase current. This makes the motor louder, but apparently
does not generate more torque.

If I touch the X-Carriage, this pushes my hand away with significant force. If I test the Y-axis, It is loosing steps
already when I place a finger to the print plate. Mechanics of both carriages are still OK,
I swapped the stepper drivers on X and Y, but this didn't change anything. Still the Y-Motor has no force.
Electric parameters of both motors are still similar, about 12 Ohms on both coils.

Is it possible that the permanent magnets of stepper motors deplete over time?

Best regards
Re: Stepper Motor loosing torque
June 29, 2015 02:05AM
Have you also tried switching just the motors, to see if the problem is not somewhere in the cabling?

My guess would rather be that the problem is cable/connector related than it having to do with depleted magnets.
Sorry, only registered users may post in this forum.

Click here to login