Welcome! Log In Create A New Profile


Strange behaviour of G29 command

Posted by andrea.rimo 
Strange behaviour of G29 command
August 18, 2014 03:03PM
I have built and calibrated a 3DR printer. after a while I got interested into auto bed levelling using FSR so I bought 3. I connected them to RUMBA ZMIN endstop, configured the endstop to use the pull-up resistor and checked it worked by manually pushing on the print bed and confirming the FSR triggers the endstop. everything seems ok, so I enable auto_bed_levelling on the firmware.
at first It throws a compile error regarding some variables not defined (ABL_PROBE_PT_....). I found the variables in the NON delta configuration.h so I added those in the delta version of the configuration.h and it compiled.
after uploading, I homed (G28) and everything work as expected.
as soon as I sent G29 only one motor (the one connected to the Z motor driver) started to move down, the other 2 stayed still, throwing the effector completely out of the printer. it was as if it did not know it was dealing with a delta printer and just tried to move down the Z axis.
another strange behaviour was when sending G30. this time the effector went down correctly (all axis moving down) , hit the bed and stopped, setting the current Z to 196.3 (my Z_HOME_POS is 163.3). I was expecting it to set the Z to zero when hitting the bed...

Does anyone have a clue?

Re: Strange behaviour of G29 command
August 21, 2014 05:03AM
I have the same problem smiling smiley. Cause is that you have firmware that does not have autolevel configured for delta machine. As far as I can tell, this firmware has support. If you check function "run_z_probe" in "marlin_main.cpp", there should be an "#ifdef delta" in it. If it is not in your current software, then this is the cause.
Re: Strange behaviour of G29 command
August 21, 2014 05:18AM
Thank you for the answer. I have been looking into Marlin_main.cpp for a couple of days days now and I had the same suspect. then I did try the firmware you are linking, it's kind of working but i have to hook up the FSR output to the bed thermistor pin, which I would rather not, because with the ZMIN pin works just fine... now I have a working setup to experiment... I'll try to figure out if I have any improvement over the manual levelling and decide if I want to keep it or not....
I thing I'll keep this setup until the main MARLIN firmware incorporates the support for autoleveling on deltas.

Re: Strange behaviour of G29 command
August 22, 2014 04:18AM
Use Rich Cattell's software. It offers auto calibration, auto bed levelling and a very enhanced M666 functionality.



Re: Strange behaviour of G29 command
November 30, 2014 06:15PM
The problem is that Rich's and Johann's firmwares are both out of date. The actual Marlin firmware is beeing updated all the time. I have a bad feeling when the firmware for such a fast moving tech like 3d printing has not been touched in almost an year...
Sorry, only registered users may post in this forum.

Click here to login